Subject: RE: [MSEC] RE: Another MIKEY Question

From: "Elisabetta Carrara (KI/EAB)" <[email-masked]>
Date: Mon, 9 Feb 2004 14:39:02 +0100

Hi Steffen, 
the information is signaled in the certificate. 
Check for ex. appendix A of
ftp://ftp.rsasecurity.com/pub/pkcs/pkcs-1/pkcs-1v2-1.pdf

cheers
/E

> -----Original Message-----
> From: Steffen Fries [mailto:[email-masked]]
> Sent: den 9 februari 2004 10:44
> To: Elisabetta Carrara (KI/EAB)
> Cc: [email-masked]
> Subject: Re: [MSEC] RE: Another MIKEY Question
> 
> 
> Hi Elisabetta,
> 
> hope I don't bother you ... here is yet another question.
> 
> In the 08 version of MIKEY, it is recommended in section 4.2.5 
> to support also RSA OAEP. How is this signaled in the Envelope 
> Key payload (section 6.3)? Is there a new payload header to be 
> defined. Tight to this would be an error message signaling an 
> error, that a dedicated key encryption method is not supported.
> 
> Regards
> 	Steffen
> 

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

_______________________________________________
msec mailing list
[email-masked]
http://www.pairlist.net/mailman/listinfo/msec

---

From: "Steffen Fries" <[email-masked]>
Date: Thu, 12 Feb 2004 11:42:45 +0100

Hi Elisabetta,

thanks for the response. I'm not quit sure if this answers the 
question completely. Within PKCS#1 there is a list of possible 
supported encryption mechanisms. This is not a choice. This 
means, if a peer supports both methods, how does the remote 
peer know which to chose?

In contrast, the certificate also describes several possible 
algorithms for signatures, which is also not a choice. But 
here, MIKEY signals the chosen signature algorithm as part of 
the Signature payload (SIGN) in the S type. 

Regards
	Steffen

From:           	"Elisabetta Carrara (KI/EAB)" <[email-masked]>
To:             	"[email-masked]'" <[email-masked]>
Copies to:      	[email-masked]
Subject:        	RE: [MSEC] RE: Another MIKEY Question
Date sent:      	Mon, 9 Feb 2004 14:39:02 +0100

> > In the 08 version of MIKEY, it is recommended in section 4.2.5 to
> > support also RSA OAEP. How is this signaled in the Envelope Key
> > payload (section 6.3)? Is there a new payload header to be defined.
> > Tight to this would be an error message signaling an error, that a
> > dedicated key encryption method is not supported.
> > 
> > Regards
> > 	Steffen
> > 
> 
> This communication is confidential and intended solely for the
> addressee(s). Any unauthorized review, use, disclosure or distribution
> is prohibited. If you believe this message has been sent to you in
> error, please notify the sender by replying to this transmission and
> delete the message without disclosing it. Thank you.
> 
> E-mail including attachments is susceptible to data corruption,
> interruption, unauthorized amendment, tampering and viruses, and we
> only send and receive e-mails on the basis that we are not liable for
> any such corruption, interception, amendment, tampering or viruses or
> any consequences thereof.
> 
>