Subject: [MSEC] RE: MIKEY Question

From: "Elisabetta Carrara (KI/EAB)" <[email-masked]>
Date: Tue, 3 Feb 2004 10:40:23 +0100

Steffen,
MIKEY is in the Editor queue. 
I hope that the addition can be fixed during the 
Authors' 48 Hours. Can Ran or Thomas confirm?

cheers
/Elisabetta

> -----Original Message-----
> From: Steffen Fries [mailto:[email-masked]]
> Sent: den 3 februari 2004 08:47
> To: Elisabetta Carrara (KI/EAB)
> Cc: [email-masked]
> Subject: RE: MIKEY Question
> 
> 
> Hi Elisabetta,
> 
> so, solving the problem is just adding the two parameters to 
> the SRTP policy section, thats good. Will you compile an 
> updated version of the MIKEY draft? 
> 
> Regards
> 	Steffen
> 
> 
> From:           	"Elisabetta Carrara (KI/EAB)" 
> <[email-masked]>
> To:             	"[email-masked]'" 
> <[email-masked]>
> Copies to:      	"[email-masked]'" 
> <[email-masked]>
> Subject:        	RE: MIKEY Question
> Date sent:      	Mon, 2 Feb 2004 19:30:49 +0100 
> 
> > Hi Steffen, 
> > the signalling you are looking for should be in the security 
> > protocol policy definition. The draft corrently specifies the 
> > policy for SRTP, and indeed explicit signalling is missing.
> > 
> > We have assumed that the default values should be used, as 
> > specified in the SRTP draft. However, as you noted, we were
> > not clear; explicit signalling (the two lenght parameters) 
> > should be added within the SRTP policy parameter section.
> > 
> > Many thanks for pointing it out,
> > cheers
> > /Elisabetta
> > 
> > 
> > 
> > 
> > > -----Original Message-----
> > > From: Steffen Fries [mailto:[email-masked]]
> > > Sent: den 2 februari 2004 10:42
> > > To: Elisabetta Carrara (KI/EAB)
> > > Cc: [email-masked]
> > > Subject: MIKEY Question
> > > 
> > > 
> > > Hi Elisabetta,
> > > 
> > > I've got some questions to MIKEY especdially regarding the 
> > > length of used keys:
> > > 
> > > - MIKEY allows to transmit either the TGK or the TEK. If the
> > >   TEK is transmitted directly, the length is provided. If the
> > >   TGK is transmitted, the length of the TGK is transmitted. How is
> > >   the length of the TEK determined on both sides, when a 
> PRF is used
> > >   to derive the TEK from the transmitted TGK? There are different
> > >   length of the TEK mention in MIKEY (128, 192, 256)
> > > 
> > > - MIKEY allows either to transmit a salting key or to derive
> > >   the salting key from the TGK. In the latter case, how is it
> > >   signaled that the salt is derived and which length of the
> > >   salt is to be used?
> > > 
> > > Regards
> > > 	Steffen
> > > -----------------------------------------------------------
> > >     Steffen Fries,     Siemens AG, CT IC 3	
> > >     Otto-Hahn-Ring 6,  D-81730 Munich, Germany 
> > >     Phone:  (+49) 89 / 636-53403,    
> > >     Fax  :  (+49) 89 / 636-48000
> > >     Email:  [email-masked]
> > > -----------------------------------------------------------
> > > 
> > > 

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

_______________________________________________
msec mailing list
[email-masked]
http://www.pairlist.net/mailman/listinfo/msec

---

From: "Steffen Fries" <[email-masked]>
Date: Wed, 04 Feb 2004 11:01:30 +0100

Hi Elisabetta,

I've got another question, just for clarification. In section 
4.4 of the MIKEY draft the following is stated:
"However, the SSRC is not sufficient. For the retrieval of the 
Data SA from MIKEY, it is RECOMMENDED that the MIKEY 
implementation support a lookup using destination network   
address and port together with SSRC."

What would be a scenario, where the network address and the 
port is not suffcient and the SSRC is actually needed?

Regards
	Steffen