Subject: [MSEC] RE: Another MIKEY Question

From: "Elisabetta Carrara (KI/EAB)" <[email-masked]>
Date: Thu, 5 Feb 2004 13:36:50 +0100

Hi Steffen,
the RTP spec says that participants in an RTP session 
may share the same destination transport address, but 
they would use the (unique) SSRC to demultiplex. 
In particular, the SSRC is needed in sessions with more 
than one participant/data source/listener. Each listener 
and data source uses its own SSRC, and the SA may be 
different for each.

Cheers
/Elisabetta

> -----Original Message-----
> From: Steffen Fries [mailto:[email-masked]]
> Sent: den 4 februari 2004 11:02
> To: Elisabetta Carrara (KI/EAB)
> Cc: [email-masked]
> Subject: Another MIKEY Question
> 
> 
> Hi Elisabetta,
> 
> I've got another question, just for clarification. In section 
> 4.4 of the MIKEY draft the following is stated:
> "However, the SSRC is not sufficient. For the retrieval of the 
> Data SA from MIKEY, it is RECOMMENDED that the MIKEY 
> implementation support a lookup using destination network   
> address and port together with SSRC."
> 
> What would be a scenario, where the network address and the 
> port is not suffcient and the SSRC is actually needed?
> 
> Regards
> 	Steffen
> 
> -----------------------------------------------------------
>     Steffen Fries,     Siemens AG, CT IC 3	
>     Otto-Hahn-Ring 6,  D-81730 Munich, Germany 
>     Phone:  (+49) 89 / 636-53403,    
>     Fax  :  (+49) 89 / 636-48000
>     Email:  [email-masked]
> -----------------------------------------------------------
> 
> 

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

_______________________________________________
msec mailing list
[email-masked]
http://www.pairlist.net/mailman/listinfo/msec

---

From: "Steffen Fries" <[email-masked]>
Date: Thu, 05 Feb 2004 14:02:43 +0100

Hi Elisabetta,

hm, okay, I did not though on a multicast case.

Just for my curiousity, how do you get the SSRC in your 
implementation for the RTP connection? Using the common RTP 
stacks, there is no option to get the SSRC before actually 
opening an RTP channel nor is there an interface to set the 
SSRC from outside. Did you adapt the RTP stack to do this?

Regards
	Steffen

From:           	"Elisabetta Carrara (KI/EAB)" <[email-masked]>
To:             	"[email-masked]'" <[email-masked]>
Copies to:      	[email-masked]
Subject:        	RE: Another MIKEY Question
Date sent:      	Thu, 5 Feb 2004 13:36:50 +0100 

> > "However, the SSRC is not sufficient. For the retrieval of the Data
> > SA from MIKEY, it is RECOMMENDED that the MIKEY implementation
> > support a lookup using destination network   address and port
> > together with SSRC."
> >

---

From: "Steffen Fries" <[email-masked]>
Date: Mon, 09 Feb 2004 10:44:12 +0100

Hi Elisabetta,

hope I don't bother you ... here is yet another question.

In the 08 version of MIKEY, it is recommended in section 4.2.5 
to support also RSA OAEP. How is this signaled in the Envelope 
Key payload (section 6.3)? Is there a new payload header to be 
defined. Tight to this would be an error message signaling an 
error, that a dedicated key encryption method is not supported.

Regards
	Steffen