Subject: [MSEC] RE: further MIKEY question

From: "Elisabetta Carrara (KI/EAB)" <[email-masked]>
Date: Fri, 4 Jun 2004 16:39:57 +0200

Hi Steffen,

> 1. In MIKEY the key validity period may be signaled either via
>    the MKI or via the key lifetime directly (MIKEY Section
>    6.13). This may be done by setting the KV to either 1 or 2.
>    SRTP allows also the simultaneous use of MKI and lifetime
>    values. (section 8.1, last paragraph).
>    How is this signaled in MIKEY?

it cannot, we included a limited set of SRTP options in MIKEY. 
Extensions can be added if people are interested. 

> 2. Using the key lifetime as described in MIKEY section 6.14, 
>    the sender may include a "Sequence number, index, timestamp,
>    or other start value that the security protocol uses to
>    identify the start position of the key usage". How does the
>    MIKEY initiator signale how the validity data is to be
>    interpreted? Is this done somehow out of band or belongs to a
>    policy?

The security protocol has to define its interpretation. 
Currently in the MIKEY profile for SRTP (see last paragraph of 6.14), 
it is either the 6 byte index or the MKI. 

Hope this answers your questions,
cheers

_______________________________________________
msec mailing list
[email-masked]
http://six.pairlist.net/mailman/listinfo/msec

---

From: "Steffen Fries" <[email-masked]>
Date: Fri, 04 Jun 2004 16:47:47 +0200

Hi Elisabetta,

oaky, that helps.
Thanks  a lot

Ciao
	Steffen

From:           	"Elisabetta Carrara (KI/EAB)" <[email-masked]>
To:             	"[email-masked]'" <[email-masked]>
Copies to:      	[email-masked]
Subject:        	RE: further MIKEY question
Date sent:      	Fri, 4 Jun 2004 16:39:57 +0200 

> >    the sender may include a "Sequence number, index, timestamp, or
> >    other start value that the security protocol uses to identify the
> >    start position of the key usage". How does the MIKEY initiator
> >    signale how the validity data is to be interpreted? Is this done
> >    somehow out of band or belongs to a policy?
>