Subject: [MSEC] MIKEY: General Extension Payload

From: Gerhard Strangar <[email-masked]>
Date: Wed, 09 Jun 2004 02:43:29 +0200

Hello,

I wondered if the General Extension Payload is mandatory for an
I_MESSAGE or not. The example message in MIKEY Draft 8 do not contain a
General Extension Payload. This makes me think it's optional.

But [1] says:

| The possibility to support multiple key management protocols may,
| unless properly handled, introduce bidding-down attacks.
| Specifically, a man-in-the-middle could "peel off" cryptographically
| strong offers (deleting the key management lines from the message),
| leaving only weaker ones as the Responder's choice. To avoid this,
| the list of identifiers of the proposed key management protocols MUST
| be authenticated. The authentication MUST be done separately by each
| key management protocol.

This makes me think it's mandatory.
Or does it mean that the General Extension Payload is mandatory if MIKEY
is used in SDP, but not if used somewhere else?

[1] Arkko, J., Carrara, E., Lindholm, F., Naslund, M., and
    Norrman, K., "Key Management Extensions for SDP and RTSP",
    draft-ietf-mmusic-kmgmt-ext-11.txt

-- 
 * Origin: (2:2480/8057.2)

_______________________________________________
msec mailing list
[email-masked]
http://six.pairlist.net/mailman/listinfo/msec

---

From: "Elisabetta Carrara (KI/EAB)" <[email-masked]>
Date: Wed, 9 Jun 2004 11:00:58 +0200

Hi Gerhard,

> General Extension Payload. This makes me think it's optional.

yes, it is optional in MIKEY

> But [1] says:
> 
> | The possibility to support multiple key management protocols may, |
> unless properly handled, introduce bidding-down attacks.
> | Specifically, a man-in-the-middle could "peel off" 
> cryptographically |
> strong offers (deleting the key management lines from the message), |
> leaving only weaker ones as the Responder's choice. To avoid 
> this, | the
> list of identifiers of the proposed key management protocols MUST | be
> authenticated. The authentication MUST be done separately by 
> each | key
> management protocol.
> 

> is used in SDP, but not if used somewhere else?

yes, that is correct.

Cheers