Subject: [MSEC] Basic MIKEY/SRTP question

From: <[email-masked]>
Date: Mon, 4 Oct 2004 16:17:16 -0400

Hi all,

I am new to MIKEY, was reading the RFC and have the following basic questions. 

Let say for a peer-to-peer voice call using SIP, suppose the peers want to protect the audio using SRTP. So, my question is

1. There are two SRTP streams, one in each direction, is that right?
2. I assume the above, so MIKEY is used to set up two crypto contexts for the two streams? or they share the same crypto contexts?
3. Is this achieved by having the initiator putting two crypto session IDs in the "CS ID map info" (Section 6.1.1 SRTP ID). Is it true that the initiator will put his/her SSRC and ROC in one of the map info, and responder filling the other? 

Just want to clarify these. Any help is much appreciated.

P.S. Page 34, CS ID map info is said to have 16 bits, should it be "variable"? and for SRTP, should it be multiples of (8+32+32) bits? Or am I misunderstanding something?

Thanks!

- Tat
_______________________________________________
msec mailing list
[email-masked]
http://six.pairlist.net/mailman/listinfo/msec

---

From: "Elisabetta Carrara (KI/EAB)" <[email-masked]>
Date: Tue, 5 Oct 2004 16:37:58 +0200

Hi Tat!

> 
> Let say for a peer-to-peer voice call using SIP, suppose the 
> peers want to protect the audio using SRTP. So, my question is
> 

yes

> 2. I assume the above, so MIKEY is used to set up two crypto 
> contexts for the two streams? or they share the same crypto contexts?

the "SRTP crypto context" are different as there are things in them that are
stream-dependent, e.g. the replay list.
You mean security parameters and keys from MIKEY. They will be 
typically different, and I'm thinking about the keys mainly. Please
give a look at section 6.1 in draft-ietf-mmusic-kmgmt-ext-11.txt,
for the use within SDP. 

> 3. Is this achieved by having the initiator putting two 
> crypto session IDs in the "CS ID map info" (Section 6.1.1 
> SRTP ID). Is it true that the initiator will put his/her SSRC 
> and ROC in one of the map info, and responder filling the other? 

yes, for example

> P.S. Page 34, CS ID map info is said to have 16 bits, should 
> it be "variable"? and for SRTP, should it be multiples of 
> (8+32+32) bits? Or am I misunderstanding something?

you are right. Thanks for spotting it!

Cheers
/E