Subject: [MSEC] small MIKEY question - Security policy payload

From: <[email-masked]>
Date: Fri, 12 Nov 2004 17:10:38 -0500

Hi all,

I have a question regarding the Security policy payload (SP) of the MIKEY protocol. In the I_MESSAGE, there is zero or more Security Policy payloads. Suppose the Initiator does not include any SP payload (so the default security policy will be used), in the CS ID map info in the header, do we still set the policy no. field to zero for all CS? 

Thanks!

BR
- Tat
_______________________________________________
msec mailing list
[email-masked]
http://six.pairlist.net/mailman/listinfo/msec

---

From: "Fredrik Lindholm (KI/EAB)" <[email-masked]>
Date: Mon, 15 Nov 2004 14:33:20 +0100

Hi Tat,

you are correct in setting the "policy no" to the same value for 
all CSs (zero is a good choice). For consistency, you should 
also include one "empty" SP header with "Policy no" zero (that 
is if you set "policy no" to zero in the first place), 
"Prot type" to the value of the protocol you are using (of course 
today you can only chose SRTP, 0), and finally "Policy param 
length" to 0 (hence no SP "payload"/parameters should be included). 
The purpose of the "empty" SP header is to indicate the protocol 
profile from which the default values are used.

BR,
Fredrik

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of 
> [email-masked]
> Sent: den 12 november 2004 23:11
> To: [email-masked]
> Subject: [MSEC] small MIKEY question - Security policy payload
> 
> 
> Hi all,
> 
> I have a question regarding the Security policy payload (SP) 
> of the MIKEY protocol. In the I_MESSAGE, there is zero or 
> more Security Policy payloads. Suppose the Initiator does not 
> include any SP payload (so the default security policy will 
> be used), in the CS ID map info in the header, do we still 
> set the policy no. field to zero for all CS? 
> 
> Thanks!
> 
> BR
> - Tat