Subject: [MSEC] IANA question to TESLA bootstrapping in MIKEY

From: "Steffen Fries" <[email-masked]>
Date: Thu, 09 Dec 2004 13:20:50 +0100

Hi Ran,

at the time being we are about writing the IANA section in the 
TESLA bootstrapping draft. One question that came up is the 
following: The current draft provides means to transport the 
TESLA policy between the media sender and the media receiver. We 
adopted the default values for MAC and PRF from the SRTP TESLA 
integration draft, which is HMAC-SHA1. Do you feel that it is 
necessary to leave the PRF and MAC function signaling in the 
TESLA policy open in terms of having IANA handling the 
registration of the further mechanisms or should we fix the 
values as provided in the draft?

Regards
	Steffen

-----------------------------------------------------------
    Steffen Fries,     Siemens AG, CT IC 3	
    Otto-Hahn-Ring 6,  D-81730 Munich, Germany 
    Phone:  (+49) 89 / 636-53403,    
    Fax  :  (+49) 89 / 636-48000
    Email:  [email-masked]
-----------------------------------------------------------

_______________________________________________
msec mailing list
[email-masked]
http://six.pairlist.net/mailman/listinfo/msec

---

From: canetti <[email-masked]>
Date: Thu, 9 Dec 2004 14:35:16 -0500 (EST)

Steffen, my personal impression is that the most important thing is to be
compatible with SRTP TESLA, since this is today the main poteintial venue
for using TELSA with MIKEY. So I'd go for the fixed version.
What do others think?

Ran

---

From: Mark Baugher <[email-masked]>
Date: Thu, 9 Dec 2004 11:54:36 -0800

Off the top of my head, I can't think of any key management protocols 
that don't allow algorithms to be upgraded for a security protocol.  
Otherwise, what happens when the default algorithm is compromised?

Mark

---

From: "Steffen Fries" <[email-masked]>
Date: Fri, 10 Dec 2004 13:14:04 +0100

Hi Mark,

to be more generic you are right. It might also be the case that 
there exist a different usecase for bootstarpping TESLA with 
MIKEY, which requires a different PRF and MAC as the ones 
currently defined.

Regards
	Steffen

Copies to:      	[email-masked], [email-masked],
       	Steffen Fries <[email-masked]>
From:           	Mark Baugher <[email-masked]>
Subject:        	Re: [MSEC] Re: IANA question to TESLA bootstrapping in MIKEY
Date sent:      	Thu, 9 Dec 2004 11:54:36 -0800
To:             	canetti <[email-masked]>

> > Steffen, my personal impression is that the most important thing is
> > to be compatible with SRTP TESLA, since this is today the main
> > poteintial venue for using TELSA with MIKEY. So I'd go for the fixed
> > version. What do others think?
> >
> > Ran
> >
> >> following: The current draft provides means to transport the TESLA
> >> policy between the media sender and the media receiver. We adopted
> >> the default values for MAC and PRF from the SRTP TESLA integration
> >> draft, which is HMAC-SHA1. Do you feel that it is necessary to
> >> leave the PRF and MAC function signaling in the TESLA policy open
> >> in terms of having IANA handling the registration of the further
> >> mechanisms or should we fix the values as provided in the draft?
> >>
> >> Regards
> >> 	Steffen
> >>
> >>
> >>