Subject: [MSEC] Application layer multicast security protocol

From: sampreeth ramavana <[email-masked]>
Date: Wed, 24 Aug 2011 11:05:47 +0530

Hi All,

Is there any multicast security protocol that can be implemented in
the application layer?

I was seeing the GDOI protocol was mainly talking about implementing
using the IPSec at the IP layer. Can GDOI protocol also be useful if
implemented at application layer.

Thanks,
Sampreeth

---

From: Adrian-Ken Rueegsegger <[email-masked]>
Date: Wed, 24 Aug 2011 08:54:24 +0200

Hi Sampreeth,

> implemented at application layer.

GDOI can be extended to provide key material for other protocols. Mark,
Sheela and I wrote a draft (which has since expired) which specifies the
usage of GDOI with SRTP [1].

Regards,
Adrian

[1] - http://tools.ietf.org/html/draft-ietf-msec-gdoi-srtp

---

From: "Sheela Rowles (sheela)" <[email-masked]>
Date: Wed, 24 Aug 2011 07:10:40 -0700

Added Dan Wing since the GDOI/SRTP draft was dropped because Dan Wing
had an alternative draft.  Sorry can't remember the details now.

Sheela

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Adrian-Ken Rueegsegger
Sent: Tuesday, August 23, 2011 11:54 PM
To: sampreeth ramavana
Cc: [email-masked]
Subject: Re: [MSEC] Application layer multicast security protocol

Hi Sampreeth,

Regards,
Adrian

[1] - http://tools.ietf.org/html/draft-ietf-msec-gdoi-srtp
_______________________________________________
MSEC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/msec

---

From: "Lewis Adam-CAL022" <[email-masked]>
Date: Wed, 24 Aug 2011 08:14:59 -0400

You can also take a look at MIKEY (rfc3830).

MIKEY can bootstrap SRTP/SRTCP, but it's really a very generic key
transport protocol that transports a crypto key (could be a group key)
from point A to point B.  Your application can use the key as it sees
fit.  

adam

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Adrian-Ken Rueegsegger
Sent: Wednesday, August 24, 2011 1:54 AM
To: sampreeth ramavana
Cc: [email-masked]
Subject: Re: [MSEC] Application layer multicast security protocol

Hi Sampreeth,

Regards,
Adrian

---

From: Mark Baugher <[email-masked]>
Date: Wed, 24 Aug 2011 10:28:14 -0700

Yes, GDOI, like ISAKMP, is intended to support a variety of applications
in user space and in the kernel.  The current open source implementation
is closely tied to IPsec, however, and changes will need to be made to
extend it beyond IPsec.

Mark

---

From: sampreeth ramavana <[email-masked]>
Date: Thu, 25 Aug 2011 15:21:20 +0530

Hi All,

Thanks for all the responses. SRTP along with MIKey/GDOI seems to fit
well. Are there any open source implementations on MIKey?

Also is SRTP tested if it is useful for streaming media. Am asking
this coz most of the references to SRTP were for VoIP applications.

Thanks,
Sampreeth

-- 
--------------------------
SAMPREETH
--------------------------