Subject: [netmod] yang-00, ordered-by statement

From: Andy Bierman <[email-masked]>
Date: Sat, 31 May 2008 09:22:25 -0700

Hi,

Another partially documented YANG feature is the 'ordered-by' statement.
As with many other features, the draft needs to specify what happens
outside the narrow scope of the intended usage (e.g., 'key' and 'insert'
attributes are only discussed appearing in <edit-config>).

Does the <get> operation need to support these in filters? (No.)
These attributes need to be removed from the data model and
turned into verbs, similar to the NETCONF 'operation' attribute.
In non-YANG data models, 'key' and 'insert' would be part
of the data being edited, not encoded verbs to change the
<edit-config> operation.  This should be documented.

What does 'ordered-by user;' mean for read-only data or
RPC input or notification content?  Can the manager create user-ordered
data unsorted, or is the PDU order always the sorted order for 'create'?

Andy

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Phil Shafer <[email-masked]>
Date: Sat, 31 May 2008 19:40:19 -0400

>attributes are only discussed appearing in <edit-config>).

Are you saying just that we need to say "these attributes are only
meaningful in the following contexts", or is something more needed?
By saying what they mean in certain contexts, we didn't see a need
to list all the contexts in which they were meaningless, nor did
we say "these are illegal everywhere else" since that makes issues
with future features that want to use them in other contexts.

>Does the <get> operation need to support these in filters? (No.)

Are you wanting an exhaustive list of "thou shalt not"s?

>turned into verbs, similar to the NETCONF 'operation' attribute.

"turned into verbs" like "insert"?  Or you're saying you'd
rather see "op='insert' insert='before' key='whatever'"?

><edit-config> operation.  This should be documented.

YANG doesn't have much to say about non-YANG models.

>data unsorted, or is the PDU order always the sorted order for 'create'?

These are great questions and these are definitely the sorts of
details we need to document in the YANG spec.

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Sat, 31 May 2008 16:53:51 -0700

> meaningful in the following contexts", or is something more needed?

That could work.
I agree with you that we should not over-specify YANG.
We need more reviews from non-authors to determine if
all the text is clear enough to write code from.

> Are you wanting an exhaustive list of "thou shalt not"s?

No -- just point out the way it is supposed to work.
Maybe an implementor will think (because RFC 4741 says so)
that these XML attributes included in the <config> content
are actually part of the <config> content.  That would
be wrong of course.  The operation attribute and
these new attributes do not get saved in the config database
at all.  IMO, that is not obvious.

Andy

Andy