Subject: Re: [netmod] list keys

From: Gerhard Muenz <[email-masked]>
Date: Fri, 09 May 2008 11:11:51 +0200

Hi Ladislav,

As your FlowMon probe is supporting Netflow, you might be interested in
the IPFIX standardization activities.
Do you know about the current IPFIX WG charter item concerning the
configuration of IPFIX devices?
As we are also using Netconf and YANG, you might be interested in
following the discussion and bring in your ideas:
http://tools.ietf.org/wg/ipfix/
http://tools.ietf.org/html/draft-muenz-ipfix-configuration-04

Regards,
Gerhard

[email-masked] wrote:
> Date: Thu, 08 May 2008 10:08:58 +0200
> From: Ladislav Lhotka <[email-masked]>
> Subject: [netmod] list keys
> To: NETMOD Working Group <[email-masked]>
> Message-ID: <1210234139.14514.33.camel@missotis>
> Content-Type: text/plain
> 
> Hi,
> 
> as an exercise, I converted manually the RELAX NG schema that we are
> using for our FlowMon probe to YANG. It went quite smoothly, the result
> is here:
> http://www.yang-central.org/twiki/pub/Main/YangExamples/flowmon.yang
> 
> I encountered two problems related to list keys, one minor and one more
> serious:
> 
> 1. In the following list
> 
> list interface {
>   key ifNumber;
>   leaf ifNumber {
>     type uint8 {
>       range 0..3;
>     }
>   }
>   choice monitoring-mirroring {
>     case monitoring-interface {
>       ...                
>     }
>     case mirroring-interface {
>       ...
>     }
>   }
> }
> 
> I actually want to use the "monitoring-interface" case for ifNumber 0 or
> 1 and the other case for ifNumber 2 or 3. I could move ifNumber under
> the choice statement and make the distinction in each of the case
> statements - but is it possible with ifNumber serving as the list key?
> 
> 2. In this list
> 
> list filterCondition {
>   ordered-by user;
>   choice filter-conditions {
>     leaf ipVersion {
>       type inet:ip-version;
>     }
>     container addressRange {
>       leaf startAddress {
>         mandatory true;
>         type inet:ip-address;
>       }
>       leaf endAddress {
>         mandatory true;
>         type inet:ip-address;
>       }
>       container matchAgainst {
>         uses address-choice;
>       }
>     }
>   }
>   leaf ifNumber {
>     type uint8 {
>       range 0..1;
>     }
>   }
> }
> 
> there is essentially no way how to define the mandatory key. With deep
> keys, it would be probably possible to use all contained leafs but IMO
> it makes little sense anyway. I propose to drop the requirement to
> define a key for lists ordered-by user. If the key is not defined (as it
> is here) the system should allocate internally ordinal numbers to list
> items that can be used for their addressing.
> 
> Lada
> 

-- 
Dipl.-Ing. Gerhard Münz
Computer Networks and Internet
Wilhelm Schickard Institute for Computer Science
University of Tuebingen
Sand 13 (Room B309), D-72076 Tuebingen, Germany
Phone:  +49 7071 29-70534       Fax: +49 7071 29-5220
E-mail: [email-masked]
WWW:    http://net.informatik.uni-tuebingen.de/~muenz

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 09 May 2008 11:22:49 +0200

Hi Gerhard,

yes, I looked at it briefly, but haven't had time yet to do a more
detailed comparison.

Cheers, Lada

PS. FlowMon now also exports IPFIX. :-)

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C