Subject: [netmod] regexp for domain name

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 07 Jul 2008 15:12:35 +0200

Hi,

the regexp for domain-name in draft-schoenw-netmod-yang-types-00 is 

'([\p{L}\p{N}]+\.)*[\p{L}\p{N}]'

The obvious problem is that it should allow hyphens.

Also, the class \p{L} stands for Unicode letters whereas RFC 1034 only
allows the 52 ASCII letters. Or has it been extended to Unicode letters?

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 14 Jul 2008 11:11:01 +0200

> allows the 52 ASCII letters. Or has it been extended to Unicode letters?

I will change this patter to read as follows:

	'([a-zA-Z0-9\-]+\.)*[a-zA-Z0-9\-]+'

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 14 Jul 2008 15:45:35 +0200

> 	'([a-zA-Z0-9\-]+\.)*[a-zA-Z0-9\-]+'

According to RFC 1034 it should be

([a-zA-Z][a-zA-Z0-9\-]*[a-zA-Z0-9]\.)*[a-zA-Z][a-zA-Z0-9\-]*[a-zA-Z0-9]

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 14 Jul 2008 16:00:46 +0200

On Mon, Jul 14, 2008 at 03:45:35PM +0200, Ladislav Lhotka wrote:
> Juergen Schoenwaelder p????e v Po 14. 07. 2008 v 11:11 +0200:
> > 

Yes, even better. I have fixed this in the .xml sources but it won't
be in the next ID which is already sitting in the ID publication
queue.

/js

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 14 Jul 2008 17:21:13 +0200 (CEST)

> ([a-zA-Z][a-zA-Z0-9\-]*[a-zA-Z0-9]\.)*[a-zA-Z][a-zA-Z0-9\-]*[a-zA-Z0-9]

Poor 3com.com (just one example).  What are the rules that are really
used?

/martin

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 14 Jul 2008 17:40:57 +0200

> Poor 3com.com (just one example).  What are the rules that are really

You are right, RFC 1123 relaxed this (Sec 2.1) and allowed first
character to be either letter or digit. So hopefully the final version
is
    '([a-zA-Z0-9][a-zA-Z0-9\-]*[a-zA-Z0-9]\.)*'
+   '[a-zA-Z0-9][a-zA-Z0-9\-]*[a-zA-Z0-9]'

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C