Subject: [netmod] Date Time formats

From: Balazs Lengyel <[email-masked]>
Date: Tue, 22 Jul 2008 12:14:45 +0200

Hello,
Will the yang:date-and-time and the XSD:datetime result in the same XML on the wire?
Balazs
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 22 Jul 2008 12:55:41 +0200

> Will the yang:date-and-time and the XSD:datetime result in the same

In most cases yes.

However, dateTime allows negative years and there is a note in [1]
that the interpretation of negative years might change in the
future. RFC 3339 does not allow negative years and I think this
restriction is OK to accept for our purposes.

[1] http://www.w3.org/TR/xmlschema-2/#dateTime

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 22 Jul 2008 18:51:28 +0200

I forgot. Sorry.
Balazs

Juergen Schoenwaelder wrote:
> On Tue, Jul 22, 2008 at 03:57:50PM +0200, Balazs Lengyel wrote:
>> Hello Jurgen,
>> I think this could be mentioned in the draft.
>> Balazs
>>
>> Juergen Schoenwaelder wrote:
> Any reason not to CC the WG?
> 
> /js
> 

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 22 Jul 2008 21:48:47 +0200

> I think this could be mentioned in the draft.

This makes sense. I will add the following statement:

    The date-and-time type is compatible with the dateTime XML
    schema type except that dateTime allows negative years
    which are not allowed by RFC 3339.

/js