Subject: [netmod] config-stmt on choice and/or case

From: Andy Bierman <[email-masked]>
Date: Sun, 27 Jul 2008 13:56:39 -0700

Hi,

Remind me again why we don't need config-stmt within choice-stmt
or case-stmt?

It seems to make sense to me.  Without it, you cannot control
a choice between multiple reusable case arm contents (via uses).

I want to be able to define building blocks like InetAddress
or maybe ConnectionEndpoint or whatever, and not declare any
config-stmts at all in the groupings.  Instead an ancestor
of the uses-stmt is expected to provide the config-stmt.

It would be tedious to read and write all the uses refinement
statements, rather than use the mechanism already in place
for this very problem.

Andy

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 28 Jul 2008 10:26:12 +0100 (IST)

> Remind me again why we don't need config-stmt within choice-stmt

I don't see any reasons for not allowing config under choice and
case.  If no one objects, I'll make this change.

/martin