Subject: [netmod] NETMOD Life-cycle document

From: Andy Bierman <[email-masked]>
Date: Sat, 02 Aug 2008 12:52:49 -0700

Hi,

The WG keeps mentioning that there is a need to
define the YANG change control rules, but so far, not much.
IMO, this is a fairly critical document for the
usefulness of YANG as a standard.

It also seems that the needs of interoperability and
the needs of vendors to 'be flexible' are moving
towards a head-on collision at some point.
One way to deal with that is a separate document
defining how YANG modules are used in IETF documents.

The entire module life-cycle needs to be addressed for
IETF purposes.  For example, how will interoperability
be measured for the purposes of standards track advancement?
What is allowed to change over time?
What is considered a change? (e.g., extension usage change ignored?)
What clauses MUST and SHOULD be present?
Are there any data modeling BCPs that should be followed?

Is there a need for this document, and if so, when is it needed?
IMO, some of the assumptions about import-by-revision may be
wrong, based on this document, so sooner would be better than later.

The language itself does not really need to define how
modules are allowed to change over time.  Proprietary modules
might change in arbitrary ways, but that is up to the vendor.
It may be faster to reach consensus on the YANG draft
if it does not contain all the change control rules.

Andy

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Sat, 02 Aug 2008 23:25:41 +0200 (CEST)

> defining how YANG modules are used in IETF documents.

I like this approach.  But I will have to think some more.  We all
know that regardless of which upgrade rules we add, some vendors will
break them for their vendor-specific modules.  That happens with SNMP
modules all the time.

SomeMost vendors want to be be good citizens, but they can
follow the IETF rules.

/martin

---

From: Andy Bierman <[email-masked]>
Date: Sat, 02 Aug 2008 17:13:49 -0700

> SomeMost vendors want to be be good citizens, but they can

That is why I think keeping as many CLRs out of
the official language specification is a good idea.

It also divides complexity and allows the language spec
to remain more stable during the early years when the
change control rules for YANG are not as well understood
as the basic constructs themselves.

I came up with a lot of specifics while writing yangdiff,
but I'll save the details for later.  Sometimes, simply recognizing
semantic equivalence is not so easy.

Andy