Subject: [netmod] conclusion on mandatory in an augment?

From: Andy Bierman <[email-masked]>
Date: Wed, 20 Aug 2008 12:08:37 -0700

Hi,

Can we wrap up this detail?

It is hard to describe, but mandatory=true is needed
when a local 'uses' and 'augment' are added together at
the same time.

By design, certain properties such as mandatory, config,
and even default, can be left out of groupings,
and added in with uses refinements or by inherited
the property from the parent of the 'uses' (i.e., late binding).

It should be an error to augment an existing object
with a mandatory node.  This cannot be enforced within
a single YANG module however.

It should also be an error to ever augment another XML namespace
with a mandatory node.

Andy

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 20 Aug 2008 21:29:05 +0200 (CEST)

> It should also be an error to ever augment another XML namespace

I agree with this.

Before we can add this, we have to define the term "mandatory node"
(leaf with mandatory true, list/leaf-list with min-elements > 0 etc)
as we have discussed earlier.  The problem with this term is that it's
confusing b/c we already talk about mandatory leafs.  Can anyone think
of a better term?

/martin