Subject: Re: [netmod] belongs-to

From: Phil Shafer <[email-masked]>
Date: Fri, 22 Aug 2008 15:28:15 -0400

Andy Bierman writes:
>In the example above, the type is the YANG int32.
>If you do something dumb (which I think is not allowed
>anyway) like reusing the names of built-in types,
>then you need to use the prefix on that type,
>because the YANG built-in type names take precedence.

Juergen was right.  We pitched the idea of adding new builtin types
in the future.  Without this, there's no need to require a prefix,
since they will never be a conflict.

Thanks,
 Phil
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Andy Bierman <[email-masked]>
Date: Fri, 22 Aug 2008 12:49:46 -0700

> since they will never be a conflict.

there is also the yang-version statement available
to avoid any conflict in the future.

the only changes to the SMI were to add 64 bit numbers.
YANG already has 64 bit numbers and floating point.

If I see a prefix, that means the definition came from
a YANG module.  No module actually contains int32
(or any built-in type), so why invent some hack prefix value
that means 'the non-existent YANG built-in types module'?

I actually do not see a problem with YANG defining its
own context for prefix handling, within a YANG file.
But within straight XML (YIN, XSLT, NETCONF PDU),
the tool must generate prefixes according to the
rules for that context.  A missing prefix is just one
corner case out of several.

>  Phil

Andy