Subject: [netmod] augment and mandatory

From: Andy Bierman <[email-masked]>
Date: Wed, 13 Aug 2008 18:43:09 -0700

Hi,

I've been thinking about this issue some more.

There is nothing wrong with a nested augment-stmt
adding mandatory nodes to some data structure.
The obvious use-case is augmenting an expanded uses-stmt
object.

However, an external augment (i.e., augmenting a
different XML namespace) MUST NOT contain any mandatory
objects.  This breaks backward compatibility.

Also, any augment-stmt with a 'when' clause configured
MUST NOT contain any mandatory nodes.  A mandatory
node must always be provided by the user.  By definition,
the when clause is not 'always'.

Andy

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Fri, 15 Aug 2008 16:43:32 +0200

Hi Andy,

I support both cases you mention since they are 
useful to avoid misuse and support backward 
compatibility.

An augment must not break a client that doesn't 
understand the augmentation.

Cheers, 
Mehmet

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of ext Andy Bierman
> Sent: Thursday, August 14, 2008 3:43 AM
> To: NETMOD Working Group
> Subject: [netmod] augment and mandatory
> 
> Hi,
>