Subject: Re: [netmod] minAccess/maxAccess

From: Balazs Lengyel <[email-masked]>
Date: Thu, 07 Aug 2008 17:23:34 +0200

Hello,
- create-only is used in Ericsson as well so I fully support Sharon's idea.
You can set leaf foo's value once, when you create the containing list/container but never after

leaf foo {
   type int32;
   default 27;
   create-only;  // we actually call this restricted
}

Balazs

Sharon Chisholm wrote:
> Hi
> 
> While inheriting minAccess and maxAccess is a good approach, it is
> important to be able to override this to support things like create-only
> or the ability to modify, but not create or delete.
> 
> I propose then that we need a minAccess/maxAccess mechanism that
> optionally overrides the access provided by the config/non-config bit.
> 
> Sharon Chisholm
> Nortel 
> Ottawa, Ontario
> Canada
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Andy Bierman <[email-masked]>
Date: Thu, 07 Aug 2008 09:35:05 -0700

>   create-only;  // we actually call this restricted

This shows up a lot in MIBs, so it seems
like a good idea to support it in YANG.

What about the use-case where the agent is
going to generate the value of the leaf, based on
the other parameters or other factors?  It will get
saved in NV-storage, but the manager doesn't always
get to pick the value.

   leaf ifIndex {
     description
        "The interface number assigned by the agent to this entry.";
     type if:InterfaceIndex;
     agent-create-only;
   }

>> optionally overrides the access provided by the config/non-config bit.

minAccess is a module conformance concept, not related
to the object definition itself.

>> Sharon Chisholm

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 07 Aug 2008 22:16:05 +0200 (CEST)

> like a good idea to support it in YANG.

...touching again the discussion about how much should be
machine-readable and how much should be specified in the description
clause ;-)

>         "The interface number assigned by the agent to this entry.";

On my slides from Dublin we suggested:

  created-by ("system" / "user");

But it would be better if we can find one concept / keyword which
covers all (most?) of the use cases.

It is important to keep in mind how these
creation/modification-specifications interact with a manager that does
get-config to store a backup and later copy-config to restore it.

/martin