Subject: [netmod] Consensus on having an interim meeting Oct 8 - 10

From: David Partain <[email-masked]>
Date: Tue, 12 Aug 2008 14:35:15 +0200

Hi,

At the recent IETF, there seemed to be strong consensus for having an interim 
meeting SINCE we have an aggressive timeline we ARE going to meet.  We have a 
tentative host near Washington, D.C, but please don't book your tickets 
yet...  I'll send out mail when everything is confirmed.

Just to confirm that consensus on the mailing list, let me ask a few 
questions:

Who supports having an interim on 8 - 10 October?

Who is opposed to such an interim?  It might be nice to know why, in this 
case.

I doubt seriously there will be the possibility of remote participation.  
Combining 20 people sitting in a room around a whiteboard with a 
teleconference seems like an impossible combination.

To get some idea of how big the facilities need to be, I need to know about 
attendance figures.  Please respond (directly to me, not the list) and tell 
me:

 - You will attend
 - You will probably attend

http://tools.ietf.org/wg/netmod/trac/wiki/interim_oct08 will be used to keep 
information about the interim, including venue, recommended hotel(s), agenda, 
attendee list, and so on.  There's nothing there yet...

Cheers,

David
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 12 Aug 2008 14:39:05 +0200 (CEST)

> Who supports having an interim on 8 - 10 October?

I support this.

/martin

---

From: Phil Shafer <[email-masked]>
Date: Tue, 12 Aug 2008 09:18:01 -0400

>Who supports having an interim on 8 - 10 October?

I support it and will attend.

Thanks,
 Phil

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Tue, 12 Aug 2008 16:05:44 +0200

I support it but will not be able to participate.

Bert

---

From: David Reid <[email-masked]>
Date: Tue, 12 Aug 2008 12:16:14 -0400

> Who supports having an interim on 8 - 10 October?

I support this and will probably attend.

-David Reid

---

From: Andy Bierman <[email-masked]>
Date: Tue, 12 Aug 2008 09:52:36 -0700

> Who supports having an interim on 8 - 10 October?

I support the interim and will attend.

> teleconference seems like an impossible combination.

We could look into an audio feed via SHOUTcast, etc. and run jabber.
(No better or worse remote participation support than a real IETF.)

> attendee list, and so on.  There's nothing there yet...

Andy

---

From: "tom.petch" <[email-masked]>
Date: Tue, 19 Aug 2008 18:02:32 +0200

I do have reservations about this.  Were I to attend - unlikely - my
expectations would be low.  I think that the process might be interesting but
that progress might be slight.

This is the most active IETF list I can recall and yet .. sometimes it seems to
be
more a tutorial in the finer points of interactions of nuances within the I-D.
Issues do arise that raise a vigorous debate but then they seem rarely to reach
a consensus.  There are also e-mails raising good points to which there is no
response on the list.  And then there are those
'Remind me, what did we conclude about ...'
to which my personal answer would be
'We did not reach a conclusion that I could discern.' :-(

E-mail is the most impoverished form of communication, face-to-face is
much richer, but I wonder why this pattern would not recur at the interim.

And, as has happened once already, there may be a tendency in the meantime to
say "Let's resolve this at the interim" which is apt to delay progress.

Tom Petch

----- Orginal Message -----
From: "Andy Bierman" <[email-masked]: "David Partain"
<[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, August 12, 2008 6:52 PM
Subject: Re: [netmod] Consensus on having an interim meeting Oct 8 - 10

> > Who supports having an interim on 8 - 10 October?
<snip>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 19 Aug 2008 19:38:19 +0200

On Tue, Aug 19, 2008 at 06:02:32PM +0200, tom.petch wrote:

> expectations would be low.  I think that the process might be
> interesting but that progress might be slight.

I have been at two pre IETF YANG meetings and they were both extremely
productive. The biggest advantage is a whiteboard where people can
write down examples etc. and the fact that most people can concentrate
on just on thing for 2+ days.
 
> This is the most active IETF list I can recall and yet .. sometimes
> it seems to be more a tutorial in the finer points of interactions
> of nuances within the I-D.  Issues do arise that raise a vigorous
> debate but then they seem rarely to reach a consensus.  There are
> also e-mails raising good points to which there is no response on
> the list.  And then there are those 'Remind me, what did we conclude
> about ...'  to which my personal answer would be 'We did not reach a
> conclusion that I could discern.' :-(

See, this is how IETF mailing lists are. People read and react next to
their daytime activities and so context is constantly lost. But on
some issues, I do actually see progress.

> E-mail is the most impoverished form of communication, face-to-face
> is much richer, but I wonder why this pattern would not recur at the
> interim.

See above.

> And, as has happened once already, there may be a tendency in the
> meantime to say "Let's resolve this at the interim" which is apt to
> delay progress.

If you see this happening and you believe things can be resolved right
now, please speak up and make it happen. The productivity of the WG
mailing list is a function of the WG members. It is up to all of us to
be disciplined and to move forward in a productive way.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Andy Bierman <[email-masked]>
Date: Tue, 19 Aug 2008 11:09:04 -0700

> on just on thing for 2+ days.

As Joel pointed out, it would be nice to capture
the design motivations for various details, instead
of just the details.

> some issues, I do actually see progress.

If your day job is implementing YANG, then the WG progress
seems quite slow, and the mailing list doesn't seem that active at all.

When the co-Chairs get the issue tracker going, the issue
resolution thing will go much faster.  Some of us (like me)
don't always keep the email subject aligned with the
actual thread, which makes it harder to follow along
and jump in.  If we sent less mail with better subject
lines, maybe that would help.

>> is much richer, but I wonder why this pattern would not recur at the

I agree with Juergen.
At a WG interim, the IETF is your day job.
I have seen people travel to an interim just to
work on their laptop and ignore the meeting,
but (unlike an IETF) that is rare, not the status quo.

Also, the co-Chairs can force issue resolution.
Notice how the agenda says 8:30am to whenever?
Old WG Chair trick: don't adjourn for dinner
until the deadlock is broken.  No food, no beer,
until the issue is solved.  (This works amazingly
well on most of us :-)

>> meantime to say "Let's resolve this at the interim" which is apt to

That's OK for some big complex issues.

> be disciplined and to move forward in a productive way.

Agreed.  We used to call out "rathole" or "tar-baby"
more often.

Perhaps Martin can summarize the list of edits for -01
that have "no objections", and we see how many
open issues there really are.

Andy

---

From: David Partain <[email-masked]>
Date: Tue, 19 Aug 2008 21:19:14 +0200

Greetings,

On Tuesday 19 August 2008 18.02.32 tom.petch wrote:
> expectations would be low.  I think that the process might be interesting
> but that progress might be slight.

I completely disagree.  The qualitative difference between sitting in the same 
room with a whiteboard and the evenings over a good beer is dramatically 
different than anything that happens anywhere on a mailing list.  Of course, 
everything gets taken back to the mailing list... (should go without saying).

> This is the most active IETF list I can recall and yet .. sometimes it
> seems to be
> more a tutorial in the finer points of interactions of nuances within the
> I-D. Issues do arise that raise a vigorous debate but then they seem rarely
> to reach a consensus.  There are also e-mails raising good points to which
> there is no response on the list.  And then there are those

I hope that, in the end, all of these issues will be sufficiently documented 
that people will be able to deal with YANG without  needing to know all of 
this background.

> much richer, but I wonder why this pattern would not recur at the interim.

Of course, it _might_, but I absolutely don't believe so.  I (as one of the 
co-chairs) have zero intention of letting us rat-hole.

> And, as has happened once already, there may be a tendency in the meantime
> to say "Let's resolve this at the interim" which is apt to delay progress.

Sometimes a face-to-face (or a jabber session or a teleconference) makes 
consensus building much easier than anything email offers.  I agree that 
email isn't a very good way to do this, but it's the tool we have at our 
disposal.

All of that said, I hope you'll attend the interim.

Cheers,

David