Subject: [netmod] section E.4

From: Andy Bierman <[email-masked]>
Date: Thu, 14 Aug 2008 09:39:17 -0700

Hi,

The error appendix section E.4 needs to say that
it defines the default error-app-tag field,
if no error-app-tag statement is present.

Andy

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Andy Bierman <[email-masked]>
Date: Thu, 14 Aug 2008 10:21:00 -0700

> if no error-app-tag statement is present.

I also think this section needs to be split into 2 sections.

The must-stmt error-tag is clearly operation-failed, as specified.

What is a 'when' statement violation?
I do not see any text in 7.15.2 about it.
If a manager sets a node that is not really there,
then the unknown-element error-tag is sent.

The length, range, and pattern error-tag should
be 'invalid-value', not 'operation-failed'.

IMO, it would also be better to have 1 error-app-tag
for length/range exceeded and another for pattern test failed.
(Strings can have both length and pattern, and the manager
needs to know which one failed.

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 20 Aug 2008 13:27:11 +0200 (CEST)

Hi,

> then the unknown-element error-tag is sent.

I agree.  I will remove this.

> be 'invalid-value', not 'operation-failed'.

Agreed.  Actually, I think 'invalid-value' is all that's needed for
these cases; there is no need for a specific
'data-restriction-violation' app-tag.  So I suggest we remove the
special app-tag for length/range/pattern.

/martin

---

From: Andy Bierman <[email-masked]>
Date: Wed, 20 Aug 2008 10:29:16 -0700

> special app-tag for length/range/pattern.

So that would leave must-violation.  Good.
I think this should have its own error-app-tag.

Reusing 'invalid-value' is safe for any existing
applications which might interpret this tag
in a generic manner.  Less work for everybody.

Andy

---

From: Balazs Lengyel <[email-masked]>
Date: Thu, 21 Aug 2008 14:18:51 +0200

Hello,
It is included in the text directly under Appendix E.
Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod