Subject: [netmod] error-message clause

From: Andy Bierman <[email-masked]>
Date: Thu, 14 Aug 2008 08:48:52 -0700

Hi,

I think we might end up expanding the 'configured errors' construct
used in the must/pattern/length/range clauses.

As I'm writing code, I noticed that even though the error-message
clause can override the internal msg string, I am still hardwiring
the xml:lang attribute to 'en'.  Perhaps an optional 'error-message-language'
clause is also needed?

Andy

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 19 Aug 2008 22:57:38 +0200 (CEST)

> the xml:lang attribute to 'en'.  Perhaps an optional 'error-message-language'

Fine with me.

/martin

---

From: Andy Bierman <[email-masked]>
Date: Tue, 19 Aug 2008 14:11:50 -0700

>> the xml:lang attribute to 'en'.  Perhaps an optional 'error-message-language'

What about a top-level 'language' clause to define
the xml:lang enum for all the textual content instead?
It is not going to be different for each error.

If we were really clever, we would figure out how to
support NETCONF agent language localization with
a standard error construct in YANG and a standard
read-write YANG data model to configure the agent.
(But that will have to wait.)

Andy