Subject: [netmod] augment clarification

From: Martin Bjorklund <[email-masked]>
Date: Mon, 11 Aug 2008 08:55:16 +0200 (CEST)

Hi,

Andy Bierman <[email-masked]> wrote:
> BTW, I just found another error-check with augmenting
> a choice.  If the choice has a default case, then you cannot
> augment the default case with any mandatory nodes.

You're right, but I don't think this is specific to a choice with a
default case.  It applies to all cases in a choice.  We need to
clarify that augment MUST NOT add any mandatory nodes (i.e. mandatory
leaf, list or leaf-list w/ min-elements > 0 etc).

The idea behind this is that an augment must not break a client that
doesn't understand the augmentation.  Such a client will never be able
to add the mandatory nodes...

/martin
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: <[email-masked]>
Date: Mon, 11 Aug 2008 18:10:28 +0300

Hi ,

> leaf, list or leaf-list w/ min-elements > 0 etc).

Doesn't this apply to also to augmentations of list, container etc?
(Not sure if that way implicitly included in your statement above).

> to add the mandatory nodes...

Exactly. 
So I think that this is a useful restriction  - as it 
allows to focus on a data tree as originally defined
in the original module.

- Bernd

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 11 Aug 2008 20:34:07 +0200 (CEST)

> Doesn't this apply to also to augmentations of list, container etc?

Yes it does.

> allows to focus on a data tree as originally defined

Ok, I will try to clarify this in the text.

/martin

---

From: Andy Bierman <[email-masked]>
Date: Mon, 11 Aug 2008 12:30:16 -0700

> Ok, I will try to clarify this in the text.

It was never clear to me that was the case,
but it seems OK.  If you need to add any mandatory
leafs you should start over instead of breaking
the original data structure for existing managers.

> /martin

Andy