Subject: Re: [netmod] config-stmt on choice and/or case

From: Martin Bjorklund <[email-masked]>
Date: Mon, 11 Aug 2008 16:03:41 +0200 (CEST)

Martin Bjorklund <[email-masked]> wrote:
> Andy Bierman <[email-masked]> wrote:
> > Hi,
> > 
> > Remind me again why we don't need config-stmt within choice-stmt
> > or case-stmt?
> 
> I don't see any reasons for not allowing config under choice and
> case.  If no one objects, I'll make this change.

Hmmm, I object.  What does this mean:

  choice foo {
    case a {
       config true;
       leaf x { ... }
    case b { 
       config false;
       leaf y { ... }
  }

I think config under choice makes perfect sense.  But for 'case', I'd
like to be more restrictive and say that if any node in any case is
config, then there must be at least one config node in each case.

/martin
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Andy Bierman <[email-masked]>
Date: Mon, 11 Aug 2008 07:25:04 -0700

> config, then there must be at least one config node in each case.

OK -- I agree this is unlikely.

> /martin
Andy