Subject: Re: [netmod] Augmentable Groupings

From: Balazs Lengyel <[email-masked]>
Date: Wed, 01 Oct 2008 11:07:44 +0200

It can make SW design easier if some meta information is visible from XML itself. Not every bit 
of the SW is fully YANG aware.
Balazs

Juergen Schoenwaelder wrote:
> On Wed, Oct 01, 2008 at 10:22:28AM +0200, Balazs Lengyel wrote:
> 
>> This solution allows you to check in the on-the-wire XML which basic 
>> grouping/list and which extension list/grouping is present, as the list 
>> itself carries the name of the grouping (only by a self-imposed naming 
>> convention).
> 
> Why is this needed? There is a namespace, no? Since I know the modules
> implemented on a device and their namespaces, I have everything I need
> to identify the exact definition of something.
> 
> /js
> 

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 1 Oct 2008 11:42:52 +0200

On Wed, Oct 01, 2008 at 11:07:44AM +0200, Balazs Lengyel wrote:

> It can make SW design easier if some meta information is visible from XML 
> itself. Not every bit of the SW is fully YANG aware.

It makes SW design easier if you can _rely_ on it. Otherwise, you are
fooling yourself.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod