Subject: [netmod] FW: Gen Art LC review of draft-ietf-netmod-yang-11

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 13 Apr 2010 16:52:53 +0200

________________________________

	From: Avshalom Houri [mailto:[email-masked]] 
	Sent: Sunday, April 11, 2010 7:10 PM
	To: General Area Review Team; [email-masked]
	Cc: Romascanu, Dan (Dan)
	Subject: Gen Art LC review of draft-ietf-netmod-yang-11

	I have been selected as the General Area Review Team (Gen-ART) 
	reviewer for this draft (for background on Gen-ART, please see 
	http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html
<http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html> ). 
	Please wait for direction from your document shepherd 
	or AD before posting a new version of the draft. 
	
	Document: draft-ietf-netmod-yang-11 
	Reviewer: Avshalom Houri 
	Review Date: 2010-04-11 (sorry for the delay but it is 180
pps...). 
	IESG last call date: 2010-04-09 
	
	Summary: The draft is ready to be published as standard track
RFC 
	
	Major issues: None 
	
	Minor issues: None 
	
	Nits/editorial comments: 
	
	Lines 4643-4652: 
	   No restrictions are placed on the XML.  This can be useful in
for 
	.... 
	   example RPC replies.  An example is the <filter> parameter in
the 
	
	in for example -> for example in 
	
	Line 5861: 
	   contents of the deviation statement give details about the
deviation. 
	give details -> gives details
	
	Line 5887: 
	   back to the unsuspecting application, or ignore that incoming

	or ignore -> or ignores 
	
	tnx 
	avshalom

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 13 Apr 2010 11:14:54 -0700

Hi -

> Subject: Gen Art LC review of draft-ietf-netmod-yang-11

...
> Lines 4643-4652: 
>    No restrictions are placed on the XML.  This can be useful in for 
>    example RPC replies.  An example is the <filter> parameter in the 
>

I think this would be much better with commas:
  useful in, for example, RPC
  useful, for example, in RPC
  For example, this can be useful in RPC replies.

Any of these would work for me.

> Line 5861: 
>   contents of the deviation statement give details about the deviation. 

Disagree.  The verb's subject is "contents", which is plural, so the correct
form of the verb is indeed "give".

>    back to the unsuspecting application, or ignore that incoming

Disagree.  This is the second prong of the construct "a choice to X
or (to) Y".  There is an implied (but very optional) "to" between "or"
and "ignore".  However, there *is* a problem  immediately following.
"ignore that requests" should be "ignore that request" or "ignore
those requests", depending on the intended nuance.

Randy

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 13 Apr 2010 21:10:29 +0200 (CEST)

> Any of these would work for me.

Ok, I picked the second one.

> form of the verb is indeed "give".

Good, that was what I thought.

> and "ignore".

Thank you.  As a non-native english speaker, I was unsure.

> However, there *is* a problem  immediately following.

Fixed ("those requests").

/martin