Subject: [netmod] Call for NETMOD Agenda Items for Maastricht

From: David Partain <[email-masked]>
Date: Tue, 29 Jun 2010 13:42:41 +0200

Greetings,

Our current status on documents is:

1. YANG - In the RFC Editor queue (https://datatracker.ietf.org/doc/draft-ietf-netmod-yang/)

2. Common YANG Data Types - In the RFC Editor queue (https://datatracker.ietf.org/doc/draft-ietf-netmod-yang-types/)

3. Guidelines for Authors and Reviewers of YANG Data Model Documents - In IETF Last Call, which ends 2010-07-08 
(https://datatracker.ietf.org/doc/draft-ietf-netmod-yang-usage/)

4. An Architecture for Network Management using NETCONF and YANG - Submitted to the IESG Secretary today to request publication. 
Should show up in the tracker soon and sent out for IETF Last Call when Dan requests it.

5. Mapping YANG to Document Schema Definition Languages and Validating NETCONF Content - Currently in WGLC.  When that is done, 
will be submitted for publication to the IESG Secretary.  Unless something dramatic happens, this will happen next Monday.

This means that all of our chartered work is nearing completion.  We will, nonetheless, meet in Maastricht and have a 2.5 hour slot.  As 
such, if you have a topic that you would like to present at the meeting, please let The Davids know as soon as possible.

Of particular interest would be any work that you have done on YANG models that you would like to present and get feedback on.  Note 
that the cut-off date for -00 internet drafts is on Mon, July 5 (see http://www.ietf.org/meeting/cutoff-dates-2010.html#IETF78)

Thanks.

David

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 29 Jun 2010 17:20:24 +0200

On Tue, Jun 29, 2010 at 01:42:41PM +0200, David Partain wrote:

> Of particular interest would be any work that you have done on YANG
> models that you would like to present and get feedback on.  Note
> that the cut-off date for -00 internet drafts is on Mon, July 5 (see
> http://www.ietf.org/meeting/cutoff-dates-2010.html#IETF78)

At IETF 75 (one year ago), I presented how libsmi translates SMIv2 to
YANG (the YANG version valid about 1.5 years ago). The slides are
here:

http://www.ietf.org/proceedings/75/slides/netmod-0.pdf

The meanwhile expired ID is here:

http://tools.ietf.org/html/draft-schoenw-netmod-smi-yang-00

I do not plan to repeat this presentation. But if the WG plans to
recharter, than this work might be considered as a possible work item.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>