Subject: [netmod] Groupings - augmentation and deviations

From: Jeffrey Haas <[email-masked]>
Date: Thu, 14 May 2015 12:34:40 -0400

[I'm weeks behind on reading this list due to day-job needs.  If this is
answered in a previous thread, I'm happy to get a pointer to that.]

As best I'm able to tell, it is not possible to add augmentations or
deviations to groupings directly.  They don't implement any data nodes.

If this is the case, the implication is that when you need to do a common
augmentation or deviation to a grouping, you're responsible for adding the
augmentation/deviation in every instantiation of it.

Is this correct?  If so, this seems a bit clumsy.

-- Jeff

---

From: "Sterne, Jason (Jason)" <[email-masked]>
Date: Thu, 14 May 2015 20:26:51 +0000

You have that correct.
Jason

-----Original Message-----
From: netmod [mailto:[email-masked]] On Behalf Of Jeffrey Haas
Sent: Thursday, May 14, 2015 12:35 PM
To: [email-masked]
Subject: [netmod] Groupings - augmentation and deviations

[I'm weeks behind on reading this list due to day-job needs.  If this is answered in a previous thread, I'm happy to get a pointer to that.]

As best I'm able to tell, it is not possible to add augmentations or deviations to groupings directly.  They don't implement any data nodes.

If this is the case, the implication is that when you need to do a common augmentation or deviation to a grouping, you're responsible for adding the augmentation/deviation in every instantiation of it.

-- Jeff

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod