Subject: [netmod] YANG Alarm Module

From: Stefan Wallin <[email-masked]>
Date: Thu, 7 May 2015 08:48:55 +0200

Hi!

We have posted a YANG alarm module: http://tools.ietf.org/html/draft-vallin-alarm-yang-module-00 <http://tools.ietf.org/html/draft-vallin-alarm-yang-module-00>

Please review and send any comments and most important of all, is this needed?

Being able to read alarm status and get alarm notifications is a basic
requirement for any manageable device. Device alarm interfaces needs to be
integrated to alarm management systems at service providers.
A standardised interface for that integration would help a lot. Currently,
service providers need to read and understand various proprieatary alarm
interfaces including enterprise specific MIBs. Many devices does not even have
a clear notion of alarms, just events in general.

The telecom industry have been pushing standardised alarm interfaces for every
new generation of mangement interface protocol. This is usually the the first
data-model that is defined in telco standards. IETF did this a bit too late for
SNMP with the Alarm MIB (RFC 3877). All vendors already had implemented alarm
instrumentation and good or bad MIBs, so vendors argued about adding support for
this MIB afterwards and the MIB had to support fairly complex mapping
capabilities to existing proprietary alarm MIBs.

We have a chance to resolve this issue with a Alarm YANG Module. Going forward
vendors will write their own alarm modules if we do not provide an IETF module.

All feed-back welcome!

Module summary:
  This YANG module defines an alarm interface for network devices.  It
  includes functions for alarm list management and notifications to
  inform management systems.  There are also RPCs to manage the
  operator state of an alarm and administrative alarm procedures.  The
  module carefully maps to relevant alarm standards.

br Stefan and Martin

---

From: De Noia Giuseppe <[email-masked]>
Date: Thu, 7 May 2015 08:33:42 +0000

Hi,
very interesting module.
However I have a question. I suppose this module will be used in netconf Event Notification framework (rfc 5277). In this case, does a network manager need to have as many SSH open sessions as the managed devices are? They could be thousands..
Regards,
Pino De Noia
------------------------------------------------------------------
Telecom Italia
Giuseppe De Noia
T.TG.NM.OSI,
Via Reiss Romoli, 274  10148 Torino
011 2288887
331 6001197

Da: netmod [mailto:[email-masked]] Per conto di Stefan Wallin
Inviato: giovedì 7 maggio 2015 08:49
A: [email-masked]; [email-masked]
Oggetto: [netmod] YANG Alarm Module

Hi!

We have posted a YANG alarm module: http://tools.ietf.org/html/draft-vallin-alarm-yang-module-00

All feed-back welcome!

Module summary:

br Stefan and Martin

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

[rispetta l'ambiente]Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: Stefan Wallin <[email-masked]>
Date: Thu, 7 May 2015 10:36:10 +0200

Hi!
Yes, that is certainly a concern and where SNMP UDP notifications has its benefits :)
I have in mind a mapping to SNMP notifications for this same module, could maybe make sense.
br Stefan

> On 07 May 2015, at 10:33, De Noia Giuseppe <[email-masked]> wrote:
> 
> Hi,
> very interesting module.
> Da: netmod [mailto:[email-masked] <mailto:[email-masked]>] Per conto di Stefan Wallin
> A: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> <logo Ambiente_foglia2.jpg>Rispetta l'ambiente. Non stampare questa mail se non è necessario.
> 
> <logo Ambiente_foglia2.jpg>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 7 May 2015 10:43:14 +0200

On Thu, May 07, 2015 at 08:33:42AM +0000, De Noia Giuseppe wrote:

> However I have a question. I suppose this module will be used in
> netconf Event Notification framework (rfc 5277). In this case, does
> a network manager need to have as many SSH open sessions as the
> managed devices are? They could be thousands..

There is work on call home mechanisms in the NETCONF WG and perhaps a
call home mechanism can also be used to establish a secure notification
delivery channel on demand (e.g., device calls home, NETCONF client
establishes a notification subscription e.g. using a suitable replay
and the NETCONF server then sends any of the pending cached events).

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Thu, 7 May 2015 14:45:55 +0000

One comment, below

From: netmod [mailto:[email-masked]] On Behalf Of Stefan Wallin
Sent: Thursday, May 07, 2015 1:36 AM
To: De Noia Giuseppe
Cc: [email-masked]
Subject: Re: [netmod] YANG Alarm Module

Hi!

AC>   Or syslog? ;-)

I believe tie-in with syslog would be needed, in fact.

---

From: "Sterne, Jason (Jason)" <[email-masked]>
Date: Thu, 7 May 2015 20:10:38 +0000

Or alternate streaming-type transport options for NETCONF notifications ?

From: netmod [mailto:[email-masked]] On Behalf Of Stefan Wallin
Sent: Thursday, May 07, 2015 4:36 AM
To: De Noia Giuseppe
Cc: [email-masked]
Subject: Re: [netmod] YANG Alarm Module

Hi!

On 07 May 2015, at 10:33, De Noia Giuseppe <[email-masked]<mailto:[email-masked]>> wrote:

Hi,
very interesting module.

Da: netmod [mailto:[email-masked]] Per conto di Stefan Wallin
Inviato: giovedì 7 maggio 2015 08:49
A: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Oggetto: [netmod] YANG Alarm Module

Hi!

All feed-back welcome!

Module summary:

br Stefan and Martin

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 7 May 2015 22:14:50 +0200

> Or alternate streaming-type transport options for NETCONF notifications ?

The topic how to transport YANG defined notifications seems to belongs
to the NETCONF WG mailing list and not really to the NETMOD mailing
list (although I understand why it started here).

/js

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 7 May 2015 13:43:53 -0700

[Cross-posting it to NETCONF]

Stefan, did try to post to netconf, but it got blocked because he was not subscribed to the mailing list.

I agree with Juegen that the topic of what transport mechanism is used belongs to the NETCONF WG, and is certainly an area of interest to the WG.

[Chair hat off]

In trying to address the issue, we need to address the issue of what happens if there are either no sessions connected to the server or thousands of them. For the latter, we might have to look at a pub/sub model to contain where alarms get delivered. Throw in other notifications and now you are looking at prioritizing event notifications, as I am sure alarms would like to be treated at a different priority.

p.s. Pardon my multiple attempts to post this message

> 
>> 
>>> On May 7, 2015, at 1:14 PM, Juergen Schoenwaelder <[email-masked]> wrote:
>>> 

Mahesh Jethanandani
[email-masked]