Subject: [netmod] Name collision in embedded choice/case

From: Balazs Lengyel <[email-masked]>
Date: Fri, 4 Sep 2015 10:26:51 +0200

Hello,
The attached module was accepted as valid by pyang and by the 
http://www.netconfcentral.org/ validator. IMHO it should be invalid as 
it seems to allow two a1 and two a2 definition inside choices desease 
and kongo.
The operation
<edit-config>
    <hospital>
       <a1>5</a1>
    </hospital>
<\edit-config>
would be abigious. Does the value 5 belong to the case pest or the case 
ebola?
Opinions?
regards Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
Senior Specialist
ECN: 831 7320
Mobile: +36-70-330-7909              email: [email-masked]

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 4 Sep 2015 10:46:19 +0200

> On 04 Sep 2015, at 10:26, Balazs Lengyel <[email-masked]> wrote:
> 
> Hello,
> The attached module was accepted as valid by pyang and by the http://www.netconfcentral.org/ validator. IMHO it should be invalid as it seems to allow two a1 and two a2 definition inside choices desease and kongo.
> The operation
> <edit-config>
>   <hospital>
>      <a1>5</a1>
>   </hospital>
> <\edit-config>
> would be abigious. Does the value 5 belong to the case pest or the case ebola?
> Opinions?

I agree, this is clearly invalid.

Lada

> <rec2.yang>_______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C