Subject: Re: [netmod] Fwd: New Version Notification for draft-ietf-netmod-yang-json-05.txt

From: Randy Presuhn <[email-masked]>
Date: Wed, 16 Sep 2015 10:55:41 -0700 (GMT-07:00)

Hi -

>From: Ladislav Lhotka <[email-masked]>
>Sent: Sep 15, 2015 11:03 PM
>To: Randy Presuhn <[email-masked]>, NETMOD Working Group <[email-masked]>
>Subject: Re: [netmod] Fwd: New Version Notification for draft-ietf-netmod-yang-json-05.txt
...
>> This leaves me wondering what it means for the data model for
>> anydata content to be "available".  In the case of ASN.1's
>> "ANY DEFINED BY" construct, there's an OBJECT IDENTIFIER to
>> unambiguously identify the grammar (and associated semantics)
>> to be used to understand the content, so tools can, if needed,
>> scurry off to obtain the parsing instructions for those
>> particular bits.  How does an implementation know in the case
>> of "anydata" which datamodel to use?
>
>It can be stated in the description of the anydata statement. One can
>then ask though why we need two constructs - anyxml and anydata -
>because a data model can be specified in the description of an anyxml
>statement as well.

How does a client (or a server, for that matter) extract that
information from the description of the anydata statement?

Randy

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 16 Sep 2015 20:38:27 +0200

> On 16 Sep 2015, at 19:55, Randy Presuhn <[email-masked]> wrote:
> 
> Hi -
> 

They don’t, unless they are terribly sophisticated. It’s up to a human implementer to parse the description text and write a corresponding code. No automation at all.

In fact, the main use case for anydata/anyxml so far has been in standards where YANG played the role of a schema language.

Lada   

> 
> Randy
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C