Subject: [netmod] Question about draft-ietf-netmod-acl-model-03

From: Linda Dunbar <[email-masked]>
Date: Thu, 24 Sep 2015 20:07:56 +0000

Dean, et al,

Does the following statement in the Section 7 IANA Consideration make  "ietf-acl" equivalent to the long name "urn:ietf:params:xml:ns:yang:ietf-access-control-list"?

urn:ietf:params:xml:ns:yang:ietf-access-control-list prefix: ietf-acl

If the answer is YES, can the example in Section 4.3 can use "ietf-acl" directly instead of the long name?
i.e.
 <access-lists "urn:ietf:params:xml:ns:yang:ietf-acl:1.0">

What does the ":1.0" mean in the example?

Thanks, Linda

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 25 Sep 2015 10:12:25 +0200

> What does the ":1.0" mean in the example?

That example is broken, it's not even well-formed XML.

It would be useful if module authors always validate such examples
before publishing an I-D. My skeleton project at GitHub shows how to
make such a validation an integral part of I-D processing - see the
Makefile:

https://github.com/llhotka/YANG-I-D

Lada

>
> Thanks, Linda
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C