Subject: [netmod] Tomorrow's Interim Meeting Details

From: Nadeau Thomas <[email-masked]>
Date: Wed, 9 Sep 2015 20:38:35 -0400

I wanted to set things up for the interim meeting tomorrow. To frame the meeting, we want to achieve two main goals: 

	1) close on requirements around a requirement to define a structure for IETF models and the requirements around ops state/models 

	2) discuss/debate/understand the differences between the 3 different solution approaches as described in draft-openconfig-netmod-opstate-01, draft-kwatsen-netmod-opstate, draft-wilton-netmod-opstate-yang.  While I understand the last two drafts are relatively new, they are there and have been for a time sufficient to read and ask questions on the list of the authors.   

	To this end, I’d like to steer the discussion in the direction of having direct questions/debate over those solutions. I’d like a representative author from each draft lead each of their sections.   If time still exists, I’d like to let Kent (speaking as co-chair), objectively compare pros/cons of each solution.  I understand that we allocated an hour for tomorrow. We incorrectly anticipated a single draft to be compared to the existing opsstate draft.  If we need additional time, a second meeting will be planned for hopefully next week, so that we can tie things off.

	This is the proposed agenda for tomorrow’s meeting.

	0) Agenda Bashing - Tom/2 min

	1) Statement from the AD:
		Please read http://www.ietf.org/mail-archive/web/netmod/current/msg13510.html
		
	1) Requirements - Tom/15 min
	  - goal is to close on consensus (to be confirmed on list)
	      on the problem statement/requirements, as described in
	      draft-openconfig-netmod-opstate-01, Sections 3 & 4, and
	      implied in draft-openconfig-netmod-model-structure-00
	      (yes, we'll need to write them down), as well as any
	      other requirements not covered by the above.
	    - please come prepared to discuss and finalize these

	2) Questions/Comments about each specific draft - 15 minutes for each
		A rep for each draft (Martin?, Wilton?, Anees?)

	   - to be led by a representative for each draft
	      (Martin?, Wilton?, Anees?)
	    - this is not intended to be a presentation of these solution
	      so much as an opportunity to ask questions of the authors
	      regarding any aspect of the presented solution.
	    - everyone should come prepared having already read these drafts.
	    - if there are no questions, we'll move on to the next draft
	      right away.

	3) Compare and contrast the solutions () - rest of the time, if time permits. Kent (as co-chair)

	    - goal is to up-level the conversation to direct comparison
	      of the various solutions.

	Finally, I’d like to ask for a volunteer to take notes as well as someone to run the Etherpad. 

	WebEx Details:

>>> 
>>> NETMOD Working Group invites you to join this WebEx meeting.
>>>  
>>> NETMOD Interm meeting on OpenConfig
>>> Thursday, September 10, 2015 
>>> 11:00 am  |  Eastern Daylight Time (New York, GMT-04:00)  |  1 hr 
>>>  
>>> Join WebEx meeting
>>> Meeting number:	645 732 277 
>>> Meeting password:	1234
>>>  
>>> Join by phone
>>> 1-877-668-4493 Call-in toll free number (US/Canada)
>>> 1-650-479-3208 Call-in toll number (US/Canada)
>>> Access code: 645 732 277

---

From: Andy Bierman <[email-masked]>
Date: Wed, 9 Sep 2015 18:01:04 -0700

Hi,

This email and the one from Benoit do not mention any sort of problem scope.
IMO it would be useful to know if the scope includes all YANG modules, only
IETF
YANG modules, or perhaps only IETF routing modules. As the scope gets wider,
the probability that "1 size fits all" goes way down.

Andy

On Wed, Sep 9, 2015 at 5:38 PM, Nadeau Thomas <[email-masked]>
wrote:

>
>         I wanted to set things up for the interim meeting tomorrow. To
> frame the meeting, we want to achieve two main goals:
>
>         1) close on requirements around a requirement to define a
> structure for IETF models and the requirements around ops state/models
>
>         2) discuss/debate/understand the differences between the 3
> different solution approaches as described in
> draft-openconfig-netmod-opstate-01, draft-kwatsen-netmod-opstate,
> draft-wilton-netmod-opstate-yang.  While I understand the last two drafts
> are relatively new, they are there and have been for a time sufficient to
> read and ask questions on the list of the authors.
>
>         To this end, I’d like to steer the discussion in the direction of
> having direct questions/debate over those solutions. I’d like a
> representative author from each draft lead each of their sections.   If
> time still exists, I’d like to let Kent (speaking as co-chair), objectively
> compare pros/cons of each solution.  I understand that we allocated an hour
> for tomorrow. We incorrectly anticipated a single draft to be compared to
> the existing opsstate draft.  If we need additional time, a second meeting
> will be planned for hopefully next week, so that we can tie things off.
>
>
>                 Please read
> http://www.ietf.org/mail-archive/web/netmod/current/msg13510.html
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Kent Watsen <[email-masked]>
Date: Thu, 10 Sep 2015 01:26:19 +0000

This goes to model-structure requirements, which are currently undefined.  As mentioned below, we will need to spend some time tomorrow writing them down, so we have something to call consensus on.    Maybe the open config folks could take a stab at this before tomorrow's meeting?

Kent

From: Andy Bierman <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, September 9, 2015 at 9:01 PM
To: Thomas Nadeau <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [netmod] Tomorrow's Interim Meeting Details

Hi,

This email and the one from Benoit do not mention any sort of problem scope.
IMO it would be useful to know if the scope includes all YANG modules, only IETF
YANG modules, or perhaps only IETF routing modules. As the scope gets wider,
the probability that "1 size fits all" goes way down.

Andy

On Wed, Sep 9, 2015 at 5:38 PM, Nadeau Thomas <[email-masked]<mailto:[email-masked]>> wrote:

        To this end, I'd like to steer the discussion in the direction of having direct questions/debate over those solutions. I'd like a representative author from each draft lead each of their sections.   If time still exists, I'd like to let Kent (speaking as co-chair), objectively compare pros/cons of each solution.  I understand that we allocated an hour for tomorrow. We incorrectly anticipated a single draft to be compared to the existing opsstate draft.  If we need additional time, a second meeting will be planned for hopefully next week, so that we can tie things off.

        This is the proposed agenda for tomorrow's meeting.

        Finally, I'd like to ask for a volunteer to take notes as well as someone to run the Etherpad.

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 10 Sep 2015 02:03:07 +0000

Since the meeting is only an hour, I think it is unrealistic to think we are going to cover both Ops-state and model structure tomorrow.
Thanks,
Acee

From: netmod <[email-masked]<mailto:[email-masked]>> on behalf of Kent Watsen <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, September 9, 2015 at 9:26 PM
To: Andy Bierman <[email-masked]<mailto:[email-masked]>>, "Thomas D. Nadeau" <[email-masked]<mailto:[email-masked]>>
Cc: netmod WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [netmod] Tomorrow's Interim Meeting Details

Kent

Hi,

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 10 Sep 2015 08:08:30 +0200

> 	1) close on requirements around a requirement to define a structure for IETF models and the requirements around ops state/models 

I am confused. Benoit pointed to section 4 which has essentially
requirements concerning the support of asynchronous systems. You seem
to be talking also about requirements that go beyond that. It would be
good to know well ahead of time what is exactly on the agenda.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Benoit Claise <[email-masked]>
Date: Thu, 10 Sep 2015 11:43:29 +0200

Jürgen,
> good to know well ahead of time what is exactly on the agenda.
I also mentioned: "or around the requirement that the YANG models need 
some sort of hierarchy (draft-openconfig-netmod-model-structure), like 
for the routing models, ..."

If the group acknowledges that there is a requirement to structure all 
YANG models, basically extending what's done for the routing models, 
that would already be an achievement.
I would like to verify whether my understanding is correct: there is a 
willingness to structure the YANG models at least per technology 
(routing, OAM, for example), and we're debating whether or not "/device" 
is appropriate. This "/device" is a minor point IMO.

Regards, Benoit

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 10 Sep 2015 12:36:48 +0200

On Thu, Sep 10, 2015 at 11:43:29AM +0200, Benoit Claise wrote:
> >>	I wanted to set things up for the interim meeting tomorrow. To frame 
> >>	the meeting, we want to achieve two main goals:
> >>
> >>	1) close on requirements around a requirement to define a structure 
> >>	for IETF models and the requirements around ops state/models
> >>

I tried to explain this in one of my previous posts. There is a real
challenge ahead to design 'good' models, namely models that are
extensible and maintainable and that remain interoperable over a long
lifetime. This requires to identify and model key core components or
abstractions and getting them 'right' is hard and requires lots of
detailed reviews, discussions, revisions. To me, the discussion where
to root models is somewhat missing the real challenge in front of us.

That said, I believe the previous discussions that led NETMOD to use
the flat roots we have used in various RFCs that define core models
have not been proven broken in the sense that the roots are flawed up
to the point that we should declare failure and throw away RFCs and
running code. And I like to note that models such as ietf-interfaces
or ietf-routing actually provide structure (e.g., interface specific
models are expected to augment the core interface model) but they go
way beyond defining a simple root path. It is these kind of models
that we need. We also need to understand the tension between cohesion
and coupling of data models. Having a single model that every other
model directly or indirectly has to augment provides a coupling that
may prove to be a major headache in 10-15 years from now.

Back to the subject of the thread, the discussion around the support
for asynchronous systems and the discussion around the value of a
common nested root structure for models are in my view two separate
things and we should not mix them.

/js

---

From: Nadeau Thomas <[email-masked]>
Date: Thu, 10 Sep 2015 08:04:20 -0400

This is a good point. This is as yet, undefined.  We should explicitly specify this.

	—Tom

> On Sep 9, 2015:9:01 PM, at 9:01 PM, Andy Bierman <[email-masked]> wrote:
> 
> Hi,
> 
> On Wed, Sep 9, 2015 at 5:38 PM, Nadeau Thomas <[email-masked] <mailto:[email-masked]>> wrote:
> 
>                 Please read http://www.ietf.org/mail-archive/web/netmod/current/msg13510.html <http://www.ietf.org/mail-archive/web/netmod/current/msg13510.html>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>
>

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 10 Sep 2015 17:01:32 +0200 (CEST)

Hi,

I got this, but there is no url to the webex there.  Can you send the
url?

/martin

> >>> 1-650-479-3208 Call-in toll number (US/Canada)
`

---

From: Lou Berger <[email-masked]>
Date: Thu, 10 Sep 2015 11:06:02 -0400

https://ietf.webex.com/ietf/j.php?MTID=m54c7bcbed84a08dc78fba128d500f8c0

---

From: Nadeau Thomas <[email-masked]>
Date: Thu, 10 Sep 2015 11:26:12 -0400

https://ietf.webex.com/ietf/j.php?MTID=m66838a52ebff4cf2879dff9b01f30f44

> On Sep 10, 2015:11:01 AM, at 11:01 AM, Martin Bjorklund <[email-masked]> wrote:
> 
> Hi,
>