Subject: [netmod] And another peak of new YANG models just before the submission deadline

From: Benoit Claise <[email-masked]>
Date: Tue, 20 Oct 2015 09:31:29 +0200

Dear all,

See http://claise.be/IETFYANGPageCompilation.png

Regards ,Benoit

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 20 Oct 2015 08:31:39 +0000

The TOTAL/COMPILATION PASSED ratio seems to have improved since April from ~25% to ~40%. This is good, but there is room for improvement. 

Regards,

Dan

> -----Original Message-----
> From: netmod [mailto:[email-masked]] On Behalf Of Benoit Claise
> Sent: Tuesday, October 20, 2015 10:31 AM
> To: NETMOD Working Group
> Subject: [netmod] And another peak of new YANG models just before the
> submission deadline
> 
> Dear all,
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 20 Oct 2015 08:32:55 +0000

COMPILATION PASSED/TOTAL ratio, sorry.

Dan

> From: Romascanu, Dan (Dan)
> Sent: Tuesday, October 20, 2015 11:32 AM
> To: 'Benoit Claise'; NETMOD Working Group
> Subject: RE: [netmod] And another peak of new YANG models just before
> the submission deadline
> 
> The TOTAL/COMPILATION PASSED ratio seems to have improved since April
> from ~25% to ~40%. This is good, but there is room for improvement.
> 
> Regards,
> 
> Dan
> 
>

---

From: Benoit Claise <[email-masked]>
Date: Tue, 20 Oct 2015 11:08:01 +0200

Dear all,

To extend on Dan's reply: Clearly, there is room for improvement!

The IETF 94 tutorial, 
https://www.ietf.org/meeting/94/tutorials/yang-tutorial-hackathon.html, 
which will explain how to use pyang, should be compulsory for everybody 
posting a YANG model that doesn't compile.  Actually, "must be 
compulsory" :-)

The community has been building all the necessary tools:
- Martin Bjorklund posted pyang version 1.6. Get it from 
https://github.com/mbj4668/pyang
- Carl Moberg built http://www.yangvalidator.com/
- Mahesh and I sent regular direct emails to draft authors, pointing to 
the compilation errors from 
http://www.claise.be/IETFYANGPageCompilation.html
- The tools team (Henrik Levkowetz and Robert Sparks) will be 
incorporating pyang directly in idnits by January.
- And more tools to come at this hackathon.

So no more excuses. At this point, most YANG modules must be compiling.

Regards, Benoit
> .