Subject: Re: [netmod] 6020bis - anydata

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 01 Oct 2015 09:24:52 +0200

Juergen Schoenwaelder <[email-masked]> writes:

> On Wed, Sep 30, 2015 at 01:01:36PM +0200, Ladislav Lhotka wrote:
>> Hi Randy,
>> 
>> thanks for the comments and proposed edits. Please see inline.
>> 
>> Randy Presuhn <[email-masked]> writes:
>> 
>> > Hi -
>> >
>> >>From: Ladislav Lhotka <[email-masked]>
>> >>Sent: Sep 29, 2015 7:07 AM
>> >>To: [email-masked]
>> >>Subject: [netmod] 6020bis - anydata
>> >>
>> >>Hi,
>> >>
>> >>I propose to expand the text in Sec. 7.10 as follows:
>> >>
>> >>OLD
>> >>
>> >>   The "anydata" statement is used to represent an unknown set of nodes
>> >>   that can be modelled with YANG.  An example of where this can be
>> >>   useful is a list of received notifications, where the exact
>> >>   notifications are not known as design time.
>> >>
>> >>NEW
>> >>
>> >>   The "anydata" statement is used to represent an unknown set of nodes
>> >>   that can be modelled with YANG but for which the data model doesn't
>> >>   exist at module design time.
>> >
>> > "doesn't exist" would not be appropriate for the example you provide
>> > below.  It would be incorrect if some of the notifications in your
>> > example had already been defined, even though "anydata" would still
>> > be necessary to handle others not yet defined.
>> 
>> Would "doesn't exist or cannot be determined at module design time" be better?
>>
>
> What about this:
>
>   The "anydata" statement is used to represent a set of nodes that can
>   be modelled with YANG but for which the data model is not known at
>   module design time.

Fine by me. So here is an updated proposal:

OLD

   The "anydata" statement is used to represent an unknown set of nodes
   that can be modelled with YANG.  An example of where this can be
   useful is a list of received notifications, where the exact
   notifications are not known as design time.

NEW

   The "anydata" statement is used to represent an unknown set of nodes
   that can be modelled with YANG but for which the data model is not
   known at module design time. It is possible, though not required, for
   the data model for "anydata" content to become known through protocol
   signalling or other means that are outside the scope of this
   document, as is the server and client behaviour.

   An example of where this can be useful is a list of received
   notifications, where the exact notifications are not known at module
   design time.

Lada

>
> /js
>
> -- 
> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
> Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
> Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 1 Oct 2015 09:33:46 +0200

>    notifications, where the exact notifications are not known at module

While the proposed new text is longer and provides more explanation,
which problem is the new text fixing?

/js

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 1 Oct 2015 10:48:37 +0200

> On 01 Oct 2015, at 09:33, Juergen Schoenwaelder <[email-masked]> wrote:
> 

It helps to make an argument that including a similar text that you proposed in the yang-json document is equally useless.

Lada