Subject: [netmod] anydata interaction with yang-patch and edit config (RE: 6020bis - anydata)

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Mon, 5 Oct 2015 20:46:43 +0000

Hi,

I have two quick questions with regards to anydata - related to the topic of the thread, but concerning a separate topic.  

(1) How does yang-patch interact with anydata?  In particular, could you apply a yang-patch edit to a data node within the anydata?  (While the module may not have been known at design time, it will be known at run time - so presume yes.)

(2) How about edit-config?  Can you use edit config to apply operations to nodes within the anydata, or just to the blob as a whole?  (Again, I would assume you can, as the nodes will be known at run time.)  

Thanks
--- Alex

-----Original Message-----
From: netmod [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Wednesday, September 30, 2015 6:52 AM
To: Ladislav Lhotka <[email-masked]>
Cc: Randy Presuhn <[email-masked]>; [email-masked]
Subject: Re: [netmod] 6020bis - anydata

On Wed, Sep 30, 2015 at 01:01:36PM +0200, Ladislav Lhotka wrote:
> Hi Randy,
> 
> thanks for the comments and proposed edits. Please see inline.
> 
> Randy Presuhn <[email-masked]> writes:
> 
> > Hi -
> >
> >>From: Ladislav Lhotka <[email-masked]>
> >>Sent: Sep 29, 2015 7:07 AM
> >>To: [email-masked]
> >>Subject: [netmod] 6020bis - anydata
> >>
> >>Hi,
> >>
> >>I propose to expand the text in Sec. 7.10 as follows:
> >>
> >>OLD
> >>
> >>   The "anydata" statement is used to represent an unknown set of nodes
> >>   that can be modelled with YANG.  An example of where this can be
> >>   useful is a list of received notifications, where the exact
> >>   notifications are not known as design time.
> >>
> >>NEW
> >>
> >>   The "anydata" statement is used to represent an unknown set of nodes
> >>   that can be modelled with YANG but for which the data model doesn't
> >>   exist at module design time.
> >
> > "doesn't exist" would not be appropriate for the example you provide 
> > below.  It would be incorrect if some of the notifications in your 
> > example had already been defined, even though "anydata" would still 
> > be necessary to handle others not yet defined.
> 
> Would "doesn't exist or cannot be determined at module design time" be better?
>

What about this:

  The "anydata" statement is used to represent a set of nodes that can
  be modelled with YANG but for which the data model is not known at
  module design time.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 05 Oct 2015 23:21:23 +0200 (CEST)

"Alexander Clemm (alex)" <[email-masked]> wrote:
> Hi,
> 
> I have two quick questions with regards to anydata - related to the
> topic of the thread, but concerning a separate topic.
> 
> (1) How does yang-patch interact with anydata?  In particular, could
> you apply a yang-patch edit to a data node within the anydata?  (While
> the module may not have been known at design time, it will be known at
> run time - so presume yes.)
> 
> (2) How about edit-config?  Can you use edit config to apply
> operations to nodes within the anydata, or just to the blob as a
> whole?  (Again, I would assume you can, as the nodes will be known at
> run time.)

The current text says:

  An anydata node is treated as an opaque chunk of data.  This data
  can be modified in its entirety only.

So the answer to both questions are "no".

I don't think that the module necessarily must be known at run-time.

/martin

---

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Mon, 5 Oct 2015 21:21:56 +0000

Thanks, Martin, this is very clear. 

(Too bad actually - I could see applications for this.) 

--- Alex

-----Original Message-----
From: Martin Bjorklund [mailto:[email-masked]] 
Sent: Monday, October 05, 2015 2:21 PM
To: Alexander Clemm (alex) <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [netmod] anydata interaction with yang-patch and edit config

The current text says:

/martin

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 05 Oct 2015 23:27:59 +0200 (CEST)

> (Too bad actually - I could see applications for this.) 

As you noted, this would require the server to know the data models.
Do you have some use case in mind where this would be useful?

/martin

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 06 Oct 2015 09:20:08 +0200

> (Too bad actually - I could see applications for this.)

Making this possible for anydata would be a useful improvement over
anyxml but that would require the server to be able to parse data
submitted in any supported encoding into the same data tree
representation as "normal" data nodes.

Lada

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C