Subject: Re: [netmod] Yang 1.0/1.1 ABNF Grammar: <a string that matches the rule ...>

From: Randy Presuhn <[email-masked]>
Date: Thu, 22 Oct 2015 20:53:25 -0700 (GMT-07:00)

Hi -

>From: Martin Bjorklund <[email-masked]>
>Sent: Oct 22, 2015 6:20 AM
>To: [email-masked]
>Cc: [email-masked]
>Subject: Re: [netmod] Yang 1.0/1.1 ABNF Grammar: <a string that matches the rule ...>
...
>> > 2. Similarly for import-stmt.  Should this have a comment indicating that prefix-stmt or revision-date-stmt can appear in any order?
>> > 
>> >   import-stmt         = import-keyword sep identifier-arg-str optsep
>> >                         "{" stmtsep
>> >                             prefix-stmt
>> >                             [revision-date-stmt]
>> >                         "}" stmtsep
>> 
>> Here it IMO makes little sense to require fixed order.
>
>Correct.  I have added the comment to this statement as well.

Just trying to understand... what problem is solved by
making the grammar more complex here?

Randy

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 23 Oct 2015 09:24:55 +0200 (CEST)

> making the grammar more complex here?

Do you mean for this particular statement?  The idea is that we
shouldn't mandate an order among statements unless there is some
reason for doing so.  Almost all statements are unordered, and it was
simply a bug that we missed this one.

/martin