Subject: [netmod] upstate-reqs #8: ability to retrieve both op-state types together

From: Kent Watsen <[email-masked]>
Date: Wed, 14 Oct 2015 18:56:45 +0000

I created this issue a little more than a week ago, but forgot to CC the list until now - sorry!

GitHub issue #8 (https://github.com/netmod-wg/opstate-reqs/issues/8) says:

====START====
On the interim call, Rob made in interesting point about config+operational, using BGP as an example.

Do we need to amend point 4 to allow for a method to retrieve these in a single operation?

OLD:

   4.  Separation of configuration and operational state data; ability
       to retrieve them independently
       A.  Be able to retrieve only the derived state aspects of
           operational state
       B.  Be able to retrieve only the non-derived state aspects of
           operational state

NEW:

   4.  Separation of configuration and operational state data; ability
       to retrieve them both together and independently
       A.  Be able to retrieve only the derived state aspects of
           operational state
       B.  Be able to retrieve only the non-derived state aspects of
           operational state
       C.  Be able to retrieve both the derived and non-derived state
           aspects of operational state together

====STOP====

Any objections to adding 4C?

Thanks,
Kent

---

From: Robert Wilton <[email-masked]>
Date: Wed, 14 Oct 2015 22:30:33 +0100

Hi Kent,

I support adding this.

Thanks,
Rob

On 14/10/2015 19:56, Kent Watsen wrote:
>
> I created this issue a little more than a week ago, but forgot to CC 
> the list until now – sorry!
>
> On the interim call, Rob made in interesting point about 
> config+operational, using BGP as an example.
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod