Subject: [netmod] draft-ietf-netmod-acl-model-03: remove time-range and put input-interface behind an if-feature

From: "Sterne, Jason (Jason)" <[email-masked]>
Date: Fri, 2 Oct 2015 20:07:43 +0000

(splitting point (A) out of the "RE: [netmod] A few other misc. comments on     draft-ietf-netmod-acl-model-03" thread)

Hi all,

I'd propose we remove time-range from the model for a number of reasons:

1)      I don't think we should build individual time-range functions all over the place in individual modules (likely in slightly different ways).  If we want time-range type functions then I think we should define that in a more generic way that can apply to any configuration items and keep it out of individual modules.

2)      Maybe time range functions are more appropriate up in the client/controller layer anyways

3)      This is not standard base functionality that is uniformly supported in devices that use ACLs

The remaining meta-data item (input-interface) should probably also be removed (same reason #3 as above).  At minimum it should an if-feature.

Regards,
Jason

From: netmod [mailto:[email-masked]] On Behalf Of Sterne, Jason (Jason)
Sent: Sunday, July 19, 2015 13:43
To: [email-masked]
Subject: [netmod] A few other misc. comments on draft-ietf-netmod-acl-model-03

Hi all,

I brought up ACL types and ACE numerical IDs in other separate email threads.  This one is for a set of other misc. comments (one functional, the rest are more editorial).

A) Please make the metadata optional with an if-feature (or make each of input-interface & time-range their own if-features - that is probably better).  Or drop those out of the model and leave them to augmentations.    If we do keep input-interface in the model as an if-feature then:
- should we import ietf-interfaces with just the prefix"if" ?  That is the prefix in the ietf-interfaces module and what is used in the routing model for example.
- shouldn't the input-interface be a leafref (e.g. if:interface-ref) ?

[>>JTS] ...snip...

---

From: "Sterne, Jason (Jason)" <[email-masked]>
Date: Wed, 28 Oct 2015 18:13:29 +0000

Hi all,

This comment is still applicable to the recent version 5 draft.

Any other opinions about this ?  Just wanted to bring it up again a little before IETF94 since this draft is on the agenda.

Regards,
Jason

From: Sterne, Jason (Jason)
Sent: Friday, October 02, 2015 16:08
To: Sterne, Jason (Jason); [email-masked]
Subject: draft-ietf-netmod-acl-model-03: remove time-range and put input-interface behind an if-feature

Hi all,

Regards,
Jason

From: netmod [mailto:[email-masked]] On Behalf Of Sterne, Jason (Jason)
Sent: Sunday, July 19, 2015 13:43
To: [email-masked]<mailto:[email-masked]>
Subject: [netmod] A few other misc. comments on draft-ietf-netmod-acl-model-03

Hi all,

[>>JTS] ...snip...

---

From: Dean Bogdanovic <[email-masked]>
Date: Wed, 28 Oct 2015 15:11:03 -0400

Jason and I spoke on this issue and the question is

Do we want to add time range directly to the standard model or create a separate model for time range that can be then applied to other different nodes? If we decide to keep it as is, then the ask is to if-feature time range.

If there will not be any replies on the mailing list, this will be one question for discussion at the WG mtg

Dean

> On Oct 28, 2015, at 2:13 PM, Sterne, Jason (Jason) <[email-masked]> wrote:
> 
> Hi all,
>  
> To: Sterne, Jason (Jason); [email-masked] <mailto:[email-masked]>
> (splitting point (A) out of the “RE: [netmod] A few other misc. comments on     draft-ietf-netmod-acl-model-03” thread)
>  
> Hi all,
>  
> I’d propose we remove time-range from the model for a number of reasons:
> 1)      I don’t think we should build individual time-range functions all over the place in individual modules (likely in slightly different ways).  If we want time-range type functions then I think we should define that in a more generic way that can apply to any configuration items and keep it out of individual modules.
> From: netmod [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Sterne, Jason (Jason)
> To: [email-masked] <mailto:[email-masked]>
> A) Please make the metadata optional with an if-feature (or make each of input-interface & time-range their own if-features – that is probably better).  Or drop those out of the model and leave them to augmentations.    If we do keep input-interface in the model as an if-feature then:
> - shouldn’t the input-interface be a leafref (e.g. if:interface-ref) ?
>  
> [>>JTS] …snip…
>  
> _______________________________________________
> netmod mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>