Subject: [netmod] [Editorial Errata Reported] RFC7950 (5237)

From: RFC Errata System <[email-masked]>
Date: Thu, 18 Jan 2018 10:47:45 -0800 (PST)

The following errata report has been submitted for RFC7950,
"The YANG 1.1 Data Modeling Language".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5237

--------------------------------------
Type: Editorial
Reported by: Muly Ilan <[email-masked]>

Section: 6.4.1.1

Original Text
-------------
The accessible tree for an action invocation of "reset" on
/a/b[id="1"] with the "when" parameter set to "10" would be:

<a xmlns="urn:example:a">
<b>
<id>1</id>
<reset>
<delay>10</delay>
</reset>
</b>
<b>
<id>2</id>
</b>
</a>
// possibly other top-level nodes here

Corrected Text
--------------
The accessible tree for an action invocation of "reset" on
/a/b[id="1"] with the "delay" parameter set to "10" would be:

<a xmlns="urn:example:a">
<b>
<id>1</id>
<reset>
<delay>10</delay>
</reset>
</b>
<b>
<id>2</id>
</b>
</a>
// possibly other top-level nodes here

Notes
-----
The example action "reset" has an input parameter named "delay" and not a parameter named "when".

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7950 (draft-ietf-netmod-rfc6020bis-14)
--------------------------------------
Title               : The YANG 1.1 Data Modeling Language
Publication Date    : August 2016
Author(s)           : M. Bjorklund, Ed.
Category            : PROPOSED STANDARD
Source              : Network Modeling
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 18 Jan 2018 20:16:07 +0100 (CET)

Hi,

This errata should be applied.  It is an obvious typo.

/martin

---

From: Benoit Claise <[email-masked]>
Date: Thu, 18 Jan 2018 20:35:56 +0100

Thanks.
It's now verified.

Regards, Benoit.
> .