Subject: Re: [netmod] FW: I-D Action: draft-ietf-netmod-rfc8022bis-06.txt

From: "t.petch" <[email-masked]>
Date: Mon, 1 Jan 2018 12:09:23 -0000

----- Original Message -----
From: "Acee Lindem (acee)" <[email-masked]>
Sent: Wednesday, December 27, 2017 5:25 PM

> Hi Benoit,
>
> On 12/27/17, 6:18 AM, "Benoit Claise (bclaise)" <[email-masked]>
wrote:
>
> >Thanks Acee,
> >
> >Minor question for the working group and the
draft-ietf-rtgwg-yang-rip
> >authors.
> >
> >The appendix is about adding a new control-plane protocol. It takes
as
> >an example RIP.
> >However, draft-ietf-rtgwg-yang-rip is being finalized (on the IESG
> >telechat on Jan 11th).
> >Does it make sense to keep the RIP example? If so, is the example
> >consistent with draft-ietf-rtgwg-yang-rip?
> >Or should we just point to draft-ietf-rtgwg-yang-rip as the example?
>
> It is probably better just to reference the RIP module draft. Does
anyone
> disagree?

Disagree; strongly.

You are then holding up as an example to the rest of the world of how to
do it a YANG module produced by a WG over which we have no control and
little influence and who may produce a less than satisfactory module.

I have already commented that IMHO the rip module is not fit to advance
and even if the issues are addressed we have no certainty that the
module will be fit to hold up to the world as an examplar.

So no, referencing yang-rip is a bad idea.

Tom Petch

>
> Thanks,
> Acee
> >
> >Not strong views on my side.
> >
> >Regards, Benoit
> >> This version includes Martin’s YANG doctor comments and some
updates to
> >> the examples (e.g., YANG Library data) from Lada.
> >>
> >> Thanks,
> >> Acee
> >>
> >> On 12/22/17, 1:28 PM, "netmod on behalf of
[email-masked]"
> >> <[email-masked] on behalf of [email-masked]>
wrote:
> >>
> >>> A New Internet-Draft is available from the on-line Internet-Drafts
> >>> directories.
> >>> This draft is a work item of the Network Modeling WG of the IETF.
> >>>
> >>>         Title           : A YANG Data Model for Routing Management
> >>>(NDMA
> >>> Version)
> >>>         Authors         : Ladislav Lhotka
> >>>                           Acee Lindem
> >>>                           Yingzhen Qu
> >>> Filename        : draft-ietf-netmod-rfc8022bis-06.txt
> >>> Pages           : 77
> >>> Date            : 2017-12-22
> >>>
> >>> Abstract:
> >>>    This document contains a specification of three YANG modules
and one
> >>>    submodule.  Together they form the core routing data model that
> >>>    serves as a framework for configuring and managing a routing
> >>>    subsystem.  It is expected that these modules will be augmented
by
> >>>    additional YANG modules defining data models for control-plane
> >>>    protocols, route filters, and other functions.  The core
routing
> >>>data
> >>>    model provides common building blocks for such extensions --
routes,
> >>>    Routing Information Bases (RIBs), and control-plane protocols.
> >>>
> >>>    The YANG modules in this document conform to the Network
Management
> >>>    Datastore Architecture (NMDA).  This document obsoletes RFC
8022.
> >>>
> >>>
> >>> The IETF datatracker status page for this draft is:
> >>> https://datatracker.ietf.org/doc/draft-ietf-netmod-rfc8022bis/
> >>>
> >>> There are also htmlized versions available at:
> >>> https://tools.ietf.org/html/draft-ietf-netmod-rfc8022bis-06
> >>>
https://datatracker.ietf.org/doc/html/draft-ietf-netmod-rfc8022bis-06
> >>>
> >>> A diff from the previous version is available at:
> >>> https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-rfc8022bis-06
> >>>
> >>>
> >>> Please note that it may take a couple of minutes from the time of
> >>> submission
> >>> until the htmlized version and diff are available at
tools.ietf.org.
> >>>
> >>> Internet-Drafts are also available by anonymous FTP at:
> >>> ftp://ftp.ietf.org/internet-drafts/
> >>>
> >>> _______________________________________________
> >>> netmod mailing list
> >>> [email-masked]
> >>> https://www.ietf.org/mailman/listinfo/netmod
> >> _______________________________________________
> >> netmod mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/netmod
> >
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 02 Jan 2018 11:42:35 +0100

On Wed, 2017-12-27 at 17:25 +0000, Acee Lindem (acee) wrote:
> Hi Benoit, 
> 
> On 12/27/17, 6:18 AM, "Benoit Claise (bclaise)" <[email-masked]> wrote:
> 
> > Thanks Acee,
> > 
> > Minor question for the working group and the draft-ietf-rtgwg-yang-rip
> > authors.
> > 
> > The appendix is about adding a new control-plane protocol. It takes as
> > an example RIP.
> It is probably better just to reference the RIP module draft. Does anyone
> disagree?

I tend to disagree. For this document, we need a simple example to illustrate
the steps that need to be done. Any production module, be it ietf-rip or
anything else, necessarily involves some complexity that defeats the purpose of
the example.

In my view, the present RIP example is fine. Perhaps we can extend the
disclaimer saying that it is not intended as a production module and also
provide a non-normative reference to the "real" RIP module.

Lada

> > > This version includes Martin’s YANG doctor comments and some updates to
> > > On 12/22/17, 1:28 PM, "netmod on behalf of [email-masked]"
> > > <[email-masked] on behalf of [email-masked]> wrote:
> > > 
> > > >    This document contains a specification of three YANG modules and one
> > > >    subsystem.  It is expected that these modules will be augmented by
> > > >    protocols, route filters, and other functions.  The core routing
> > > > data
> > > >    model provides common building blocks for such extensions -- routes,
> > > >    The YANG modules in this document conform to the Network Management
> > > >    Datastore Architecture (NMDA).  This document obsoletes RFC 8022.
> > > > 
> > > > 
> > > > until the htmlized version and diff are available at tools.ietf.org.
> > > > 
-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 2 Jan 2018 11:59:04 +0000

Hi Lada, Tom,

Okay - no sense in derailing this draft based on an example if there isn’t
consensus. 

Thanks,
Acee

---

From: Benoit Claise <[email-masked]>
Date: Thu, 4 Jan 2018 13:46:05 +0100

Hi,

While the abstract mentions: "This document obsoletes RFC 8022 
<https://tools.ietf.org/html/rfc8022>.", you forgot the obsolete tag in 
the header.

Regards, Benoit.
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>          Title           : A YANG Data Model for Routing Management (NDMA Version)
>     protocols, route filters, and other functions.  The core routing data
> Please note that it may take a couple of minutes from the time of submission
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> .
>

---

From: Benoit Claise <[email-masked]>
Date: Thu, 4 Jan 2018 13:46:21 +0100

> Okay - no sense in derailing this draft based on an example if there isn’t
Fine with me.

Regards, B.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 4 Jan 2018 13:21:47 +0000

Hi Benoit,
Good catch - I have fixed in the –07 version.
Thanks,
Acee

From: netmod <[email-masked]<mailto:[email-masked]>> on behalf of "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, January 4, 2018 at 7:46 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [netmod] I-D Action: draft-ietf-netmod-rfc8022bis-06.txt

Hi,

While the abstract mentions: "This document obsoletes RFC 8022<https://tools.ietf.org/html/rfc8022>.", you forgot the obsolete tag in the header.

Regards, Benoit.

Abstract:

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-netmod-rfc8022bis-06https://datatracker.ietf.org/doc/html/draft-ietf-netmod-rfc8022bis-06

[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/i-d-announce