Subject: [netmod] Fwd: [OPSAWG] Minor change in [email-masked]

From: Eliot Lear <[email-masked]>
Date: Thu, 8 Feb 2018 17:34:09 +0100

Subject: [OPSAWG] Minor change in [email-masked]
From: "M. Ranganathan" <[email-masked]>
To: [email-masked]
Date: Thu, 8 Feb 2018 11:25:26 -0500
List-Id: OPSA Working Group Mail List <opsawg.ietf.org>

In order to compile the published YANG model with OpenDaylight Yangtools I
had to make the following change ( diff published file vs. changed file is
below ):

583c583
<                 path "../../../../../../acl/name";
---
>                 path "/access-lists/acl/name";
597c597
<                   path "../../../../../../../acl/aces/ace/name";
---
>                   path "/access-lists/acl/aces/ace/name";

I am not sure (don't have enough YANG experience) to know if the error is
with Yangtools or with the published YANG model but I thought I'd send this
information to the list just in case.

Thank you for your attention.

Regards,

Ranga

-- 
M. Ranganathan
_______________________________________________
OPSAWG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/opsawg

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 8 Feb 2018 11:56:30 -0800

> On Feb 8, 2018, at 8:34 AM, Eliot Lear <[email-masked]> wrote:
> 
> 
> 
> Date: February 8, 2018 at 8:25:26 AM PST
> To: [email-masked]
> 
> 
> In order to compile the published YANG model with OpenDaylight Yangtools I had to make the following change ( diff published file vs. changed file is below ):
> 
> 583c583
> >                   path "/access-lists/acl/aces/ace/name”;

That path is correct. And I have four tools (pyang, yanglint, yangdump-pro and confdc) compile the model. Nobody complained about it.

> 
> 
> I am not sure (don't have enough YANG experience) to know if the error is with Yangtools or with the published YANG model but I thought I'd send this information to the list just in case.
> 
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

Mahesh Jethanandani
[email-masked]

---

From: Eliot Lear <[email-masked]>
Date: Thu, 8 Feb 2018 20:58:01 +0100

Ok.

On 08.02.18 20:56, Mahesh Jethanandani wrote:
>
>
>> On Feb 8, 2018, at 8:34 AM, Eliot Lear <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>>
>>
>> *From: *"M. Ranganathan" <[email-masked] <mailto:[email-masked]>>
>> *Subject: **[OPSAWG] Minor change in
>> [email-masked]
>> <mailto:[email-masked]>*
>> *Date: *February 8, 2018 at 8:25:26 AM PST
>> *To: [email-masked] <mailto:[email-masked]>
>>
>>
>> In order to compile the published YANG model with OpenDaylight
>> Yangtools I had to make the following change ( diff published file
>> vs. changed file is below ):
>>
>> 583c583
> That path is correct. And I have four tools (pyang, yanglint,
> yangdump-pro and confdc) compile the model. Nobody complained about it.
>
>>
>>
>> I am not sure (don't have enough YANG experience) to know if the
>> error is with Yangtools or with the published YANG model but I
>> thought I'd send this information to the list just in case.
>>
>> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
>

---

From: Jan Lindblad <[email-masked]>
Date: Fri, 9 Feb 2018 10:20:59 +0100

Eliot,

> Thank you for your attention.

Both the old and the new path look valid to me. Even if you can always replace a relative path with an absolute from a YANG validity perspective, changing from relative to absolute paths often *changes the semantics*, so that is not generally safe. In this case, however, they do amount to the same thing (since they both end up going all the way up to the top level container).

/jan

---

From: Eliot Lear <[email-masked]>
Date: Fri, 9 Feb 2018 10:28:39 +0100

This may be. bug in OpenDaylight that is being tickled.  Ranga is
chasing it a bit.

---

From: Kent Watsen <[email-masked]>
Date: Fri, 9 Feb 2018 21:23:56 +0000

Yes, it may be a bug in ODL, but I also think that there is something wrong to use such a long relative path.  In that case, the relative path is actually longer than the absolute path!  That said, there is no guidance in rfc6087bis currently, so we may need to let it go this time.

K. // shepherd

===== original message =====