Subject: [netmod] I-D Action: draft-chopps-netmod-geo-location-00.txt

From: Christian Hopps <[email-masked]>
Date: Wed, 27 Feb 2019 21:39:33 -0500

FYI.

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: I-D Action: draft-chopps-netmod-geo-location-00.txt
> Date: February 26, 2019 at 3:59:23 PM EST
> To: <[email-masked]>
> Reply-To: [email-masked]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>        Title           : YANG Geo Location
>        Author          : Christian Hopps
> 	Filename        : draft-chopps-netmod-geo-location-00.txt
> 	Pages           : 17
> 	Date            : 2019-02-26
> 
> Abstract:
>   This document defines a generic geographical location object YANG
>   grouping.  The geographical location grouping is intended to be used
>   in YANG models for specifying a location on or in reference to the
>   Earth or any other astronomical object.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-chopps-netmod-geo-location/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-chopps-netmod-geo-location-00
> https://datatracker.ietf.org/doc/html/draft-chopps-netmod-geo-location-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Kent Watsen <[email-masked]>
Date: Thu, 28 Feb 2019 15:38:28 +0000

This is a neat draft.   Reminds me of when I worked on the Virtual Reality and
real-time simulations.    I once wrote a class to convert locations, vectors, and
orientations to and from WGS84 geocentric coordinate space and topocentric
coordinate space systems.   I was fresh out of college with a Math degree, so
of course they gave it to the new guy (me) to figure out  ;)

Anyway, while WGS84 appears to still be applicable, it looks like a lot of other
standards work has occurred since.   I'd have to dig into it to provide a deeper
comment.   From a gap-perspective, it seems that this module covers locations,
but not vectors or orientations (intentional?) Note: "heading" defines a value in
just a single dimension, so doesn't work for VR.   From an add-perspective, I'm
surprised to see "speed" included here, at least we always had 1st (and 2nd)
order temporal information defined elsewhere.

Kent // contributor

> On Feb 27, 2019, at 9:39 PM, Christian Hopps <[email-masked]> wrote:
> 
> FYI.
> 
>> Begin forwarded message:
>> 
>> From: [email-masked] <mailto:[email-masked]>
>> To: <[email-masked] <mailto:[email-masked]>>
>> Reply-To: [email-masked] <mailto:[email-masked]>
>> 
>> 
>> https://datatracker.ietf.org/doc/draft-chopps-netmod-geo-location/ <https://datatracker.ietf.org/doc/draft-chopps-netmod-geo-location/>
>> 
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Christian Hopps <[email-masked]>
Date: Thu, 28 Feb 2019 12:10:24 -0500

> of course they gave it to the new guy (me) to figure out  ;)

Thanks. :)

> order temporal information defined elsewhere.

So yeah, there seems to be limitless amounts of work going on at least related or involving this topic.

Regarding WGS84, the WGS84 geoid has been updated multiple times that's what the EGM96 and EGM08 are all about. Each one getting better at handling local gravitational variance, which affects actual sea levels. The original WGS84 was actually very inaccurate. The EGM (earth gravitational model) updates have been fixing this based on data from various satellite missions.

Regarding movement: The point here is to define a geographical location -- so there is a concept of stability involved. It seemed reasonable to include relatively stable movement as well, key thing being stable (e.g., continental drift). Once you start trying to describe motion, all bets are off and we aren't really talking about geographical locations anymore. The text specifically mentions it's not trying to handle 2nd and further derivative motion (or I thought it did :)

I do think I may need to add a second value to the velocity vector to handle 3d movement though as continents are actually moving in 3 dimensions (rising and sinking as well as moving on the globe).

I may also need to add something to indicate the height value being relative to ground (or more). At first I thought this could be captured by a variation of the geodeditc-datum value, but on further thought I think that might not be the right solution -- we also may want to be able to specify multiple different things the height could be relative too (e.g., the ground floor or basement of a building), not just the ground itself.

Orientation (e.g., the way a camera is pointed or what it's focal length is, etc) seems out of scope -- those aren't attributes of location they are describing something else. Orientation, etc, are covered with KML though.

Thanks,
Chris.