Subject: [netmod] I-D Action: draft-ietf-netmod-yang-data-ext-02.txt

From: [email-masked]
Date: Thu, 07 Mar 2019 23:11:23 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Modeling WG of the IETF.

        Title           : YANG Data Structure Extensions
        Authors         : Andy Bierman
                          Martin Bjorklund
                          Kent Watsen
	Filename        : draft-ietf-netmod-yang-data-ext-02.txt
	Pages           : 14
	Date            : 2019-03-07

Abstract:
   This document describes YANG mechanisms for defining abstract data
   structures with YANG.  It is intended to replace and extend the
   "yang-data" extension statement defined in RFC 8040.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netmod-yang-data-ext/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-netmod-yang-data-ext-02
https://datatracker.ietf.org/doc/html/draft-ietf-netmod-yang-data-ext-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-yang-data-ext-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Fri, 15 Mar 2019 14:16:10 +0000

Hi, 

Two minor questions on this draft.

(1) In the definition of the structure and augment-structure extensions, should the draft explicitly state what the canonical statement ordering is?  Although TBH, the ordering is pretty intuitive.

(2) Probably beyond the scope of this draft, but does there need to be any thought about how SIDs (draft-ietf-core-sid-05) are allocated to YANG data extensions?

Thanks,
Rob

-----Original Message-----
From: netmod <[email-masked]> On Behalf Of [email-masked]
Sent: 08 March 2019 07:11
To: [email-masked]
Cc: [email-masked]
Subject: [netmod] I-D Action: draft-ietf-netmod-yang-data-ext-02.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod