Subject: Re: [netmod] Adoption poll for draft-wu-netmod-factory-default-02

From: Qin Wu <[email-masked]>
Date: Tue, 26 Mar 2019 04:58:15 +0000

Thanks Andy, see reply inline.

发件人: netmod [mailto:[email-masked]] 代表 Andy Bierman
发送时间: 2019年3月26日 6:11
收件人: Kent Watsen <[email-masked]>
抄送: NetMod WG <[email-masked]>
主题: Re: [netmod] Adoption poll for draft-wu-netmod-factory-default-02

On Mon, Mar 25, 2019 at 1:35 PM Kent Watsen <[email-masked]<mailto:[email-masked]>> wrote:
This email begins a 2-week adoption poll for:

    https://tools.ietf.org/html/draft-wu-netmod-factory-default-02

Please voice your support or objections before April 8.

I have significant concerns about this draft and work item.
The intentions are good and the scope is well-defined.
The problem is that this is a very proprietary implementation detail.

I have already raised the issue that our server cannot factory reset a single datastore.
It can only do that for the whole server (which will setup the datastores
in an implementation manner and order). So another RPC is needed, and if-features..
[Qin]: We allow to reset multiple target datastore within the server, that means we have capability to
Reset all target datastores in the server. In the YANG module, we do add a note to say:
“
      // Do we need an extra parameter that may order a restart of
      // the YANG-server or the whole system?
”
So thanks Andy, we are aware this issue.
I have seen some comments on this issue: "This is great but our server
does not work that way, so we need X,Y,Z"  (Just like I am doing ;-)
How will the WG keep that from happening 10 or 30 times?

I support this work if the WG can figure out how to keep it simple.
(Meaning I support adoption of the work but not going to wait 2+ years for it)
[Qin]: Thanks, that is also the goal we set for this draft.

Kent (and Lou)

Andy

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

---

From: Qin Wu <[email-masked]>
Date: Tue, 26 Mar 2019 13:37:08 +0000

发件人: Kent Watsen [mailto:[email-masked]]
发送时间: 2019年3月26日 15:37
收件人: Rob Wilton (rwilton) <[email-masked]>
抄送: Kent Watsen <[email-masked]>; [email-masked]; Balázs Lengyel <[email-masked]>; Qin Wu <[email-masked]>
主题: Re: [netmod] Adoption poll for draft-wu-netmod-factory-default-02

I would rather see <copy-config> fixed more generically to allow copying between two configuration datastores than specifically augmenting specifically for this datastore.  Hence, I think that extending/replacing the <copy-config> RPC could probably be deferred to a NETCONF-bis or NETCONF-NMDA-bis document.

Agreed.  Qin, please add to the NETCONF-next issue tracker.

https://github.com/netconf-wg/netconf-next/issues<https://github.com/netconf-wg/netconf-next/issues/>

[Qin]: Done.
Kent

---

From: Susan Hares <[email-masked]>
Date: Tue, 26 Mar 2019 10:04:57 -0400

Kent:

This is a useful feature.  The draft is a good place to start the 
work, but there are issues that need to be agreed upon.

Sue

On Monday 25/03/2019 at 4:35 pm, Kent Watsen  wrote:
> Kent (and Lou)_______________________________________________
> netmod mailing list
> [email-masked]