Subject: Re: [netmod] error-message

From: JOEY BOYD <[email-masked]>
Date: Mon, 25 Mar 2019 14:55:08 +0000

Hi,

I wanted to follow up on this as I have not received any feedback. I thinking now that even though it is isn't specifically called out in the update section, that adding an error-message could be backward compatible as it has no impact on the data or modeled constraint. It merely defines the error response which was previously up to the implementation to determine.

Any thoughts on this?

Regards,
Joey

From: JOEY BOYD
Sent: Monday, March 4, 2019 9:37 AM
To: [email-masked]' <[email-masked]>
Subject: error-message

Hi,

Is the addition of an 'error-message' to an existing 'must' statement considered backward compatible? I don't see 'error-message' mentioned in the "Updating a Module" section which leads me to believe that it isn't but wanted to double check to see what implications adding one to an existing module would have.

Thanks and regards,
Joey

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 25 Mar 2019 21:14:04 +0100 (CET)

Hi,

I think that this should be listed as an acceptable change in secion
11.  Something to fix if we do YANg 1.2.

/martin

JOEY BOYD <[email-masked]> wrote:
> Hi,
> 
> I wanted to follow up on this as I have not received any feedback. I
> thinking now that even though it is isn't specifically called out in
> the update section, that adding an error-message could be backward
> compatible as it has no impact on the data or modeled constraint. It
> merely defines the error response which was previously up to the
> implementation to determine.
> 
> Any thoughts on this?
> 
> Regards,
> Joey
> 
> From: JOEY BOYD
> Is the addition of an 'error-message' to an existing 'must' statement
> considered backward compatible? I don't see 'error-message' mentioned
> in the "Updating a Module" section which leads me to believe that it
> isn't but wanted to double check to see what implications adding one
> to an existing module would have.
> 
> Thanks and regards,
> Joey
>