Subject: [netmod] Fwd: New Version Notification for draft-ietf-netmod-nmda-diff-01.txt

From: Alexander Clemm <[email-masked]>
Date: Tue, 21 May 2019 21:24:01 -0700

Hello Netmod WG,

we have just posted a new revision of draft-ietf-netmod-nmda-diff.  The 
new revision adds the inclusion of the both the source and target values 
to the result of the comparison; for this purpose, the YANG-Patch 
grouping was augmented accordingly.

--- Alex

-------- Forwarded Message --------
Subject: 	New Version Notification for draft-ietf-netmod-nmda-diff-01.txt
Date: 	Tue, 21 May 2019 21:15:58 -0700
From: 	[email-masked]
To: 	Andy Bierman <[email-masked]>, Yingzhen Qu <[email-masked]>, 
Alexander Clemm <[email-masked]>, Jeff Tantsura <[email-masked]>

A new version of I-D, draft-ietf-netmod-nmda-diff-01.txt
has been successfully submitted by Alexander Clemm and posted to the
IETF repository.

Name:		draft-ietf-netmod-nmda-diff
Revision:	01
Title:		Comparison of NMDA datastores
Document date:	2019-05-23
Group:		netmod
Pages:		15
URL:            https://www.ietf.org/internet-drafts/draft-ietf-netmod-nmda-diff-01.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-netmod-nmda-diff/
Htmlized:       https://tools.ietf.org/html/draft-ietf-netmod-nmda-diff-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-netmod-nmda-diff
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-nmda-diff-01

Abstract:
    This document defines an RPC operation to compare management
    datastores that comply with the NMDA architecture.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Kent Watsen <[email-masked]>
Date: Thu, 23 May 2019 03:11:29 +0000

It's great to see activity on this draft.   However, authors should close open items on list before posting updates.   Specifically, there are open items from the adoption-poll, the 103 meeting minutes, and the emails Andy and Juergen sent on Nov 6.

PS: as a contributor, the update seems incomplete without an example illustrating the new 'source-value' element.

Kent   // chair

> On May 22, 2019, at 12:24 AM, Alexander Clemm <[email-masked]> wrote:
> 
> Hello Netmod WG,
> 
> we have just posted a new revision of draft-ietf-netmod-nmda-diff.  The new revision adds the inclusion of the both the source and target values to the result of the comparison; for this purpose, the YANG-Patch grouping was augmented accordingly.  
> 
> --- Alex
> 
> 
> From:	[email-masked] <mailto:[email-masked]>
> To:	Andy Bierman <[email-masked]> <mailto:[email-masked]>, Yingzhen Qu <[email-masked]> <mailto:[email-masked]>, Alexander Clemm<[email-masked]> <mailto:[email-masked]>, Jeff Tantsura <[email-masked]> <mailto:[email-masked]>
> 
> URL:            https://www.ietf.org/internet-drafts/draft-ietf-netmod-nmda-diff-01.txt <https://www.ietf.org/internet-drafts/draft-ietf-netmod-nmda-diff-01.txt>
> Status:         https://datatracker.ietf.org/doc/draft-ietf-netmod-nmda-diff/ <https://datatracker.ietf.org/doc/draft-ietf-netmod-nmda-diff/>
> Htmlized:       https://tools.ietf.org/html/draft-ietf-netmod-nmda-diff-01 <https://tools.ietf.org/html/draft-ietf-netmod-nmda-diff-01>
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-netmod-nmda-diff <https://datatracker.ietf.org/doc/html/draft-ietf-netmod-nmda-diff>
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-nmda-diff-01 <https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-nmda-diff-01>
> 
> Abstract:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Alexander Clemm <[email-masked]>
Date: Mon, 27 May 2019 23:55:34 -0700

Hi Kent,

thank you for your comments!

Regarding example, yes, I agree, we need to add examples and will do so 
in the next revision.

Per your suggestion, I looked again at the 103 minutes. They do state 
that we should come up with a single format, hence the option to select 
from different formats has been removed.    Now, which specific format 
to select is the topic of the discussion items in the Juergen's and 
Andy's emails from Nov 6.  This concerned the question whether the diff 
was to be computed against the tree, vs a textual representation of the 
tree, and if the latter, what the serialization would be. If I interpret 
the sentiment in those emails correctly, the sentiment is that the diff 
should be computed against the tree.  This is what is reflected in the 
current revision; the representation of differences leverages YANG-Patch 
(RFC 8072) and the "source-value" element extrapolates this to include 
the source values.  Of course, we can consider alternatives; this is one 
proposal.

The other item that was raised concerns whether to include diff'ing on 
metadata.  Whether this is needed probably requires further discussion.  
Personally, I think this is a useful feature but it has not been 
included in this revision.

--- Alex

On 5/22/2019 8:11 PM, Kent Watsen wrote:
> It's great to see activity on this draft.   However, authors should 
> close open items on list before posting updates.   Specifically, there 
> are open items from the adoption-poll, the 103 meeting minutes, and 
> the emails Andy and Juergen sent on Nov 6.
>
> PS: as a contributor, the update seems incomplete without an example 
> illustrating the new 'source-value' element.
>
> Kent   // chair
>
>
>
>> On May 22, 2019, at 12:24 AM, Alexander Clemm <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> Hello Netmod WG,
>>
>> we have just posted a new revision of draft-ietf-netmod-nmda-diff.  
>> The new revision adds the inclusion of the both the source and target 
>> values to the result of the comparison; for this purpose, the 
>> YANG-Patch grouping was augmented accordingly.
>>
>> --- Alex
>>
>>
>> To: 	Andy Bierman <[email-masked]>, Yingzhen Qu 
>> <[email-masked]>, Alexander Clemm <[email-masked]>, Jeff 
>> Tantsura <[email-masked]>
>>
>>
>>
>> URL:https://www.ietf.org/internet-drafts/draft-ietf-netmod-nmda-diff-01.txt
>> Status:https://datatracker.ietf.org/doc/draft-ietf-netmod-nmda-diff/
>> Htmlized:https://tools.ietf.org/html/draft-ietf-netmod-nmda-diff-01
>> Htmlized:https://datatracker.ietf.org/doc/html/draft-ietf-netmod-nmda-diff
>> Diff:https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-nmda-diff-01
>>
>> Abstract:
>> until the htmlized version and diff are available attools.ietf.org <http://tools.ietf.org>.
>>
>> The IETF Secretariat
>>
>> [email-masked] <mailto:[email-masked]>