Subject: Re: [netmod] Adoption poll for draft-wu-netmod-factory-default-02

From: Qin Wu <[email-masked]>
Date: Tue, 7 May 2019 01:57:26 +0000

Thanks Joe, please see reply inline below.
发件人: Joe Clarke (jclarke) [mailto:[email-masked]]
发送时间: 2019年5月6日 23:12
收件人: Qin Wu <[email-masked]>
抄送: Kent Watsen <[email-masked]>; [email-masked]
主题: Re: [netmod] Adoption poll for draft-wu-netmod-factory-default-02

On May 6, 2019, at 08:06, Qin Wu <[email-masked]<mailto:[email-masked]>> wrote:

Hi, Chairs:
Sorry for late follow up, thanks Jurgen, Andy,Joe, Joel and all others for good comments, here is the update based on discussion and suggestion on the mailing list
The diff is:
https://www.ietf.org/rfcdiff?url2=draft-wu-netmod-factory-default-03

Hey, Qin.  I read through the changes, and I have a couple of additional comments.

First, the term “YANG server” sounds odd to me.  I know what you mean, but I haven’t seen this defined before.  Maybe just saying a device or host is sufficient?

[Qin]: Right, “host”, in my opinion, is not a term used in the context of NETCONF, it is also usually referred to end device in many cases, I prefer to use device. The device should have YANG capability.
When you talk about the datastore to be reset, you list <running>, <startup>, and <candidate>.  You state that each will receive the contents of <factory-default>.  The <candidate> DS wouldn’t need that.  I think it would just be zeroed out.

[Qin]: I have no strong opinion for this, <candidate> is also part of read-write configuration datastores, we could reset <candidate>, but I think it is not recommended based on what you say.

I think the RPC should reset any and all non-derived read-write datastores and not imply that a specific DS’s contents (i.e., the factory-default DS) is copied to them.  This way, other DSes would just be handled by this RPC based on implementation.  The <factory-default> can exist as the factory default contents for <startup>.
[Qin]: We have decoupled <factory-reset> rpc from <factory-default> datastore, since <factory-default> datastore is defined as optional datastore in the current version, <factory-default> content can be specified in many different ways, not limited to take content of <factory-default> datastore.
Also <factory-default> content is referred to preconfigured initial configuration that can be used to initialize the configuration of a server.
These will address your comment.

Joe

We believe it is ready for second adoption poll. Thanks!

-Qin (on behalf of authors)
发件人: netmod [mailto:[email-masked]] 代表 Kent Watsen
发送时间: 2019年4月9日 2:36
收件人: [email-masked]<mailto:[email-masked]>
主题: Re: [netmod] Adoption poll for draft-wu-netmod-factory-default-02

This message concludes the adoption poll for draft-wu-netmod-factory-default-02   The working group consensus supports working on the problem, but fundamental concerns were raised regarding the solution, specifically around reseting datastores versus resetting devices.  The chairs feel that these issues should be addressed before proceeding with the adoption.

Authors, please update and resubmit the draft addressing the comments received during the adoption poll.  Another adoption poll will be issued when ready.
Thank you,
Kent (and Lou and Joel)

On Mar 25, 2019, at 4:34 PM, Kent Watsen <[email-masked]<mailto:[email-masked]>> wrote:

This email begins a 2-week adoption poll for:

    https://tools.ietf.org/html/draft-wu-netmod-factory-default-02

Please voice your support or objections before April 8.<x-apple-data-detectors://1>

Kent (and Lou)
_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Thu, 9 May 2019 14:27:23 +0000

Seems like suggestions from Martin and Jürgen will sort this out.

That’s my point.  I don’t think you want to really do anything with <candidate>.  Resetting <startup> and for runtime, <running> would seem to be sufficient (modulo other DSes the system may support).

You still mention that you copy these contents as part of the RPC (or maybe I misread).  This is what led to my confusion.

Joe