Subject: [netmod] Add network instance name on interface, IPv4, IPv6

From: Qin Wu <[email-masked]>
Date: Mon, 5 Aug 2019 14:05:50 +0000

Hi, authors:

In RFC8529, the bind-network-instance-name leaf provides the association between an interface and its associated NI.

However it is not clear to me why the same association between Ipv4/Ipv6 type and its association NI

Should be provided as well? See model structure snippet defined in RFC8529 as follows:
"
   augment /if:interfaces/if:interface:
     +--rw bind-ni-name?   -> /network-instances/network-instance/name
   augment /if:interfaces/if:interface/ip:ipv4:
     +--rw bind-ni-name?   -> /network-instances/network-instance/name
   augment /if:interfaces/if:interface/ip:ipv6:
     +--rw bind-ni-name?   -> /network-instances/network-instance/name
"

So the question is

Can we add different NI name for IPv4/IPv6 type? Isn't IPv4 type and IPv6 type and interface pointing to the same NI name?

Why IPv4 type and IPv6 type in IP data model can not inherit the same NI name from the interface model since IP Data model is an extension to Interface Data Model?
Suppose we configure interface and associated IP addresses and assign this interface to a NI,
Which configuration snippet is correct:
Option A:
{
"name": "eth1",
"type": "iana-if-type:ethernetCsmacd",
"ietf-ip:ipv4": {
"address": [
{
"ip": "192.0.2.11",
"prefix-length": 24
}
]
"ietf-network-instance:bind-network-instance-name": "vrf-red"
},
"ietf-ip:ipv6": {
"address": [
{
"ip": "2001:db8:0:2::11",
"prefix-length": 64
}
]
"ietf-network-instance:bind-network-instance-name": "vrf-red"
},
"ietf-network-instance:bind-network-instance-name": "vrf-red"
},
Option B:
{
"name": "eth1",
"type": "iana-if-type:ethernetCsmacd",
"ietf-ip:ipv4": {
"address": [
{
"ip": "192.0.2.11",
"prefix-length": 24
}
]
},
"ietf-ip:ipv6": {
"address": [
{
"ip": "2001:db8:0:2::11",
"prefix-length": 64
}
]
},
"ietf-network-instance:bind-network-instance-name": "vrf-red"
},

-Qin

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 5 Aug 2019 16:46:44 +0000

Hi Qin,

From: Qin Wu <[email-masked]>
Date: Monday, August 5, 2019 at 10:11 AM
To: "[email-masked]" <[email-masked]>
Cc: Routing WG <[email-masked]>, "[email-masked]" <[email-masked]>, "Wangleilei (DOPRA SSP)" <[email-masked]>
Subject: Add network instance name on interface, IPv4, IPv6
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, Christian Hopps <[email-masked]>, Acee Lindem <[email-masked]>, Dean Bogdanovic <[email-masked]>, <[email-masked]>, <[email-masked]>, Jeff Tantsura <[email-masked]>, Yingzhen Qu <[email-masked]>, Alia Atlas <[email-masked]>, Martin Vigoureux <[email-masked]>, Deborah Brungard <[email-masked]>, Alvaro Retana <[email-masked]>, Yingzhen Qu <[email-masked]>
Resent-Date: Monday, August 5, 2019 at 10:11 AM

Hi, authors:

“
“

So the question is

Can we add different NI name for IPv4/IPv6 type? Isn’t IPv4 type and IPv6 type and interface pointing to the same NI name?

The model allows the IPv4/IPv6 level of granularity for network-instance specification. However, many, if not most, implementations do not. My memory is hazy as to which implementation(s) supports this.

Thanks,
Acee

-Qin