Subject: [netmod] New Version draft-shytyi-netmod-vysm-02.txt as Working Group document.

From: Dmytro Shytyi <[email-masked]>
Date: Tue, 27 Aug 2019 18:03:42 +0200

Dear All,

I am one of the authors of ID VYSM and I would like to draw your attention to the evolution of the draft https://www.ietf.org/internet-drafts/draft-shytyi-netmod-vysm-01.txt.

Recently we produced (but did not submitted yet) a new version of ID (02) and I beleive it fits the netmod working group.

We would be gratefull if you could suggest if the new version(02) of the document  could become an official work item of the WG?

      If yes, could you please indicate which modifications must be done in the document before submition.

After reading the https://tools.ietf.org/html/rfc2026 it seems the document may fit multiple different "Intended statuses". Currentry it has "Informational" intended status. Could you please express your suggestion: which intended status is more appropriate for the current document? Shoult it be Experimental or BCP?

Thank you for your time.

Best Regards,

______________
Dmytro SHYTYI

============ Forwarded message ============
From:  <mailto:[email-masked]>
To: "Dmytro Shytyi"<mailto:[email-masked]>
Date: Thu, 28 Mar 2019 12:24:35 +0100
Subject: New Version Notification for draft-shytyi-netmod-vysm-01.txt
============ Forwarded message ==========

A new version of I-D, draft-shytyi-netmod-vysm-01.txt 
has been successfully submitted by Dmytro Shytyi and posted to the 
IETF repository. 
 
Name:        draft-shytyi-netmod-vysm 
Revision:    01 
Title:        Virtualization YANG Servise Model (VYSM) 
Document date:    2019-03-27 
Group:        Individual Submission 
Pages:        9 
URL: https://www.ietf.org/internet-drafts/draft-shytyi-netmod-vysm-01.txt 
Status: https://datatracker.ietf.org/doc/draft-shytyi-netmod-vysm/ 
Htmlized: https://tools.ietf.org/html/draft-shytyi-netmod-vysm-01 
Htmlized: https://datatracker.ietf.org/doc/html/draft-shytyi-netmod-vysm 
Diff: https://www.ietf.org/rfcdiff?url2=draft-shytyi-netmod-vysm-01 
 
Abstract: 
 This document provides a specification of the Virtual Network 
 Functions YANG Service Model (VYSM).  The VNF YANG Service Model 
 serves as a base framework for managing an universal Customer- 
 Premises Equipment (uCPE) NFV subsystem from the Orchestrator.

---

From: Robert Varga <[email-masked]>
Date: Wed, 28 Aug 2019 01:44:05 +0200

On 27/08/2019 18:03, Dmytro Shytyi wrote:
> Dear All,
> 
> I am one of the authors of ID VYSM and I would like to draw your
> attention to the evolution of the
> draft https://www.ietf.org/internet-drafts/draft-shytyi-netmod-vysm-01.txt.
> Recently we produced (but did not submitted yet) a new version of ID
> (02) and I beleive it fits the netmod working group.
> 
> We would be gratefull if you could suggest if the new version(02) of the
> document  could become an official work item of the WG?

Hmm, looking over the model, it would seem there is quite a bit of
overlap with RFC8345 -- to the point I believe the model could be
formulated in terms of RFC8345 specialization:

virtualization -> networks/network

device/links/interfaces/switches/vms are probably a mix of
node/termmination-point/link extensions with conjunction with
supporting-{topology,node,link}.

How would the draft relate to RFC8345? Should it perhaps call out it is
a different take on the similar problem, specialized to a particular
use-case?

Regards,
Robert (with RFC8345 co-author hat on)

---

From: Dmytro Shytyi <[email-masked]>
Date: Wed, 28 Aug 2019 15:45:39 +0200

Hello,

Please find comments inline.

>>       If yes, could you please indicate which modifications must be done

>> in the document before submition.

>formulated in terms of RFC8345 specialization:

First of all I would like to thank you for this comment.  

-Dmytro

>supporting-{topology,node,link}.

I can imagine mapping:

virtualization (ID) -> networks/network (RFC 8345)

links (ID)- >link;(RFC 8345)

ports (ID)-> termination points;(RFC 8345)

But still.. it seems here we have to create extension of the model proposed in RFC 8345.

Precisely for node (RFC 8345) we may add types (switches, vms) and futer add leafs /listsfor type if required (ex: #RAM,#vCPUs and other leafs for VMs)

-Dmytro

>use-case?

One can suggest that  in the RFC8345 Figure 1, the block "service Topology model" can include the proposed in the draft network service descriptor with appropriate modification of mapping according to the RFC8345. 

Meanwhile I find that the proposed solution(ID) try to solve the problem descibed below:

The uCPE management mechanism may involve not only YANG modules but  also the speficif logic written in programming languages. The proposed organisation of yang model is an attempt to find the best fit  for combination (YANG modules + specific logic written in python for example )  to manage different existing NFVIs in the uCPE (by the orchestrator). 

In the case of uCPE, the mapping (w/wo additinal logic) of "variables " between service yang modules (in the orchestrator) and NETCONF payload(that is sent to the uCPE) will be more complex (requires additional transformations in the logic) with generic approach, then the solution presented in the ID, that is tailored to the uCPE. 

Therefore I find the proposed solution as a stadalone generic approach to manage multiple vendor uCPE that appears to be a particular case tailored for uCPE NFVIs that may be not nesseraly follows RFC8345. I would be pleased if you could comment this.

-Dmytro

>+1, in addition, I am wondering whether this is something related to overlay topology model, if yes, how it is different from DC Fabric topology model defined in RFC8542? 

>-Qin 

Thank you for your comment. The RFC8542 condisers PODs in the DC network. uCPE is located on the customer site. if we consider that uCPE is A POD (with links and nodes like VMs and swithces) then in the RFC8542 describes different PODs in the  network that are interconnected with links. The yang model proposed in the ID ifocuses only on the uCPE interiour network service, not the interconnection between the uCPEs. Aslo, I explained the difference about extension neded for type of nodes,vms leafs and furter complexity in the mapping logic in the reponce to Robert.

-Dmytro

Best regards,

Dmytro.