Subject: Re: [netmod] New Version draft-shytyi-netmod-vysm-02.txt as Working Group document.

From: Qin Wu <[email-masked]>
Date: Thu, 29 Aug 2019 02:00:01 +0000

Dmytro:
发件人: Dmytro Shytyi [mailto:[email-masked]]
发送时间: 2019年8月28日 21:46
收件人: Robert Varga <[email-masked]>; Qin Wu <[email-masked]>
抄送: netmod <[email-masked]>
主题: Re: [netmod] New Version draft-shytyi-netmod-vysm-02.txt as Working Group document.

Hello,
Please find comments inline.

>On 27/08/2019 18:03, Dmytro Shytyi wrote:
>> Dear All,
>>
>> I am one of the authors of ID VYSM and I would like to draw your
>> attention to the evolution of the
>> draft https://www.ietf.org/internet-drafts/draft-shytyi-netmod-vysm-01.txt.
>> Recently we produced (but did not submitted yet) a new version of ID
>> (02) and I beleive it fits the netmod working group.
>>
>> We would be gratefull if you could suggest if the new version(02) of the
>> document  could become an official work item of the WG?
>>       If yes, could you please indicate which modifications must be done
>> in the document before submition.
>
>Hmm, looking over the model, it would seem there is quite a bit of
>overlap with RFC8345 -- to the point I believe the model could be
>formulated in terms of RFC8345 specialization:

First of all I would like to thank you for this comment.
-Dmytro
>virtualization -> networks/network
>
>device/links/interfaces/switches/vms are probably a mix of
>node/termmination-point/link extensions with conjunction with
>supporting-{topology,node,link}.

I can imagine mapping:
virtualization (ID) -> networks/network (RFC 8345)
links (ID)- >link;(RFC 8345)
ports (ID)-> termination points;(RFC 8345)

But still.. it seems here we have to create extension of the model proposed in RFC 8345.
Precisely for node (RFC 8345) we may add types (switches, vms) and futer add leafs /listsfor type if required (ex: #RAM,#vCPUs and other leafs for VMs)
-Dmytro

>How would the draft relate to RFC8345? Should it perhaps call out it is
>a different take on the similar problem, specialized to a particular
>use-case?

One can suggest that  in the RFC8345 Figure 1, the block "service Topology model" can include the proposed in the draft network service descriptor with appropriate modification of mapping according to the RFC8345.

Meanwhile I find that the proposed solution(ID) try to solve the problem descibed below:

The uCPE management mechanism may involve not only YANG modules but  also the speficif logic written in programming languages. The proposed organisation of yang model is an attempt to find the best fit  for combination (YANG modules + specific logic written in python for example )  to manage different existing NFVIs in the uCPE (by the orchestrator).
In the case of uCPE, the mapping (w/wo additinal logic) of "variables " between service yang modules (in the orchestrator) and NETCONF payload(that is sent to the uCPE) will be more complex (requires additional transformations in the logic) with generic approach, then the solution presented in the ID, that is tailored to the uCPE.

Therefore I find the proposed solution as a stadalone generic approach to manage multiple vendor uCPE that appears to be a particular case tailored for uCPE NFVIs that may be not nesseraly follows RFC8345. I would be pleased if you could comment this.
-Dmytro

>Regards,
>Robert (with RFC8345 co-author hat on)

>+1, in addition, I am wondering whether this is something related to overlay topology model, if yes, how it is different from DC Fabric topology model defined in RFC8542?
>-Qin

Thank you for your comment. The RFC8542 condisers PODs in the DC network. uCPE is located on the customer site. if we consider that uCPE is A POD (with links and nodes like VMs and swithces) then in the RFC8542 describes different PODs in the network that are interconnected with links. The yang model proposed in the ID ifocuses only on the uCPE interiour network service, not the interconnection between the uCPEs. Aslo, I explained the difference about extension neded for type of nodes,vms leafs and furter complexity in the mapping logic in the reponce to Robert.
-Dmytro

[Qin]:So you focus on interconnection between local vPE and remote vPE?
It is not clear whether we should distinguish VM from switch. In my understanding, Upon VNF is instantiated, there is no difference between virtual and physical worlds.
VNF lifecycle management is separated from topology construction, wrong?

Best regards,
Dmytro.

---

From: Dmytro Shytyi <[email-masked]>
Date: Thu, 29 Aug 2019 18:38:11 +0200

># # # : Dmytro Shytyi [mailto:mailto:[email-masked]]

># # # # : 2019# 8# 28#  21:46

># # # : Robert Varga <mailto:[email-masked]>; Qin Wu <mailto:[email-masked]>

># # : netmod <mailto:[email-masked]>

># # : Re: [netmod] New Version draft-shytyi-netmod-vysm-02.txt as Working Group document.

>[Qin]:So you focus on interconnection between local vPE and remote vPE?

[Dmytro]:

Thank you for this question. It seems that the next version of draft should include the explanation of the uCPE interiour network service.

Example: We can have multiple VMs instantiated in the uCPE (vFW,vRouter/vCPE,SD-WAN). With support of links and swithes  VMs may create a service chains.

Example of service chains:

1)WAN--vRouter(vCPE)-link-uCPEvSW -link2-vFirewall-LAN

2)WAN--SDWAN--vFirewall--LAN

>It is not clear whether we should distinguish VM from switch. In my understanding, Upon VNF is instantiated, there is no difference between virtual and physical worlds.

[Dmytro]:

The VM/VNF in the uCPE could be a vROuter or Vfirewall or an SD-WAN that is not a default part of virtual network resources of the uCPE (chapter 3 in the ID).

The switch (ex. Open vSwith) in the uCPE is a default part of uCPE network virtual resources (chapter 3 in the ID).

Thus we need to distingish swithes and VNFs to not to mix uCPE network virtual resources and VNFs.

Another reason why the destingishing is required: because VM and SW have different device-attributes. SW does not require VNFD attributtes.

If we do not distinguish nodes, and only extend the grouping "device attributes" for required attributes the switch will have the properties that are  unused leafs which represent the VM-device-attributes.

>VNF lifecycle management is separated from topology construction, wrong?

[Dmytro]:

a) In case of the NFVIs uCPE the same High Level interface allows to configure both topology construction and VM lifecycle management in the same transaction.

b) We can not activate Network Service Descriptor without consituent VM node information. At the moment of NSD activation we already have to set the VM node information such as VM capabilities that can be created (previosly)/(at the moment of configuration of NSD) but have to be a part of the network service descriptor at the moment of activation.

[Dmytro]

The Internet Draft also defines the term uCPE that is not defined at IETF yet.