Subject: [netmod] Alexey Melnikov's Discuss on draft-ietf-netmod-artwork-folding-08: (with DISCUSS)

From: Alexey Melnikov via Datatracker <[email-masked]>
Date: Wed, 28 Aug 2019 11:50:38 -0700

Alexey Melnikov has entered the following ballot position for
draft-ietf-netmod-artwork-folding-08: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-netmod-artwork-folding/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Thank you for your document.

It might be just me, but I think your examples in 9.4.1 with trailing \ don’t
seem to match the folding algorithm in section 7, as it doesn’t describe
special handling of trailing \.

---

From: Kent Watsen <[email-masked]>
Date: Wed, 28 Aug 2019 22:03:27 +0000

Hi Alexey,

Response at bottom.

Kent

> On Aug 28, 2019, at 2:50 PM, Alexey Melnikov via Datatracker <[email-masked]> wrote:
> 

Can you be more specific regarding what it is you think doesn't match?   Step (2) says, at the location where the fold is to occur, insert '\' followed by '\n'.  That appears to be what is shown in 9.4.1, yes?

FWIW, the text in Section 9.4.1 (as with all the examples in the draft) was dynamically-generated (at draft build time) by feeding the text in Section 9.4 into the script in the Appendix A.

Kent  // co-author

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 29 Aug 2019 09:55:03 +0100

Hi Kent,

> On 28 Aug 2019, at 23:03, Kent Watsen <[email-masked]> wrote:
> 
> Hi Alexey,
> 
> Response at bottom.
> 
> Kent
> 
> 

In the HTML version (in datatracker) I am seeing:

“This line ends with a backslash \\”
followed by an empty line. So I see 2 trailing \ followed by end of line, instead of \, end of line, and then \.

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 29 Aug 2019 09:55:26 +0100

> FWIW, the text in Section 9.4.1 (as with all the examples in the draft) was dynamically-generated (at draft build time) by feeding the text in Section 9.4 into the script in the Appendix A.

This is a fantastic news!

---

From: Barry Leiba <[email-masked]>
Date: Thu, 29 Aug 2019 09:31:47 -0400

The example is set up so that the source is in 9.4, 9.4.1 is the
result of "\ folding" of 9.4, and 9.4.2 is the result of "\\ folding"
of 9.4.

So the original source (in 9.4) was "This line ends with a backslash \".
The result of "\ folding" gives "This line ends with a backslash \\",
because the backslash had to be escaped.

Barry

---

From: "Alexey Melnikov" <[email-masked]>
Date: Thu, 29 Aug 2019 14:36:11 +0100

> because the backslash had to be escaped.

But the algorithm described in prose says absolutely nothing about escaping trailing "\"! So why the example is Ok, it just doesn't match the folding algorithm.

---

From: Kent Watsen <[email-masked]>
Date: Thu, 29 Aug 2019 13:39:04 +0000

Correct and, to be even more clear, the location where the fold occurred was between the '\' and '\n' in the original input, thus producing the sequence: '\' + '\' + '\n' + '\n', where the first and last characters are from the input and the inner-two characters were introduced by the folding process.

Alexey, does this explanation clear your DISCUSS?

Kent // co-author

> On Aug 29, 2019, at 9:31 AM, Barry Leiba <[email-masked]> wrote:
>

---

From: Kent Watsen <[email-masked]>
Date: Thu, 29 Aug 2019 13:44:35 +0000

> On Aug 29, 2019, at 9:36 AM, Alexey Melnikov <[email-masked]> wrote:
> 

The word "escape" is a bit misleading, even though, in a way, that is what is happening (e.g., working around a special character), but it's not "escaping" in the traditional sense (i.e., the first '\' is in no way giving special significance to the second '\').  What's really going on is better described as a forced folding on a line that contains an invalid end-of-line sequence.  Makes sense?

Kent // co-author

---

From: "Alexey Melnikov" <[email-masked]>
Date: Thu, 29 Aug 2019 14:44:22 +0100

Hi,

> Correct and, to be even more clear, the location where the fold occurred was between the '\' and '\n' in the original input, thus producing the sequence: '\' + '\' + '\n' + '\n', where the first an…

Hmm, Ok. That is not how I understood your folding algorithm, so I think this is not very clear.

> Alexey, does this explanation clear your DISCUSS?

I would clear, but I suggest you should add more text explaining this.

Best Regards,
Alexey

---

From: Barry Leiba <[email-masked]>
Date: Thu, 29 Aug 2019 09:47:01 -0400

You're saying, then, that "This line ends with a backslash
\\[EOL][EOL]" only loses the last "\" in unfolding, because there is
no space character on the next line.  Is that right?  If so, Alexey is
right that the algorithm doesn't say that.

Barry

---

From: Kent Watsen <[email-masked]>
Date: Sat, 31 Aug 2019 01:15:52 +0000

Hi Alexey (and Barry),

I have clarified forced-foldings in the latest update:

   https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding-09 <https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding-09>

Please let me know if this clears your DISCUSS.

Thanks,
Kent

> On Aug 29, 2019, at 9:47 AM, Barry Leiba <[email-masked]> wrote:
>

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 31 Aug 2019 11:11:41 +0100

Hi Kent,

> On 31 Aug 2019, at 02:15, Kent Watsen <[email-masked]> wrote:
> 
> Hi Alexey (and Barry),
> 
>    https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding-09

This is helpful, thank you!