Subject: Re: [netmod] New Version Notification for draft-wwx-netmod-event-yang-03.txt

From: wangzitao <[email-masked]>
Date: Tue, 15 Oct 2019 06:17:10 +0000

Dear Working Group,

As you recall that we presented the "draft-wwx-netmod-event-yang-02" in the last NETMOD session and got a good number of supports when the chair polled in the room.
Recently we have a minor update on the draft based on Montreal meeting discussion, adding an appendix section to introduce how to reuse the "trigger-grouping", more details please review the document.
https://tools.ietf.org/html/draft-wwx-netmod-event-yang-03

We believe this draft is stable enough and would like to ask for WG adoption.

Comments and suggestion are welcome! 

Best Regards!
-Michael(on behalf of authors)

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2019年10月15日 14:14
收件人: wangzitao <[email-masked]>; Chongfeng Xie <[email-masked]>; Qin Wu <[email-masked]>; wangzitao <[email-masked]>; Qin Wu <[email-masked]>
主题: New Version Notification for draft-wwx-netmod-event-yang-03.txt

A new version of I-D, draft-wwx-netmod-event-yang-03.txt
has been successfully submitted by Michael Wang and posted to the IETF repository.

Name:		draft-wwx-netmod-event-yang
Revision:	03
Title:		A YANG Data model for Policy based Event Management
Document date:	2019-10-13
Group:		Individual Submission
Pages:		30
URL:            https://www.ietf.org/internet-drafts/draft-wwx-netmod-event-yang-03.txt
Status:         https://datatracker.ietf.org/doc/draft-wwx-netmod-event-yang/
Htmlized:       https://tools.ietf.org/html/draft-wwx-netmod-event-yang-03
Htmlized:       https://datatracker.ietf.org/doc/html/draft-wwx-netmod-event-yang
Diff:           https://www.ietf.org/rfcdiff?url2=draft-wwx-netmod-event-yang-03

Abstract:
   [RFC8328] defines a policy-based management framework that allow
   definition of a data model to be used to represent high-level,
   possibly network-wide policies.  This document defines an YANG data
   model for the policy based event management [RFC7950].  The policy
   based Event YANG provides the ability for the network management
   function (within a controller, an orchestrator, or a network element)
   to control the configuration and monitor state change on the network
   element and take simple and instant action when a trigger condition
   on the system state is met.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Lou Berger <[email-masked]>
Date: Tue, 22 Oct 2019 08:38:12 -0400

Michael/Authors/WG,

Thank you for this work.  One of the questions in looking at this draft is the relationship to this draft to other individual work that has been discussed in the WG, notablyhttps://tools.ietf.org/html/draft-bryskin-netconf-automation-yang  . In looking at both drafts, I read it as that the latter provides general infrastructure for event-condition-actions (ECAs).  I'm less sure about your draft, in reading it it too seems aimed at a general infrastructure, but it also seems tailored to a specific set of ECAs that are aligned with the EVEN-MIB.

What is your/the authors intent?

If the former, perhaps it would be good for both sets of authors to (at least try to) work together to come up with with a merged document?  If the latter, does it make sense to adjust your draft to document your use case using the more general mechanisms of the other draft?

What do you think?

Please let me know if you think I'm misreading or missed something here.

Thanks,
Lou

On 10/15/2019 2:17 AM, wangzitao wrote:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 24 Oct 2019 22:43:45 +0800

Lou:
I think draft-wwx-netmod-event-yang-03 aims at generic policy, has been polished based on source of existing work (e.g.,supa Work)and it doesn't need to be perfect at adoption stage,
But it is a good starting point for WG to develop generic ECA model, in my view.

Best
Chongfeng

From: Lou Berger
Date: 2019-10-22 20:38
To: wangzitao
CC: NetMod WG Chairs; draft-bryskin-netconf-automation-yang; [email-masked]; draft-wwx-netmod-event-yang
Subject: Re: [netmod] New Version Notification for draft-wwx-netmod-event-yang-03.txt
Michael/Authors/WG,

 
 
What do you think?

Thanks,
Lou