Subject: Re: [netmod] New Version Notification for draft-ietf-netmod-factory-default-04.txt

From: Qin Wu <[email-masked]>
Date: Tue, 29 Oct 2019 02:56:23 +0000

Hi, Joe:
Thanks for your valuable comments, see reply inline below.
-----邮件原件-----
发件人: Joe Clarke (jclarke) [mailto:[email-masked]] 
发送时间: 2019年10月28日 22:13
收件人: Qin Wu <[email-masked]>
抄送: [email-masked]
主题: Re: [netmod] New Version Notification for draft-ietf-netmod-factory-default-04.txt

> On Oct 27, 2019, at 23:37, Qin Wu <[email-masked]> wrote:
> 
> v-04 is posted
> https://tools.ietf.org/html/draft-ietf-netmod-factory-default-04
> additional text to clarify rpc usage.

Thanks, Qin.  I re-read this latest draft, and albeit there were only a few changes, I have some broader comments.

First, I remember we talked about a reboot operation I think at the last IETF(?).  It was said that perhaps a reboot would happen as part of this RPC because once the <running> datastore is reset to factory-default, the device would not be reachable.  I don’t know where we landed on that.  However, I think some attention should be paid to things like zero-touch provisioning.  If I reset to factory-default, I would expect the device to undergo any out-of-the-box bootstrapping.  Perhaps adding some text that after the RPC is executed, the device SHOULD perform any initial bootstrapping processes?

[Qin]:Yes, initial bootstrapping processes should be covered, I will propose text in the separate email for this.

===

In Section 2, perhaps for clarity say that, “Factory-default content SHALL be specified by one of the following means in descending order of precedence”?  I’m nit-picking on this one, though.

[Qin]: okay, fixed.
===

In Section 2, you mention Instance Data is second in the list.  What is really meant by this?  Does that mean the factory-default config is defined by an instance data file specified by the vendor in some offline location?  If so, perhaps it’s worth clarifying that.
[Qin]: How about the following proposed changes:
OLD TEXT
"
YANG Instance Data [I-D.ietf-netmod-yang-instance-file-format]
"
NEW TEXT:
"
  by vendors using YANG Instance Data [I-D.ietf-netmod-yang-instance-file-format] file format in
  vendor's website or other places where off-line document is kept;
"

===

In Section 2 and in the YANG module description for the RPC your tenses don’t match.  You should say:

Upon receiving the RPC the server resets the contents of all read-write configuration datastore (e.g., <running> and <startup>) to their factory-default contents.

[Qin]:Good catch, fixed.
===

In Section 2, you say, “some of the SW processes”.  I think you mean software.  You should expand SW.
[Qin]:Fixed.

Joe

> 
> -Qin
> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 
> 发送时间: 2019年10月28日 11:36
> 收件人: Niuye <[email-masked]>; Qin Wu <[email-masked]>; Qin Wu <[email-masked]>; Balazs Lengyel <[email-masked]>
> 主题: New Version Notification for draft-ietf-netmod-factory-default-04.txt
> 
> 
> A new version of I-D, draft-ietf-netmod-factory-default-04.txt
> has been successfully submitted by Qin Wu and posted to the IETF repository.
> 
> Name:		draft-ietf-netmod-factory-default
> Revision:	04
> Title:		Factory Default Setting
> Document date:	2019-10-26
> Group:		netmod
> Pages:		11
> URL:            https://www.ietf.org/internet-drafts/draft-ietf-netmod-factory-default-04.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-netmod-factory-default/
> Htmlized:       https://tools.ietf.org/html/draft-ietf-netmod-factory-default-04
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-netmod-factory-default
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-factory-default-04
> 
> Abstract:
>   This document defines a method to reset a server to its factory-
>   default content.  The reset operation may be used e.g. during initial
>   zero-touch configuration or when the existing configuration has major
>   errors, so re-starting the configuration process from scratch is the
>   best option.
> 
>   A new factory-reset RPC is defined.  Several methods of documenting
>   the factory-default content are specified.
> 
>   Optionally a new "factory-default" read-only datastore is defined,
>   that contains the data that will be copied over to the running
>   datastore at reset.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Qin Wu <[email-masked]>
Date: Tue, 29 Oct 2019 03:01:59 +0000

发件人: Kent Watsen [mailto:[email-masked]]
发送时间: 2019年10月28日 23:55
收件人: Joe Clarke (jclarke) <[email-masked]>
抄送: Qin Wu <[email-masked]>; [email-masked]
主题: Re: [netmod] New Version Notification for draft-ietf-netmod-factory-default-04.txt

Regarding this point:

Perhaps the draft could say something like:

"...resets the configuration to the device's factory default configuration, for the OS version it is running.  For devices supporting zero touch bootstrapping mechanisms, the factory default configuration causes the bootstrapping process to execute."

[Qin]:Thanks Kent, how about the following proposed changes:
OLD TEXT:
“
Section 2

In addition, the "factory-reset" RPC might also be used
   to trigger some other restoring and resetting tasks such as files
   cleanup, restarting the node or some of the software processes,
   setting some security data/passwords to the default value, removing
   logs, or removing any temporary data (from datastore or elsewhere),
   etc.  When and why these tasks are triggered is not the scope of this
   document.
”
NEW TEXT:
“
Section 2

   For the server supporting zero touch bootstrapping mechanisms, the

   factory default configuration causes the bootstrapping process to

   execute, e.g.,the server might reset configuration to device's factory

   default configuration, for the version of operating system software it

   is running.  In addition, the "factory-reset" RPC might also be used

   to trigger some other restoring and resetting tasks such as files

   cleanup, restarting the node or some of the software processes,

   setting some security data/passwords to the default value, removing

   logs, or removing any temporary data (from datastore or elsewhere),

   etc.  When and why these tasks are triggered is not the scope of this
   document.
”
“restarting the node or some of the software processes” description may be a little bit duplicated since
we have already had separate initial bootstrapping process description before the sentence “In addition, the “facory-reret”…”

Kent // contributor