Subject: [netmod] FW: New Version Notification for draft-rwilton-netmod-yang-packages-03.txt

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 19 Feb 2020 16:31:58 +0000

FYI, I've posted an updated version of the YANG packages draft.  This is the version that we plan to request a WG adoption call on, once we have an updated version of the version selection draft posted (hopefully ready soon).

To highlight the main changes:
 - Added a section to describe how YANG packages relate to datastore schema, along with guidance on how to structure package definitions.
 - Unified the package definition on the server vs in YANG instance data documents.  In particular, the on-server definition no longer reuses the module-sets from YANG library.  This also simplifies the explanation of how these definitions relate since the same common grouping is reused.
 - Move packages into its own top level container, rather than being under YANG library.
 - Changed the binding between datastore schema in YANG library and packages.  Before there was a 1:1 binding from datastore schema to package definition.  It has been changed to a 1:N binding, i.e. a datastore scheme is represented by a union of compatible packages.  This aligns with how the relationship is defined in the version selection draft.

Thanks,
Rob

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: 19 February 2020 16:15
To: Jason Sterne <[email-masked]>; Reshad Rahman (rrahman) <[email-masked]>; Rob Wilton (rwilton) <[email-masked]>; Joe Clarke (jclarke) <[email-masked]>; Wu Bo <[email-masked]>; Bo Wu <[email-masked]>
Subject: New Version Notification for draft-rwilton-netmod-yang-packages-03.txt

A new version of I-D, draft-rwilton-netmod-yang-packages-03.txt
has been successfully submitted by Robert Wilton and posted to the IETF repository.

Name:		draft-rwilton-netmod-yang-packages
Revision:	03
Title:		YANG Packages
Document date:	2020-02-19
Group:		Individual Submission
Pages:		56
URL:            https://www.ietf.org/internet-drafts/draft-rwilton-netmod-yang-packages-03.txt
Status:         https://datatracker.ietf.org/doc/draft-rwilton-netmod-yang-packages/
Htmlized:       https://tools.ietf.org/html/draft-rwilton-netmod-yang-packages-03
Htmlized:       https://datatracker.ietf.org/doc/html/draft-rwilton-netmod-yang-packages
Diff:           https://www.ietf.org/rfcdiff?url2=draft-rwilton-netmod-yang-packages-03

Abstract:
   This document defines YANG packages, a versioned organizational
   structure holding a set of related YANG modules, that collectively
   define a YANG schema.  It describes how packages: are represented on
   a server, can be defined in offline YANG instance data documents, and
   can be used to define the schema associated with YANG instance data
   documents.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Lou Berger <[email-masked]>
Date: Wed, 19 Feb 2020 11:36:50 -0500

Thanks Rob/Team!

All,

     We're planning to run the adoption poll on the versioning document 
set  once the next update of the selection draft is published -- so 
please feel free to get started reading/commenting on this document now.

Lou

On 2/19/2020 11:31 AM, Rob Wilton (rwilton) wrote:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 19 Feb 2020 17:02:48 +0000

Just as a reminder of what the full set of versioning documents are that we will ask the chairs to consider for WG adoption (in case you wish to start reviewing some of the drafts early), are listed them below, and I have indicated which ones have been (or will be) updated since 106.

1) draft-verdt-netmod-yang-solutions-03 
 - Solution overview, updated since 106 to cover updates to version selection and schema comparison drafts.

2) draft-verdt-netmod-yang-module-versioning-01
 - Base module versioning solution, unchanged from the version presented at 106.

3) draft-verdt-netmod-yang-semver-01
 - YANG Semantic version numbers, unchanged from the version presented at 106.

4) draft-rwilton-netmod-yang-packages-03
 - YANG packages draft, updated since 106, as per notes below.

5) draft-verdt-netmod-yang-module-versioning-02 (TBD)
 - Version selection, will post updated version soon, current aim is for the end of Feb.

6) draft-verdt-netmod-yang-schema-comparison-00
 - Schema comparison tooling, unchanged from the version presented at 106.

Thanks,
Rob

> From: Lou Berger <[email-masked]>
> Sent: 19 February 2020 16:37
> To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
> Subject: Re: [netmod] FW: New Version Notification for draft-rwilton-
> netmod-yang-packages-03.txt
> 
> Thanks Rob/Team!
> 
> All,
> 
> set  once the next update of the selection draft is published -- so please
> feel free to get started reading/commenting on this document now.
> 
> Lou
> 
> > FYI, I've posted an updated version of the YANG packages draft.  This is
> the version that we plan to request a WG adoption call on, once we have an
> updated version of the version selection draft posted (hopefully ready
> soon).
> >
> >   - Added a section to describe how YANG packages relate to datastore
> schema, along with guidance on how to structure package definitions.
> >   - Unified the package definition on the server vs in YANG instance
> data documents.  In particular, the on-server definition no longer reuses
> the module-sets from YANG library.  This also simplifies the explanation
> of how these definitions relate since the same common grouping is reused.
> >   - Changed the binding between datastore schema in YANG library and
> packages.  Before there was a 1:1 binding from datastore schema to package
> definition.  It has been changed to a 1:N binding, i.e. a datastore scheme
> is represented by a union of compatible packages.  This aligns with how
> the relationship is defined in the version selection draft.
> >
> > Thanks,
> > Rob
> >
> >
> > To: Jason Sterne <[email-masked]>; Reshad Rahman (rrahman)
> > <[email-masked]>; Rob Wilton (rwilton) <[email-masked]>; Joe
> > Clarke (jclarke) <[email-masked]>; Wu Bo <[email-masked]>; Bo
> > Wu <[email-masked]>
> > Subject: New Version Notification for
> > draft-rwilton-netmod-yang-packages-03.txt
> >
> >
> > Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> >
> > The IETF Secretariat
> >