Subject: Re: [netmod] WG Last Call: draft-ietf-netmod-yang-instance-file-format-06 to -07

From: Balázs Lengyel <[email-masked]>
Date: Fri, 14 Feb 2020 16:03:57 +0000

Hello Chairs,
I replied to Juergen, and exchanged some additional mails with him. I updated the draft to draft-ietf-netmod-yang-instance-file-format-07. Please take it forward in the process.

https://protect2.fireeye.com/v1/url?k=ed368c2e-b1bcaefa-ed36ccb5-0cc47ad93e6a-1bf0817821133165&q=1&e=b8630aed-b037-42b0-a579-0e6e8067e0eb&u=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-netmod-yang-instance-file-format-07
Regards Balazs

-----Original Message-----
From: netmod <[email-masked]> On Behalf Of Kent Watsen
Sent: 2020. február 9., vasárnap 20:23
To: [email-masked]
Subject: Re: [netmod] WG Last Call: draft-ietf-netmod-yang-instance-file-format-06

This message closes the WGLC.

Authors, please respond to Juergen’s message from Jan 20, ultimately posting an update to the draft.

Thanks,
Kent // as shepherd

> On Jan 7, 2020, at 7:41 AM, Kent Watsen <[email-masked]> wrote:
> 
> 
> This begins a two-week Working Group Last Call (WGLC) on draft-ietf-netmod-yang-instance-file-format-06.  The WGLC ends on Jan 21.  Please send your comments to the working group mailing list.
> 
> Positive comments, e.g., "I've reviewed this document and believe it is ready for publication", are welcome!  This is useful and important, even from authors.  Objections, concerns, and suggestions are also welcomed at this time.
> 
> Thank you,
> NETMOD Chairs
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Kent Watsen <[email-masked]>
Date: Fri, 14 Feb 2020 19:15:10 +0000

Juergen,

Does the update address all your concerns?  Do you feel there is
a need for another LC

Hi Balazs,

Did you mean to send this to the netmod-chairs alias?  Oh well, as
 long we’re here, following are some questions/comments:

Have the YANG modules been validated and tested for formatting?
(i.e., pyang -f yang --keep-comments --yang-line-length 69 filename) 

Have the examples in the draft validated against the YANG module?

Please review the Normative/Informative status of the references.
Not looking carefully, but RFCs 2119 and 8174 should be Normative, 
and I think RFCs 3688 and 6020 should be Informative, right?

All of the “import” statements in the YANG module are missing a
“reference” statement.

Please add a paragraph to Section 5.2 preceding the YANG module
indicating all the aforementioned Normative references.

The copyright in the YANG module needs to be 2020 (not 2019)

Please ensure a blank line between paragraphs in the “description"
statements.

Please add a statement to the Introduction regarding why the module
Isn’t compliant with NMDA.

The tree diagram does not adhere to the syntax described in 
draft-ietf-netmod-yang-data-ext.  Please update the first sentence 
in Section 5.1 to also reference draft-ietf-netmod-yang-data-ext.

Please ensure that the planning-text version of the draft passes
IDNITS (https://www6.ietf.org/tools/idnits) at the “verbose output”
level and correct any issues found, or explain why they shouldn’t
be corrected.

Thanks,
Kent  // shepherd

> On Feb 14, 2020, at 11:03 AM, Balázs Lengyel <[email-masked]> wrote:
> 
> Hello Chairs,