Subject: Re: [netmod] New Version Notification for draft-ietf-netmod-factory-default-10.txt

From: Qin Wu <[email-masked]>
Date: Mon, 10 Feb 2020 04:28:04 +0000

The v-10 is posted to address comments raised in Shepherd document review.
The diff is:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-factory-default-10

-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2020年2月10日 12:26
收件人: Niuye <[email-masked]>; Qin Wu <[email-masked]>; Qin Wu <[email-masked]>; Balazs Lengyel <[email-masked]>
主题: New Version Notification for draft-ietf-netmod-factory-default-10.txt

A new version of I-D, draft-ietf-netmod-factory-default-10.txt
has been successfully submitted by Qin Wu and posted to the IETF repository.

Name:		draft-ietf-netmod-factory-default
Revision:	10
Title:		Factory Default Setting
Document date:	2020-02-09
Group:		netmod
Pages:		11
URL:            https://www.ietf.org/internet-drafts/draft-ietf-netmod-factory-default-10.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-netmod-factory-default/
Htmlized:       https://tools.ietf.org/html/draft-ietf-netmod-factory-default-10
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-netmod-factory-default
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-factory-default-10

Abstract:
   This document defines a method to reset a server to its factory-
   default content.  The reset operation may be used, e.g., when the
   existing configuration has major errors so re-starting the
   configuration process from scratch is the best option.

   A new factory-reset RPC is defined.  When resetting a device, all
   previous configuration settings will be lost and replaced by the
   factory-default content.

   A new optional "factory-default" read-only datastore is defined, that
   contains the factory default configuration for the device.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Kent Watsen <[email-masked]>
Date: Mon, 10 Feb 2020 15:38:36 +0000

Thanks for the update, Qin.

BTW, my previous email to the “netmod” list did not get reflected back to me, and I don’t see either of out emails in the archives, so there is a chance that we’re having this conversation in isolation, even though “netmod” is CC-ed….

Regardless, looking at the diffs, I have the following comments:

- I’m not happy with the new “factory-default” term.  Please remove it and review all uses of “factory-default” to see if they should be “factory default” (without the hyphen).  Again, the hyphen should only be used when referring to the YANG node; in all other cases it should not be hyphenated.  Please beware that I see I the diff you made an attempt to hyphenate a number of instances of what should be “factory default”.  Please undo all these.  Again, the hyphen should only be present when referring to the YANG node, otherwise the hyphen should not be present.

- In Section 2, replace ", and logs (e.g., /var/log), temporary files (e.g., /tmp/*)” with ", logs (e.g., /var/log), and temporary files (e.g., /tmp/*).”  That is, move the “and” to the end...

- In the YANG module, you must’ve copy/pasted the description incompletely…please add the last stanza from my previous email (“i.e., beginning with “and”) to "This module defines an RPC called 'factory-reset', a datastore identity called 'factory-default-datastore’”.

- in Section 6:

  a) s/sensitive in and therefore/sensitive and therefore//
  b) s/default- deny-all/default-deny-all/
  c) s/in . [RFC8341]/in [RFC8341]./

Kent // as Shepherd

> On Feb 9, 2020, at 11:28 PM, Qin Wu <[email-masked]> wrote:
>