Subject: [netmod] Erratum 5514 on NMDA [RFC 8342]

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 28 Apr 2020 11:33:30 +0000

Hi,

There is one open erratum on NMDA from 2018 that I would like to process.

The erratum is here: https://www.rfc-editor.org/errata/eid5514

There has been quite a lot of discussion on this erratum previously on the NETMOD alias.  The last email in the thread was https://mailarchive.ietf.org/arch/msg/netmod/LHJZmf5gtESX6Nobwst0OwXbGG4/

>From my reading of the discussion, I don't think that there is clear WG consensus between the two competing concerns:
(1) The origin for any top-level configuration data nodes must be specified (section 7, YANG annotation definition).
(2) The origin applies to all configuration nodes except non-presence containers (section 5.3.4).

Hence my proposal is to mark this as "Hold for Document Update" with Kent's proposed resolution of changing the description in the YANG model.

OLD:
    The origin for any top-level configuration data nodes must be specified.

NEW:
    The origin for any top-level configuration data nodes, except
    non-presence containers, must be specified.

For reference, this will mean that the extension [NEW] is defined as:

     md:annotation origin {
       type origin-ref;
       description
         "The 'origin' annotation can be present on any configuration
          data node in the operational state datastore.  It specifies
          from where the node originated.  If not specified for a given
          configuration data node, then the origin is the same as the
          origin of its parent node in the data tree.  The origin for
          any top-level configuration data nodes, except non-presence
          containers,  must be specified.";
     }

Please can you let me know if you support or object to this resolution.  I'll leave it a week to see if there is consensus before processing the erratum.

Regards,
Rob

---

From: Martin Björklund <[email-masked]>
Date: Tue, 28 Apr 2020 17:47:04 +0200 (CEST)

"Rob Wilton \(rwilton\)" <rwilton=[email-masked]> wrote:
> There has been quite a lot of discussion on this erratum previously on
> the NETMOD alias.  The last email in the thread was
> https://mailarchive.ietf.org/arch/msg/netmod/LHJZmf5gtESX6Nobwst0OwXbGG4/
> 
> >From my reading of the discussion, I don't think that there is clear
> >WG consensus between the two competing concerns:
> (1) The origin for any top-level configuration data nodes must be
> specified (section 7, YANG annotation definition).
> Hence my proposal is to mark this as "Hold for Document Update" with
> Kent's proposed resolution of changing the description in the YANG
> model.
> 
> OLD:
> Please can you let me know if you support or object to this
> resolution.  I'll leave it a week to see if there is consensus before
> processing the erratum.

I think this is ok.

/martin