Subject: [netmod] Murray Kucherawy's No Objection on draft-ietf-netmod-factory-default-14: (with COMMENT)

From: Murray Kucherawy via Datatracker <[email-masked]>
Date: Fri, 03 Apr 2020 13:12:04 -0700

Murray Kucherawy has entered the following ballot position for
draft-ietf-netmod-factory-default-14: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-netmod-factory-default/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Section 2:
* "All security sensitive data (i.e., private keys, passwords, etc.)  SHOULD be
overwritten ..." presents a choice.  Why would an implementer not do this? *
"Implementors SHOULD reboot the device or otherwise restart processes needed to
bootstrap it." leads me to the same question.

Nits:
* "Upon receiving the RPC" is followed by a list, so please add a colon
* "datastores(e.g.," -- add a space after "datastores"

Section 3:
Nits:
* "The contents of <factory-default> is defined  ..." -- s/is/are/

Section 5:
* "This document registers one URI in the IETF XML Registry [RFC3688]. ..."
should say explicitly that it's the "ns" sub-registry receiving a new entry.

---

From: Qin Wu <[email-masked]>
Date: Sat, 18 Apr 2020 09:18:47 +0000

Thanks for your suggestion, will consider them as a whole.
发件人: Murray S. Kucherawy [mailto:[email-masked]]
发送时间: 2020年4月14日 0:39
收件人: Qin Wu <[email-masked]>
抄送: The IESG <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; Kent Watsen <[email-masked]>
主题: Re: Murray Kucherawy's No Objection on draft-ietf-netmod-factory-default-14: (with COMMENT)

Hi Qin,

On Sun, Apr 12, 2020 at 8:12 PM Qin Wu <[email-masked]<mailto:[email-masked]>> wrote:
Section 2:
* "All security sensitive data (i.e., private keys, passwords, etc.)  SHOULD be overwritten ..." presents a choice.  Why would an implementer not do this? *
[Qin]: This was outcome of the discussion, see the following link:
https://mailarchive.ietf.org/arch/msg/netmod/qrU_71AkP42lnkR6KnfaMsoSgCs/
i.e., folks concerned to restore security data and password to default value, that's we introduce clean requirements to address this concern.
"Implementors SHOULD reboot the device or otherwise restart processes needed to bootstrap it." leads me to the same question.
[Qin]: To make default configuration take effect, the device reboot is recommended, but in some case, the IP address reachability of the device may be lost, therefore bootstrapping may be needed.

For both of these I suggest mentioning in the document the reason it's a SHOULD and not a MUST, i.e., describe a situation when it might be okay to do something other than what it says.

(Reminder: These are not blocking comments, just suggestions.)

Thanks for considering these suggestions.

-MSK