Subject: Re: [netmod] Murray Kucherawy's No Objection on draft-ietf-netmod-factory-default-14: (with COMMENT)

From: Qin Wu <[email-masked]>
Date: Mon, 13 Apr 2020 03:11:58 +0000

Thanks Murray, see reply inline below.
-----邮件原件-----
发件人: Murray Kucherawy via Datatracker [mailto:[email-masked]] 
发送时间: 2020年4月4日 4:12
收件人: The IESG <[email-masked]>
抄送: [email-masked]; [email-masked]; [email-masked]; Kent Watsen <[email-masked]>
主题: Murray Kucherawy's No Objection on draft-ietf-netmod-factory-default-14: (with COMMENT)

Murray Kucherawy has entered the following ballot position for
draft-ietf-netmod-factory-default-14: No Objection

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-netmod-factory-default/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Section 2:
* "All security sensitive data (i.e., private keys, passwords, etc.)  SHOULD be overwritten ..." presents a choice.  Why would an implementer not do this? * 
[Qin]: This was outcome of the discussion, see the following link:
https://mailarchive.ietf.org/arch/msg/netmod/qrU_71AkP42lnkR6KnfaMsoSgCs/
i.e., folks concerned to restore security data and password to default value, that's we introduce clean requirements to address this concern.
"Implementors SHOULD reboot the device or otherwise restart processes needed to bootstrap it." leads me to the same question.
[Qin]: To make default configuration take effect, the device reboot is recommended, but in some case, the IP address reachability of the device may be lost, therefore bootstrapping may be needed.
Nits:
* "Upon receiving the RPC" is followed by a list, so please add a colon
* "datastores(e.g.," -- add a space after "datastores"

[Qin]: Fixed, thanks.
Section 3:
Nits:
* "The contents of <factory-default> is defined  ..." -- s/is/are/

[Qin]: Fixed, thanks.
Section 5:
* "This document registers one URI in the IETF XML Registry [RFC3688]. ..."
should say explicitly that it's the "ns" sub-registry receiving a new entry.

[Qin]:Okay.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 13 Apr 2020 09:38:50 -0700

Hi Qin,

On Sun, Apr 12, 2020 at 8:12 PM Qin Wu <[email-masked]> wrote:

> Section 2:
> * "All security sensitive data (i.e., private keys, passwords, etc.)
> SHOULD be overwritten ..." presents a choice.  Why would an implementer not
> do this? *
> i.e., folks concerned to restore security data and password to default
> value, that's we introduce clean requirements to address this concern.
>
"Implementors SHOULD reboot the device or otherwise restart processes
> needed to bootstrap it." leads me to the same question.
> [Qin]: To make default configuration take effect, the device reboot is
> recommended, but in some case, the IP address reachability of the device
> may be lost, therefore bootstrapping may be needed.
>

For both of these I suggest mentioning in the document the reason it's a
SHOULD and not a MUST, i.e., describe a situation when it might be okay to
do something other than what it says.

(Reminder: These are not blocking comments, just suggestions.)

Thanks for considering these suggestions.

-MSK