Subject: [netmod] JSON encoding of events in draft-ietf-netconf-https-notif

From: Balázs Lengyel <[email-masked]>
Date: Tue, 7 Apr 2020 08:27:39 +0000

Hello Mahesh, Kent,

I was wondering how the JSON encoding of event would look like in your
draft. (I intend to propose something similar to 3GPP so I am most
interested.)

The part below push-update or push-change-update is well defined in YANG
however the part outside is not. In Restconf
(https://trac.tools.ietf.org/html/rfc8040#section-6.4) I see the following
example:

{

"ietf-restconf:notification" : {

  "eventTime" : "2013-12-21T00:01:00Z",

  "example-mod:event" : {

    "event-class" : "fault",

    "reporting-entity" : { "card" : "Ethernet0" },

    "severity" : "major"

  } } }

However how would the first 2 lines look here? IMHO keeping restconf as a
module name seems wrong. 

So maybe we should define it here in this draft :

{

 "json-yang-notification:notification" : {

  "eventTime" : "2013-12-21T00:01:00Z",

  "push-change-update" : {

    ...

  } } }

How to define this wrapper (the first 2 lines, I am unsure. As far as I know
it is not possible to describe this in YANG.  Maybe just some text like:

The YANG encoding of the notification SHALL be wrapped in a JSON object as
illustrated below

"json-yang-notification:notification" : {

  "eventTime" : "2013-12-21T00:01:00Z",

Also I would definitely need an example of a notification sent.

Regards Balazs

-- 

Balazs Lengyel                    Senior Specialist
Ericsson Hungary Ltd. 

Mobile: +36-70-330-7909              email: [email-masked]

---

From: Kent Watsen <[email-masked]>
Date: Tue, 7 Apr 2020 12:08:13 +0000

Moving to “netconf” (“netmod” in BCC)

K. 

Sent from my iPhone
>> On Apr 7, 2020, at 4:35 AM, Balázs Lengyel <balazs.lengyel=[email-masked]> wrote:
> 
> Hello Mahesh, Kent,
> I was wondering how the JSON encoding of event would look like in your draft. (I intend to propose something similar to 3GPP so I am most interested.)
> The part below push-update or push-change-update is well defined in YANG however the part outside is not. In Restconf (https://trac.tools.ietf.org/html/rfc8040#section-6.4) I see the following example:
>  
> {
> However how would the first 2 lines look here? IMHO keeping restconf as a module name seems wrong.
> How to define this wrapper (the first 2 lines, I am unsure. As far as I know it is not possible to describe this in YANG.  Maybe just some text like:
> The YANG encoding of the notification SHALL be wrapped in a JSON object as illustrated below
>  
> Balazs Lengyel                    Senior Specialist                       Ericsson Hungary Ltd.