Subject: [netmod] [Technical Errata Reported] RFC7317 (6245)

From: RFC Errata System <[email-masked]>
Date: Wed, 29 Jul 2020 06:32:25 -0700 (PDT)

The following errata report has been submitted for RFC7317,
"A YANG Data Model for System Management".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6245

--------------------------------------
Type: Technical
Reported by: Maurizio Brigandi' <[email-masked]>

Section: 6

Original Text
-------------

         leaf-list user-authentication-order {
           type identityref {
             base authentication-method;
           }
           must '(. != "sys:radius" or ../../radius/server)' 

Corrected Text
--------------

         leaf-list user-authentication-order {
           type identityref {
             base authentication-method;
           }
           must '(not(. = "sys:radius") or ../../radius/server)'

Notes
-----
As indicated in https://www.w3.org/TR/1999/REC-xpath-19991116/#booleans

the following expression comparing a node-set with a string

       . != "sys:radius"

is true if at least one node in the node-set satisfies the boolean expression.

This is not the intention of the "must" condition.

It is necessary to use not(. = "sys:radius") to achieve the right intention of the check.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7317 (draft-ietf-netmod-system-mgmt-16)
--------------------------------------
Title               : A YANG Data Model for System Management
Publication Date    : August 2014
Author(s)           : A. Bierman, M. Bjorklund
Category            : PROPOSED STANDARD
Source              : Network Modeling
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Martin Björklund <[email-masked]>
Date: Thu, 06 Aug 2020 19:50:44 +0200 (CEST)

Hi,

This errata is correct; the must expression in the errata reflects the
intention correctly.

But the question is if this can be fixed by an RFC errata...

/martin

RFC Errata System <[email-masked]> wrote:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod