Subject: [netmod] [Technical Errata Reported] RFC7950 (6258)

From: RFC Errata System <[email-masked]>
Date: Wed, 19 Aug 2020 23:42:16 -0700 (PDT)

The following errata report has been submitted for RFC7950,
"The YANG 1.1 Data Modeling Language".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6258

--------------------------------------
Type: Technical
Reported by: Fred Gan <[email-masked]>

Section: 5.6.5

Original Text
-------------
For example, with these modules:

     module a {
       yang-version 1.1;
       namespace "urn:example:a";
       prefix "a";

       import b {
         revision-date 2015-01-01;
       }
       import c;

       revision 2015-01-01;

Corrected Text
--------------
For example, with these modules:

     module a {
       yang-version 1.1;
       namespace "urn:example:a";
       prefix "a";

       import b {
         revision-date 2015-01-01;
         prefix b;
       }
       import c {
         prefix c;
       }

       revision 2015-01-01;

Notes
-----
As is considered in 7.1.5, The mandatory "prefix" substatement assigns a prefix for the imported module that is scoped to the importing module or submodule. 

So, there should be a prefix substatement in the "import b" and "import c" statement respectively.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7950 (draft-ietf-netmod-rfc6020bis-14)
--------------------------------------
Title               : The YANG 1.1 Data Modeling Language
Publication Date    : August 2016
Author(s)           : M. Bjorklund, Ed.
Category            : PROPOSED STANDARD
Source              : Network Modeling
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Martin Björklund <[email-masked]>
Date: Thu, 20 Aug 2020 08:48:39 +0200 (CEST)

Hi,

This errata is correct and should be accepted.

/martin

RFC Errata System <[email-masked]> wrote:
> As is considered in 7.1.5, The mandatory "prefix" substatement
> assigns a prefix for the imported module that is scoped to the
> importing module or submodule.
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 20 Aug 2020 09:30:29 +0000

Hi Martin,

Thanks for the quick comment.

I agree.

I've leave this for a week in case anyone has any further comment, but otherwise will mark this as verified.

Regards,
Rob

> -----Original Message-----
> From: Martin Björklund <[email-masked]>
> Sent: 20 August 2020 07:49
> To: [email-masked]
> Cc: [email-masked]; Rob Wilton (rwilton) <[email-masked]>;
> [email-masked]; [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: [netmod] [Technical Errata Reported] RFC7950 (6258)
> 
> Hi,
>