Subject: Re: [netmod] New Version Notification for draft-tao-netmod-yang-node-tags-04.txt

From: Qin Wu <[email-masked]>
Date: Mon, 10 Aug 2020 13:04:02 +0000

Hi, 
v-04 is posted, to address comments received from Jurgen and a few offline discussion.
https://datatracker.ietf.org/doc/html/draft-tao-netmod-yang-node-tags
The main changes include:
1. Add one NETCONF example in the appendix
2. Add Non-NMDA State Module in the appendix
3. Module structure alignment with module tag module.
4. Split Metric group from opm tag and define it as context info tag.
5. A few changes to Self Explanation Tags Use Cases.

-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2020年8月10日 20:56
收件人: Qin Wu <[email-masked]>; Qin Wu <[email-masked]>; Benoit Claise <[email-masked]>; Liang Geng <[email-masked]>; Zongpeng Du <[email-masked]>
主题: New Version Notification for draft-tao-netmod-yang-node-tags-04.txt

A new version of I-D, draft-tao-netmod-yang-node-tags-04.txt
has been successfully submitted by Qin Wu and posted to the IETF repository.

Name:		draft-tao-netmod-yang-node-tags
Revision:	04
Title:		Self Explanation Data Object Tags
Document date:	2020-08-10
Group:		netmod
Pages:		40
URL:            https://www.ietf.org/internet-drafts/draft-tao-netmod-yang-node-tags-04.txt
Status:         https://datatracker.ietf.org/doc/draft-tao-netmod-yang-node-tags/
Htmlized:       https://tools.ietf.org/html/draft-tao-netmod-yang-node-tags-04
Htmlized:       https://datatracker.ietf.org/doc/html/draft-tao-netmod-yang-node-tags
Diff:           https://www.ietf.org/rfcdiff?url2=draft-tao-netmod-yang-node-tags-04

Abstract:
   This document defines a method to tag data objects associated with
   operation and management data in YANG Modules.  This YANG data object
   tagging method can be used to identify characteristics data and
   correlate data objects from different data sources and provide input,
   instruction, indication to selection filter and filter queries of
   operational state on a server during a "pub/sub" service for YANG
   datastore updates.  When the state of all subscriptions of a
   particular Subscriber to be fetched is huge, the amount of data to be
   streamed out to the destination can be greatly reduced and only
   targeted to the characteristics data.

   An extension statement to be used to indicate YANG data node self
   explanation tags that SHOULD be added by the module implementation
   automatically (i.e., outside of configuration).

   A YANG module [RFC7950] is defined, which augments Module tag model
   and provides a list of data node entries to allow for adding or
   removing of data node self explanation tags as well as viewing the
   set of self explanation tags associated with a YANG module.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: 刘 鹏 <[email-masked]>
Date: Tue, 11 Aug 2020 10:53:49 +0000

Hi Qin,

I think it’s better and more mature than the last version. Here are some comments:

1. What is the difference between “data node” and “data object”? If they are the same, it is better to be consistent.

2. Whether the IANA should include all the functions before?

Regards,

Peng(CMCC)

________________________________
发件人: netmod <[email-masked]> 代表 Qin Wu <[email-masked]>
发送时间: 2020年8月10日 21:04
收件人: NETMOD Group <[email-masked]>
主题: Re: [netmod] New Version Notification for draft-tao-netmod-yang-node-tags-04.txt

Hi,

-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2020年8月10日 20:56
收件人: Qin Wu <[email-masked]>; Qin Wu <[email-masked]>; Benoit Claise <[email-masked]>; Liang Geng <[email-masked]>; Zongpeng Du <[email-masked]>
主题: New Version Notification for draft-tao-netmod-yang-node-tags-04.txt

Abstract:

The IETF Secretariat

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: 刘 鹏 <[email-masked]>
Date: Tue, 11 Aug 2020 10:58:01 +0000

In addition，

3. You mentioned that “Split Metric group from opm tag and define it as context info tag”, but I didn’t see context info tag to be defined, are you saying opm tag is one example of context info tag or not?
________________________________
发件人: netmod <[email-masked]> 代表 刘 鹏 <[email-masked]>
发送时间: 2020年8月11日 18:53
收件人: Qin Wu <[email-masked]>; NETMOD Group <[email-masked]>
主题: [netmod] 回复: New Version Notification for draft-tao-netmod-yang-node-tags-04.txt

Hi Qin,

Regards,

Peng(CMCC)

Hi,

-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2020年8月10日 20:56
收件人: Qin Wu <[email-masked]>; Qin Wu <[email-masked]>; Benoit Claise <[email-masked]>; Liang Geng <[email-masked]>; Zongpeng Du <[email-masked]>
主题: New Version Notification for draft-tao-netmod-yang-node-tags-04.txt

A new version of I-D, draft-tao-netmod-yang-node-tags-04.txt
has been successfully submitted by Qin Wu and posted to the IETF repository..

Htmlized:       https://tools.ietf.org/html/draft-tao-netmod-yang-node-tags-04<https://tools.ietf..org/html/draft-tao-netmod-yang-node-tags-04>

Abstract:

The IETF Secretariat