Subject: [payload] Question about draft-singh-payload-rtp-1d2d-parity-scheme

From: Bernard Aboba <[email-masked]>
Date: Tue, 28 Oct 2014 04:49:32 -0700

Can the masking scheme described in the draft support generation of multi-frame FEC such as is described in the paper below?http://static.googleusercontent.com/media/research.google.com/en/us/pubs/archive/41611.pdf
As an example, say it is desired to use the following 3-frame (6,3) FEC scheme shown in Figure 3: 
1 0 0 1 0 11 0 1 0 1 0 0 1 1 0 0 1
How would this be represented?   It doesn't seem like this would fit within a 16-bit mask (MSK = 00), so does this mean that the 48-bit mask (MSK = 01)is required?

---

From: Varun Singh <[email-masked]>
Date: Wed, 29 Oct 2014 16:44:38 +0200

Hi Bernard,

See inline.

-Varun

On Tue, Oct 28, 2014 at 1:49 PM, Bernard Aboba
<[email-masked]> wrote:
> Can the masking scheme described in the draft support generation of
> multi-frame FEC such as is described in the paper below?
> http://static.googleusercontent.com/media/research.google.com/en/us/pubs/archive/41611.pdf
>
> 1 0 0 1 0 1
> 1 0 1 0 1 0
> 0 1 1 0 0 1

The row FECs fit in 6, so that should be fine
The columns have SN-base, and I think 13 bits should be enough.
   SN_base: 1 RLE Mask for offset packets 1, 7, 13
   SN_base: 6 RLE Mask for offset packets 1, 13

If we wanted a FEC for all the packets, then that would need the larger mask.

> How would this be represented?   It doesn't seem like this would fit within
> a 16-bit mask (MSK = 00), so does this mean that the 48-bit mask (MSK = 01)
> is required?
>

See above, but for this example it doesn't seem like it. unless I
miscalculated something.

>
>
>
>
> _______________________________________________
> payload mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/payload
>

-- 
http://www.netlab.tkk.fi/~varun/