Subject: [payload] Specific PLI feedback from draft-ietf-payload-rtp-h265-01

From: Martin Ellis <[email-masked]>
Date: Thu, 11 Dec 2014 11:39:56 +0200

Hi,

In the early drafts of draft-ietf-payload-rtp-h265, there was a
proposed feedback message, "Specific Picture Loss Indication (SPLI)",
which was removed in later versions.
>From the list archives, I see that there was some discussion about
whether this feedback message should be defined in a separate document
updating RFC 4585, but I can't find any further references to it.

Does anyone know what happened there?
If SPLI is not used, what would be the recommended approach to give
feedback for specifically lost pictures, to allow tracking of errors
on the encoder side?

Cheers,
Martin

---

From: Jonatan Samuelsson <[email-masked]>
Date: Thu, 11 Dec 2014 13:24:06 +0000

Hi Martin,

Thanks for bringing up the question of feedback for indicating specific lost pictures in h.265.

There were two more feedback message features discussed during the h.265 payload drafting:
- indicating incorrect Decoded Picture Hash values
- indicating multiple reference pictures that can be used for reference

I, Muhammed Coban and Stephan Wenger have been drafting text for a new feedback message that is supposed to have support for all of these three features . The feedback message should be possible to use with h.265 as well as other codecs such as h.264. Our ambition is to soon submit an I-D in the AVTEXT working group. Please let me know if you would like to receive our current (draft) version of the draft.

Best Regards Jonatan

-----Original Message-----
From: payload [mailto:[email-masked]] On Behalf Of Martin Ellis
Sent: den 11 december 2014 10:40
To: [email-masked]
Subject: [payload] Specific PLI feedback from draft-ietf-payload-rtp-h265-01

Hi,

In the early drafts of draft-ietf-payload-rtp-h265, there was a proposed feedback message, "Specific Picture Loss Indication (SPLI)", which was removed in later versions.
>From the list archives, I see that there was some discussion about
whether this feedback message should be defined in a separate document updating RFC 4585, but I can't find any further references to it.

Does anyone know what happened there?
If SPLI is not used, what would be the recommended approach to give feedback for specifically lost pictures, to allow tracking of errors on the encoder side?

Cheers,
Martin

_______________________________________________
payload mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/payload

---

From: Jonatan Samuelsson <[email-masked]>
Date: Tue, 16 Dec 2014 13:41:25 +0000

Hi again,

The draft I mentioned below has now been submitted to the AVTEXT working group (https://datatracker.ietf.org/doc/draft-samuelsson-avtext-rpvi/). I have just sent out a notification about the availability of the draft on the AVTEXT mailing list.

In order to avoid parallel discussions, I suggest that further discussions on the topic are (primarily) held on the AVTEXT mailing list.

Best Regards Jonatan

-----Original Message-----
From: payload [mailto:[email-masked]] On Behalf Of Jonatan Samuelsson
Sent: den 11 december 2014 14:24
To: Martin Ellis; [email-masked]
Subject: Re: [payload] Specific PLI feedback from draft-ietf-payload-rtp-h265-01

Hi Martin,

Best Regards Jonatan

-----Original Message-----
From: payload [mailto:[email-masked]] On Behalf Of Martin Ellis
Sent: den 11 december 2014 10:40
To: [email-masked]
Subject: [payload] Specific PLI feedback from draft-ietf-payload-rtp-h265-01

Hi,

Cheers,
Martin