Subject: [payload] draft-ietf-payload-rtp-opus-05: maxaveragebitrate

From: Fredrik Bergholtz <[email-masked]>
Date: Wed, 10 Dec 2014 10:11:02 +0000

Hi.

I read in the latest draft that you have removed the maxaveragebitrate parameter from the SDP signalling for Opus. I think that this parameter is useful and that it provides added value over the bandwidth modifiers added by RFC 3556.

I must admit that I haven't read all of RFC 3556 but as I understand it, a b= line are not in any way related to an actual format of a media description. This means that with this mechanism, only one bitrate specification can be sent with each media description. Different coding algorithms have different constraints on the allowed bitrate. For example, I might want to send an SDP offer with both Enhanced apt-X at 576 kbit/s and Opus at 510kbit/s with cbr. Now, specifying 576kbit/s via a b= line works for apt-X but makes no sense for Opus and vice versa. I think that the a=fmtp line is the correct place to specify the desired bitrate.

For the broadcasting use-case, it is often more important to have a constant and predictable audio quality and network usage than mere audibility at any cost.

Best regards,
Fredrik Bergholtz
Swedish Radio

---

From: Jean-Marc Valin <[email-masked]>
Date: Thu, 11 Dec 2014 20:07:54 -0500

I have to say this is not something I understand really well. Does
anyone else here have an opinion on how to specify bit-rate?

	Jean-Marc

On 10/12/14 05:11 AM, Fredrik Bergholtz wrote:
> Hi.
> 
>  
> 
> I read in the latest draft that you have removed the maxaveragebitrate
> parameter from the SDP signalling for Opus. I think that this parameter
> is useful and that it provides added value over the bandwidth modifiers
> added by RFC 3556.
> 
>  
> 
> I must admit that I haven’t read all of RFC 3556 but as I understand it,
> a b= line are not in any way related to an actual format of a media
> description. This means that with this mechanism, only one bitrate
> specification can be sent with each media description. Different coding
> algorithms have different constraints on the allowed bitrate. For
> example, I might want to send an SDP offer with both Enhanced apt-X at
> 576 kbit/s and Opus at 510kbit/s with cbr. Now, specifying 576kbit/s via
> a b= line works for apt-X but makes no sense for Opus and vice versa. I
> think that the a=fmtp line is the correct place to specify the desired
> bitrate.
> 
>  
> 
> For the broadcasting use-case, it is often more important to have a
> constant and predictable audio quality and network usage than mere
> audibility at any cost.
> 
>  
> 
> Best regards,
> 
> Fredrik Bergholtz
> 
> Swedish Radio
> 
>  
> 
> 
> 
> _______________________________________________
> payload mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/payload
>

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Wed, 31 Dec 2014 04:57:49 +0000

My understanding is that the b= line in the SDP is quite a subjective parameter. I have seen people use it differently over the past several years. So, it is a bit difficult to infer much accuracy from that line.

OTOH, if someone feels like Opus needs to specify some sort of bitrate variability in the SDP, it can do so in an optional (opus) parameter. Obviously rules around how to set that value and what to do with that value need to be clearly specified.

Fredrik (or anyone else in the WG), do you see a strong need for this? If so, now is the time to mention that.

-acbegen

> On Dec 12, 2014, at 3:07 AM, Jean-Marc Valin <[email-masked]> wrote:
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1
> 
> iQEcBAEBAgAGBQJUij/kAAoJEJ6/8sItn9q9V6EIALgEC6Iv+nZuu2BU8useaV4Z
> jLRz97vCEdcmj60jMzELC2gSKLpVW3AMcbP7gtPjm0odeLFEMvoweUFytnVt/cd6
> bCadjHMPAOSNXrPtbmS57JdlcmWHnsrJIVrsV/Ipn6o44FWL2BN5g/LnwlSTKs/N
> OtrjAdLj8b/GsmVS6VTTjTkygL1bp1Wsry5oAGXIPwPqFgQwuGMAxv/Wf6eEu7c3
> eoZzBKfBDM0bC8L+RCy6REYKHvSjPbyPAH0bQvkkKHfSc6I5ZLOZspvOHBmHvQFu
> DNj4DHCShHPnRRknVnXCXX9ddSC4/bLQSyZ9+WI9622N5lkre8+VnUIGx9iAr3I=
> =ZuN4
> -----END PGP SIGNATURE-----
>

---

From: Fredrik Bergholtz <[email-masked]>
Date: Wed, 31 Dec 2014 09:42:41 +0000

Yes, I do see a strong need for specifying the bitrate. 

In the broadcasting use case we have to make sure that we get the best audio quality that is possible for the network that is currently used but never try to send more data than the particular link is capable of. For this reason, specifying a maximum bit rate is required.

In addition we often have the requirement that the quality is constant rather than the best possible. To avoid as many audible changes in the audio as possible over time we will often use constant bit rate and then it becomes even more important to be able to specify what bit rate should be. 

We will use the Opus codec over various network links with different capabilities in terms of bit rate, delay variation, absolute delay, etc and we will typically use the SDP to signal the parameters that best fit both the current network and the current type of radio production. 

Best regards
Fredrik Bergholtz
Swedish Radio

> On 31 dec 2014, at 05:57, "Ali C. Begen (abegen)" <[email-masked]> wrote:
>

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Wed, 31 Dec 2014 11:26:40 +0000

Authors

Please chime in and lets discuss s quick solution for this on the list. Once agreed we can ship this draft.

-acbegen

From: Fredrik Bergholtz <[email-masked]>
Sent: Dec 31, 2014 11:42 AM
To: Ali C. Begen (abegen)
Cc: Jean-Marc Valin <[email-masked]>;Fredrik Bergholtz;[email-masked]
Subject: Re: [payload] draft-ietf-payload-rtp-opus-05: maxaveragebitrate

Best regards
Fredrik Bergholtz
Swedish Radio