Subject: [payload] new I-D draft-edwards-rtp-ancillary RTP Payload for SMPTE ST 291 Ancillary Data

From: Thomas Edwards <[email-masked]>
Date: Wed, 14 Jan 2015 01:37:39 +0000

Dear Payload WG,

I have submitted a new I-D (draft-edwards-rtp-ancillary) defining an RTP Payload for SMPTE ST 291 Ancillary Data.

SMPTE Ancillary data is used in today's professional serial digital video formats to carry a range of ancillary data types, including time code, KLV metadata, Closed Captioning, and the Active Format Description (AFD).

The broadcast industry is preparing to move from the use of serial digital video over coax to "all-IP" professional networked media inside our broadcast plants.  Two of the needed standards have been there for years waiting for affordable 10 GbE networks.  IETF has already standardized RTP carriage of uncompressed video in RFC 4175, and 24-bit uncompressed audio in RFC 3190 (as referenced by AES67).

The one remaining item needed is a way of carrying SMPTE ancillary data over RTP, which this I-D should address.

The I-D has already been through an informal review by SMPTE 32NF, and I have worked in the comments received.  I do not expect that this process will require formal liaison with between IETF and SMPTE.  The data model used for the Ancillary data in RTP is based on an existing SMPTE standard to carry Ancillary data over MPEG transport stream, so fortunately most of the "heavy lifting" on the data model design has already been done.

A new version of I-D, draft-edwards-rtp-ancillary-00.txt
has been successfully submitted by Thomas G. Edwards and posted to the
IETF repository.

Name: draft-edwards-rtp-ancillary
Revision: 00
Title: RTP Payload for SMPTE ST 291 Ancillary Data
Document date: 2015-01-13
Group: Individual Submission
Pages: 11
URL:            http://www.ietf.org/internet-drafts/draft-edwards-rtp-ancillary-00.txt
Status:         https://datatracker.ietf.org/doc/draft-edwards-rtp-ancillary/
Htmlized:       http://tools.ietf.org/html/draft-edwards-rtp-ancillary-00

Abstract:
   This memo describes an RTP Payload format for SMPTE Ancillary data,
   as defined by SMPTE ST 291-1.  SMPTE Ancillary data is generally used
   along with professional video formats to carry a range of ancillary
   data types, including time code, KLV metadata, Closed Captioning, and
   the Active Format Description (AFD).

-Thomas

--
Thomas Edwards
VP Engineering & Development
FOX Network Engineering and Operations
[email-masked]<mailto:[email-masked]>
Phone: +1.310.369.6696
10201 West Pico Blvd.
Los Angeles, CA 90035

---

From: Thomas Edwards <[email-masked]>
Date: Wed, 14 Jan 2015 23:21:28 +0000

Dear Payload WG,

On the advice of the Payload WG chairs, I have re-submitted this I-D under the name "draft-edwards-payload-rtp-ancillary" so that it properly shows up in the Payload WG list of individual submissions.

http://datatracker.ietf.org/doc/draft-edwards-payload-rtp-ancillary/

-Thomas

From: FNG <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, January 13, 2015 at 5:37 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: new I-D draft-edwards-rtp-ancillary RTP Payload for SMPTE ST 291 Ancillary Data

Dear Payload WG,

Abstract:

-Thomas