Subject: [payload] Question regarding RFC 4867

From: Gunnar Persson N <[email-masked]>
Date: Mon, 12 Jan 2015 10:54:44 +0000

Hi
I have a simple question regarding RFC 4867
In chapter...
4.3.1<https://tools.ietf.org/html/rfc4867#section-4.3.1>.  The Payload Header

...it is stated:

Therefore, if a terminal continuously wishes to receive frames in the

   same mode X, it needs to set CMR=X for all its outbound payloads, and

   if a terminal has no preference in which mode to receive, it SHOULD

   set CMR=15 in all its outbound payloads.

Question:
Does "all its outbound payloads" mean "every RTP frame" (I e every 20ms)?

Comment:
On air interface CMR value is only communicated every second speech frame (I e every 40ms). I assume the idea is that BSS shall remember the last communicated CMR from mobile terminal and insert this CMR in all RTP frames. Please comment if my assumption is correct.

Best Regards,
Gunnar Persson at Ericsson

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 30 Jan 2015 11:54:28 +0100

Hi,

As author of this RFC, here is my answer.

On 2015-01-12 11:54, Gunnar Persson N wrote:
> In chapter…
>         4.3.1 <https://tools.ietf.org/html/rfc4867#section-4.3.1>.  The
>         Payload Header
> 
> …it is stated:
> 
>  
> 
> *Does “all its outbound payloads” mean “every RTP frame” (I e every 20ms)? *

payloads are RTP payloads, thus within each RTP packet sent for that
stream that contain an AMR payload.

> 
>  
> 
> Comment:
> 
> On air interface CMR value is only communicated every second speech
> frame (I e every 40ms). I assume the idea is that BSS shall remember the
> last communicated CMR from mobile terminal and insert this CMR in all
> RTP frames. Please comment if my assumption is correct.

Yes, that becomes the implication if one sends RTP packets which
contains only a single 20ms AMR frame.

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Services, Media and Network features, Ericsson Research EAB/TXM
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Färögatan 6                 | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------