Subject: [payload] Gen-ART review of draft-ietf-payload-rtp-opus-08

From: Christer Holmberg <[email-masked]>
Date: Sat, 11 Apr 2015 13:23:05 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>

Document:                         draft-ietf-payload-rtp-opus-08

Reviewer:                           Christer Holmberg

Review Date:                     11 April 2015

IETF LC End Date:             17 February 2015

IETF Telechat Date:         9 April 2015

Summary:        Most of the comments I gave on a previous version of the document have been addressed. However, it seems like one of the comments have not been addressed.

Major Issues: None

Minor Issues: I previously gave the following comment:

"Regarding SDP, I think it would be good to have the ABNF syntax for the a=fmtp parameter (currently you only have descriptive text of the different parameters). It makes the life for the parser implementers much easier :)"

I guess one, by reading section 7 and the examples, can figure out how to encode the a=fmtp parameter, but I think it would to explicitly define the syntax.

Editorial nits: None

---

From: "Ben Campbell" <[email-masked]>
Date: Tue, 14 Apr 2015 17:42:04 -0500

On 11 Apr 2015, at 8:23, Christer Holmberg wrote:

> “Regarding SDP, I think it would be good to have the ABNF syntax for 
> the a=fmtp parameter (currently you only have descriptive text of the 
> different parameters). It makes the life for the parser implementers 
> much easier :)”
>  
> I guess one, by reading section 7 and the examples, can figure out how 
> to encode the a=fmtp parameter, but I think it would to explicitly 
> define the syntax.

Hi Christer,

(For the record, I just recently took over responsibility for PAYLOAD, 
so if I'm misinterpreting things, someone please tell me :-)  )

While I can see that as a "might be nice" addition, I don't think it's 
something that we have required of other payload drafts. 
draft-ietf-payload-rtp (in RFC ed queue) says the following about ABNF 
for SDP parameters:

"Not that commonly used in RTP payload formats but may be useful when 
defining Media Type parameters of some complexity."

If I'm reading correctly, the FMTP parameters in this draft fit the 
pretty common "semicolon delimited list of parameter=value pairs", so I 
don't think this rises to the level of "some complexity".

So unless you think the parameters in this draft are more complex than 
average, I don't think we need to add them at this late stage. It might 
be worth discussing whether we should ask authors of future payload 
drafts to include ABNF for this sort of thing.

Thanks!

Ben.

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 15 Apr 2015 09:38:44 +0000

Hi,

> (For the record, I just recently took over responsibility for PAYLOAD, so if I'm misinterpreting things, someone please tell me :-)  )
>
> While I can see that as a "might be nice" addition, I don't think it's something that we have required of other payload drafts. 

After all my years of taking drafts through the IETF publication process, I have learned that there is no such thing as consistency :)

> draft-ietf-payload-rtp (in RFC ed queue) says the following about ABNF for SDP parameters:
>
> "Not that commonly used in RTP payload formats but may be useful when defining Media Type parameters of some complexity."
>
> If I'm reading correctly, the FMTP parameters in this draft fit the pretty common "semicolon delimited list of parameter=value pairs", so I don't think this rises to the level of "some complexity".
>
> So unless you think the parameters in this draft are more complex than average, I don't think we need to add them at this late stage. It might be worth discussing whether we should ask authors of future payload drafts to include ABNF for this sort of thing.

I can live without any changes.

Regards,

Christer

---

From: "Ben Campbell" <[email-masked]>
Date: Wed, 15 Apr 2015 08:56:35 -0500

On 15 Apr 2015, at 4:38, Christer Holmberg wrote:

>> (For the record, I just recently took over responsibility for 
>> PAYLOAD, so if I'm misinterpreting things, someone please tell me :-) 
>>  )
>>
>> While I can see that as a "might be nice" addition, I don't think 
>> it's something that we have required of other payload drafts.
>
> After all my years of taking drafts through the IETF publication 
> process, I have learned that there is no such thing as consistency :)
>

That is absolutely true. And I do think it's worth discussing whether 
future payload specs should do that. It's just a matter of who gets 
stuck with a new documentation requirement :-)

>> pretty common "semicolon delimited list of parameter=value pairs", so 
>> I don't think this rises to the level of "some complexity".
>>
>> So unless you think the parameters in this draft are more complex 
>> than average, I don't think we need to add them at this late stage. 
>> It might be worth discussing whether we should ask authors of future 
>> payload drafts to include ABNF for this sort of thing.
>

Thanks!