Subject: [payload] I-D Action: draft-ietf-payload-vp9-01.txt

From: [email-masked]
Date: Mon, 19 Oct 2015 14:06:48 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Audio/Video Transport Payloads Working Group of the IETF.

        Title           : RTP Payload Format for VP9 Video
        Authors         : Justin Uberti
                          Stefan Holmer
                          Magnus Flodman
                          Jonathan Lennox
                          Danny Hong
	Filename        : draft-ietf-payload-vp9-01.txt
	Pages           : 21
	Date            : 2015-10-19

Abstract:
   This memo describes an RTP payload format for the VP9 video codec.
   The payload format has wide applicability, as it supports
   applications from low bit-rate peer-to-peer usage, to high bit-rate
   video conferences.  It includes provisions for temporal and spatial
   scalability.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-payload-vp9/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-payload-vp9-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-payload-vp9-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Jonathan Lennox <[email-masked]>
Date: Mon, 19 Oct 2015 21:09:45 +0000

In addition to some editorial improvements, this version has some changes to better handle non-flexible mode in the presence of packet loss.

The first byte of “Layer indices” field has been changed to explicitly hold the temporal layer ID (“T”) and temporal up switching flag (“U”) for every packet.
This way, packets of both flexible and non-flexible modes carry the same first byte information of “Layer indices”. 
With this change in the non-flexible mode, the old GOF_IDX has been removed and the GOF information specified in the SS data is indexed using PICTURE ID.
In relation to the above change, the SS data is modified so that all frames of a GOF are specified in the order they appear. 
Previously, only the frames with distinct reference picture indices were specified in the GOF, and GOF_IDX was used to index one of the specified frames information. 
With this changes, the PICTURE ID  of the packet that carries the new SS data corresponds to the first specified frame of the GOF. 
Then subsequent PICTURE IDs are mapped to subsequently specified frames in the GOF, modulo N_G (the size of GOF).
 
Lastly, for the flexible mode, the P_DIFF field is modified to always be represented in 7 bits, thus removing the “X” bit.

Comments are welcome.

> On Oct 19, 2015, at 5:06 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> payload mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/payload
>