Subject: [payload] draft-ietf-payload-rtp-ancillary-05: ANC Line numbers and multistream video

From: Kjetil Oftedal <[email-masked]>
Date: Thu, 15 Sep 2016 22:07:29 +0200

Hi,

I commented earlier on the draft spec for carriage of ANC data over RTP:

>From the earlier email thread: "WGLC comments on
draft-ietf-payload-rtp-ancillary-03"
Comment:
"This new draft only has 11-bit line numbers with the effect of limiting
the supported
video rasters to 2047 lines. The emerging 4K/UHD standards on the other
hand has around
2160 active lines, thus not fully supported.  There is a similar issue
with the Horizontal_Offset field. This field is limited to 4096 (12-bits).
Ancillary data can be carried in the horizontal blanking/HANC of a
SDI-signal, which starts after the active
video section, thus it is barley reachable in 3840/UHD formats."

>From Thomas Edwards
Resolution:
"Line_Number" and "Offset" refer to the location of ANC data within an SDI
raster, not active video.  Several professional video vendors have told me
that since 2160 line professional video is carried in a quad mux, the SDI
line numbers are not going to change.  Moreover, it is expected that ANC
data will only be carried in one quadrant of the mux.  Going forward, the
industry seeks to move away from linkage between SDI lines and location of
ANC packets anyway, so it is expected that SDI raster location data will
no longer be required soon.  Thus I think it is best to maintain
compatibility with the existing SMPTE ST 2038 data model.
---

I have since reviewed the 2160p over quad link 3G-SDI specification
(SMPTE ST 425-5:2015) which states that ancillary data shall be mapped
to the first 3G-SDI link first etc. So far so good.
However, the specification also requires that Video Payload Identifier ANC
packet be present in all the data channels. (6.2.3) Which means there
will be at least one ancillary data packet in each of the eight data streams.
(Two data streams per 3G-SDI link)
How shall this be signaled in the RTP packets? If the Line_number is supposed
to be the original SDI raster line number, a receiver can receive the eight VPI
packets with the same line number and same position.

There is a similar issue with 3G-SDI Level B Dual link, which also
requires VPI in
both links. Most, if not all HD formats that can be carried with
3G-SDI Level B DL,
can be carried with 3G-SDI Level A. So the receiver cannot know what
the original
link format was based upon video format of the associated video essence stream.
Since the line numbers have different meaning in Level B and Level A
the original
ANC packet placement cannot be reliably restored in this case.

Best regards,
Kjetil Oftedal

---

From: Thomas Edwards <[email-masked]>
Date: Thu, 15 Sep 2016 20:58:29 +0000

For those who want to use the various SMPTE multi-link SDI standards with draft-ietf-payload-rtp-ancillary, we could add optional Media Type Parameters “3g-sdi-link” of 1-4 and “3g-sdi-data-stream” of 1-2.

I believe this should cover not only SMPTE ST 425-5 Quad Link 3 Gb/s Serial Interface and also SMPTE ST 425-3 Dual Link 3 Gb/s Serial Interface.

I’m not a big fan of specifying 3G-SDI link/stream inside the payload as it is a corner case for a set of formats about to be wiped out with IP.  Already at IBC last week I saw RFC 4175 over 25 GbE for 2160p50/60.

-Thomas

-- 
Thomas Edwards	
VP Engineering & Development
FOX Networks Engineering and Operations
[email-masked]
Phone: +1.310.369.6696
10201 West Pico Blvd.
Los Angeles, CA 90035

On 9/15/16, 1:07 PM, "payload on behalf of Kjetil Oftedal" <[email-masked] on behalf of [email-masked]> wrote:

>_______________________________________________
>payload mailing list
>[email-masked]
>https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_payload&d=DQICAg&c=uw6TLu4hwhHdiGJOgwcWD4AjKQx6zvFcGEsbfiY9-EI&r=lekNOOM5noV61zrPH3rwPyhtNnLLWoLEHgd0quQxly8&m=7SgTMVAgifHttZPn-RiKTrfVdTNcrYKuoLuNEgbx9oM&s=oBbVZDCNOsUCWc2kT9cC1uG6DdxsiyqsibjJeTlzr5A&e=

---

From: Kjetil Oftedal <[email-masked]>
Date: Thu, 15 Sep 2016 23:37:03 +0200

Hi,

I guess most broadcasters will not throw away all their existing equipment
when transitioning to IP. And 3G level B is often the only available output
on cameras from some manufacturers, so I guess this needs to be supported.
This gets even worse with the newer 12G-SDI standards. Such as, ST2082-12
(8K/4K over Quad 12G-SDI) which has 32 data streams mapped onto
4x12G-SDI links.
Although it would be nice if level A/full raster remapping was
required prior to
IP transmission as multistream interfaces does noẗ make that much sense
in a IP world. But this requires that the line numbers are not from
the original
SDI raster, but is more though of as timing information between video
and ANC data.

Regards,
Kjetil Oftedal

On 15/09/2016, Thomas Edwards <[email-masked]> wrote:
> For those who want to use the various SMPTE multi-link SDI standards with
> draft-ietf-payload-rtp-ancillary, we could add optional Media Type
> Parameters “3g-sdi-link” of 1-4 and “3g-sdi-data-stream” of 1-2.
>
> I believe this should cover not only SMPTE ST 425-5 Quad Link 3 Gb/s Serial
> Interface and also SMPTE ST 425-3 Dual Link 3 Gb/s Serial Interface.
>
> I’m not a big fan of specifying 3G-SDI link/stream inside the payload as it
> is a corner case for a set of formats about to be wiped out with IP.
> Already at IBC last week I saw RFC 4175 over 25 GbE for 2160p50/60.
>
> -Thomas
>
> --
> Thomas Edwards	
> On 9/15/16, 1:07 PM, "payload on behalf of Kjetil Oftedal"
> <[email-masked] on behalf of [email-masked]> wrote:
>
>>Hi,
>>