Subject: Re: [payload] WGLC on draft-ietf-payload-tetra-00

From: REISENBAUER Andreas <[email-masked]>
Date: Tue, 23 Oct 2018 16:14:20 +0000

Hi Dave,
Thanks a lot for your review!

I just uploaded version 01 of this draft where I did my best to incorporate all your comments

All the best
Andreas

From: payload [mailto:[email-masked]] On Behalf Of Dave Satterlee (Vocal)
Sent: Dienstag, 10. Juli 2018 20:04
To: [email-masked]
Subject: Re: [payload] WGLC on draft-ietf-payload-tetra-00

Review Comments for:

 RTP Payload Format for the TETRA Audio Codec
 draft-ietf-payload-tetra-00

July 10, 2018 by
David Satterlee
[email-masked]<mailto:[email-masked]>

The draft appears to be generally well specified and useful.

Review Comments:

1.  Introduction

It would seem to me that:

TErrestial Trunked Radio (TETRA)

should be have a capital A (in multiple places in the document):

TErrestial Trunked RAdio (TETRA)

4.3.7.  S: Spare (7 bits)

The use of 'those' appears awkward. There are a number of these cases throughout the document:

<< Those bits are reserved for future use and set to "0" currently.

>> The S bits...

5.  Payload example

<< The following example shows how a first and a consecutive 30 ms frame

   is combined into a single 60ms RTP packet.

>> The use of consecutive is awkward - maybe subsequent, or second consecutive?

8.1.  Offer/Answer Considerations

<< o  Integer multiples of 30ms SHALL be used for ptime.  It is

      recommended to use packet size of 60ms.  Even if there is no good

      reason why not doing so, there is no need that ptime and maxptime

      parameters are negotiated symmetrically.

>> o  Integer multiples of 30ms SHALL be used for ptime.  It is

      recommended to use packet size of 60ms.  There is no need that

      the ptime and maxptime parameters be negotiated symmetrically.

8.2.  Declarative SDP Considerations

<< For declarative media, the "ptime" and "maxptime" parameter specifies

   the possible variants used by the sender.

>> For declarative media, the "ptime" and "maxptime" parameter specify

   the possible variants used by the sender.

---

From: REISENBAUER Andreas <[email-masked]>
Date: Sun, 28 Oct 2018 19:49:35 +0000

Hi Dave,
Thanks for your first review - just realized I did not yet address this aspect yet - sorry.

You are entirely right - originally there have been some ideas to propagate multi-channel payload which was refused in a very early stage already but we did not update the intro chapter.

So I simply remove this item from the enumeration with the next version. Is this OK for you?

All the best
Andreas

From: payload [mailto:[email-masked]] On Behalf Of Dave Satterlee (Vocal)
Sent: Montag, 25. Juni 2018 17:17
To: [email-masked]
Subject: Re: [payload] WGLC on draft-ietf-payload-tetra-00

Review Comments for:

June 25, 2018 by
David Satterlee

Review Comments:

In section 1 (Introduction) the document says "The payload format supports transmission of multiple channels..." . It is unclear to me what this means, and where it is specified in the draft.

There are a number of non-technical issues (grammatical etc.).  I believe type of review is for a later stage, but I can make some recommendations on that aspect as well if needed.

Regards,
Dave Satterlee
VOCAL Technologies

On 6/19/2018 1:17 AM, Roni Even (A) wrote:
WG,

We are starting WGLC for https://tools.ietf.org/html/draft-ietf-payload-tetra-00 . Please review the draft and send your comments to the list by July 10th . If you read the draft but you have no comments, say so as well.

There were already some comments on the mailing list and we can consider them as part of the WGLC comments

Roni Even (A) Payload WG co-chair