Subject: Re: [payload] EOC marker in RTP transport of JPEG XS

From: "[email-masked]" <[email-masked]>
Date: Mon, 3 Jun 2019 01:38:43 +0000

Dear Descampe-san,

The socond solution is simple because the metadata packets and the coded-data packets can be clearly classified using slice counters.

In case of the first solution, since the EOC marker is mapped to the same packet as a coded-data, the above clear classification can not be performed.

Best regards,

Junichiro Kawamoto,
NHK (Japan Broadcasting Corporation)

差出人: Antonin Descampe
送信日時: 5月29日水曜日 17:53
件名: [payload] EOC marker in RTP transport of JPEG XS
宛先: [email-masked]

Dear all,

In the current version of the ID of RTP payload format for ISO/IEC 21122 (JPEG XS)

https://datatracker.ietf.org/doc/draft-ietf-payload-rtp-jpegxs/

the EOC marker (end of codestream, 2 bytes long) is transported in its own RTP packet, which leads to a suboptimal situation when padding is enabled, as a complete RTP packet is used for transporting only 2 bytes of metadata.

Two solutions are envisioned to solve this issue:
1/ Include the EOC marker in the previous packet (the one containing entropy coded data from the last slice).
2/ Simply drop the EOC marker and mark the packet containing data from the last slice as the last packet of the frame.

We advocate for the second solution as it avoids mixing entropy-coded data and metadata within the same RTP packet, but it also has the drawback to require to regenerate an EOC marker at decoding side if a fully compliant JPEG XS codestream is needed.

Any opinion/advice on this ?

Any other comment on the current version of the RTP payload format is also welcome. FYI, the current version is a much simpler version than the previous one and is now in a pretty mature stage.

Kind regards,

Antonin Descampe

--
Antonin Descampe - Ph.D.
Compression technologist

IntoPIX s.a.
+32 10 23 84 70 (Office)
[email-masked]<mailto:[email-masked]>

CONFIDENTIALITY NOTICE: Unless otherwise explicitly or implictly stated, this email message and any of its attachments are the property of intoPIX SA and are strictly confidential.
If you are an unintended recipient, please notify the sender immediately.

---

From: Antonin Descampe <[email-masked]>
Date: Mon, 3 Jun 2019 15:57:37 +0000

Dear Kawamoto-san,

Many thanks for your input. Unless there are other comments, we’ll go for the second solution then (simply discard the EOC marker) and update the draft accordingly.

Kind regards,

Antonin

Le 3 juin 2019 à 03:38, [email-masked]<mailto:[email-masked]> a écrit :

Dear Descampe-san,

Best regards,

Junichiro Kawamoto,

差出人: Antonin Descampe
送信日時: 5月29日水曜日 17:53
件名: [payload] EOC marker in RTP transport of JPEG XS
宛先: [email-masked]<mailto:[email-masked]>

Dear all,

Kind regards,

Antonin Descampe

--
Antonin Descampe - Ph.D.
Compression technologist

IntoPIX s.a.
+32 10 23 84 70 (Office)