Subject: [payload] I-D Action: draft-ietf-payload-tetra-03.txt

From: [email-masked]
Date: Fri, 26 Jul 2019 12:05:22 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Audio/Video Transport Payloads WG of the IETF.

        Title           : RTP Payload Format for the TETRA Audio Codec
        Authors         : Andreas Reisenbauer
                          Udo Brandhuber
                          Joachim Hagedorn
                          Klaus-Peter Höhnsch
                          Stefan Wenk
	Filename        : draft-ietf-payload-tetra-03.txt
	Pages           : 15
	Date            : 2019-07-26

Abstract:
   This document specifies a Real-time Transport Protocol (RTP) payload
   format for TETRA encoded speech signals.  The payload format is
   designed to be able to interoperate with existing TETRA transport
   formats on non-IP networks.  A media type registration is included,
   specifying the use of the RTP payload format and the storage format.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-payload-tetra/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-payload-tetra-03
https://datatracker.ietf.org/doc/html/draft-ietf-payload-tetra-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-payload-tetra-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: REISENBAUER Andreas <[email-masked]>
Date: Fri, 26 Jul 2019 19:27:03 +0000

Hi Antti, Roni, payload working group

I did an update of the draft-ietf-tetra. Thanks a lot for your comments Antti - according your feedback we changed references from the historical ETSI TS 100 392-3-6 to ETSI TS 100 392-3-8. Indeed we did not change the control bit structure. As it is well defined in our draft-ietf-payload-tetra we do not need a bit equivalency to any ETSI standard.

According Antti's comment regarding, it seems a bit superfluous to specify another slightly different format:
There is one single specification (ETSI TS 100 392-3-8 ) addressing both circuit switched lines as well as for transport via RTP and it specifically addresses the application of a TETRA Intersystem Interface rather than a generic TETRA audio payload for RTP. Because of this fact the cited standard is little more TDM-stylish rather than pure RTP. There are attributes included as part of the payload which are either superfluous or at least confusing for pure RTP communications (e.g. call reference, traffic type which identifies codec, frame number – supposed to handle slipped frames in SDH). For this reasons we (the authors) of this draft think it is worth to specify a pure IP way to propagate TETRA payload via RTP and therefore ask IANA to register “audio/TETRA” as a valid payload type according the specification given here.

Best regards 
Andreas

-----Original Message-----
From: payload <[email-masked]> On Behalf Of [email-masked]
Sent: Freitag, 26. Juli 2019 21:05
To: [email-masked]
Cc: [email-masked]
Subject: [payload] I-D Action: draft-ietf-payload-tetra-03.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
payload mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/payload