Subject: Re: [Perc] Names, Names, Names

From: "David Benham (dbenham)" <[email-masked]>
Date: Wed, 6 Jul 2016 18:58:56 +0000

Given these are names of entities, Distributor is better than Distribution in the naming; thus, Key Distributor works.   Also, Media Distribution Device was written in to the groups charter specifically because was generic (not tied to any specific topology) and deemed reasonably descriptive, so it would be only modestly different, and parallel to Key Distributor name to call it the Media Distributor. 

MDD  >>     Media Distributor
KMF  >>      Key Distributor 

-----Original Message-----
From: Russ Housley [mailto:[email-masked]] 
Sent: Wednesday, May 11, 2016 1:50 PM
To: Cullen Jennings <[email-masked]>
Cc: [email-masked]
Subject: Re: [Perc] Names, Names, Names

> KMF - change to "Key Server" or "Key Manger"

The role here is Key Distribution.  In some old systems, this is called the KDC, or Key Distribution Center.

Russ

-----Original Message-----
From: Cullen Jennings [mailto:[email-masked]] 
Sent: Thursday, May 12, 2016 9:57 AM
To: Emil Ivov <[email-masked]>
Cc: Paul Jones <[email-masked]>; [email-masked]
Subject: Re: [Perc] Names, Names, Names

> On May 11, 2016, at 4:18 PM, Emil Ivov <[email-masked]> wrote:
> 
> On Wed, May 11, 2016 at 3:45 PM, Cullen Jennings <[email-masked]> wrote:
>> 
>>> On May 11, 2016, at 3:08 AM, Emil Ivov <[email-masked]> wrote:
>>> 
>>> 
>>> 
>>> On Wednesday, 11 May 2016, Paul E. Jones <[email-masked]> wrote.
>>> 
>>> MDD - change to "Media Switch" or "Switch".
>>> 
>>> Switching Conference Server is the original term we used, I think. I have no strong preference on this one.
>>> 
>>> Why is it again that we are not using SFU here?
>>> 
>>> Emil
>>> 
>> 
>> Some people felt the "Forward" part implied an architecture where it only forwarded without modifying. PERC supports that arch but also supports some sort of modifications so we needed a moe general term. I was hoping that Switch or Media Switch might avoid that problem in that a SFU is one type of Media Switch but there are other types that both forward and modify. Work for you?
> 
> I feel that if we have a common denominator between topologies then it
> should be defined and named in the topologies draft. I also feel that
> terms like SFU are often used in a way that is generic enough (so much
> so that 7667 uses it without actually defining it). Most importantly
> though, I believe the gain of using a common and well known term would
> far outweigh the potential confusion of it not being perfectly exact.
> 
> In other words: I cannot believe that someone would ever look at PERC
> and say: "oh wait this thing talks about the 3.7 topo from 7667 and I
> really am more like the one in 3.8 so nah ... no go."
> 

Good point. I mostly find topologies too baffling to bother reading but agree this should be aligned.  

> That said, I don't believe that this is the most important issue we
> are facing now, so I could live with whatever. I am sure we could use
> the extra exercise on our brains anyway ;)
> 
> Emil

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 7 Jul 2016 07:39:06 -0700

I like that. 

> On Jul 6, 2016, at 11:58 AM, David Benham (dbenham) <[email-masked]> wrote:
>