Subject: [PSAMP] two more selectorAlgorithm

From: "Schmoll, Carsten" <[email-masked]>
Date: Mon, 7 Aug 2006 19:00:49 +0200

Dear authors of [PSAMP-INFO] + [PSAMP-PROTO],
 
I recently read above documents and would like to
extend the list of selector algorithms with two 
new algorithms:

* Random 1-in-k sampling    (spatial)

where from every consequitive k packets within 
a selector's input stream one is selected at random.

and

* Random 1-in-T sampling    (temporal)

where from all packets within a selector's input
observed within the interval T one packet is selected
at random.

(current selector algorithm list is in [PSAMP-INFO],
 section 9.2.5  selectorAlgorithm)

In case you should agree to include these two in the 
list I can supply a description for [PSAMP-INFO] and
for [PSAMP-PROTO], section 6.5.2 Selector Report Interpretation
with the needed selector parameters and examples.

Thanks for your consideration.
Comments?

Best regards,
Carsten.

--
"The difference between theory and practice is that in theory
theory and practice are the same but in practice they are not."

</>Dipl.Ing. Carsten Schmoll           Fraunhofer Institute FOKUS
[email-masked]         National Research Institute
Fraunhofer FOKUS / dept. ANTS       for Open Communication Systems
Tel: +49-30-3463-7136               Kaiserin-Augusta-Allee 31
Fax: +49-30-3463-8000               D-10589 Berlin, Germany

_______________________________________________
PSAMP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/psamp

---

From: Andrew Johnson <[email-masked]>
Date: Mon, 07 Aug 2006 23:45:02 +0100

Hello Carsten

Please see some comments inline.

> a selector's input stream one is selected at random.

How is this different from n-out-of-N, where n = 1 and N = k?

> observed within the interval T one packet is selected

How do you scale this method to gain information about the
parent population?  For example, if T = 10 seconds and the
traffic is a single stream sending 1000 pps, it would generate
the same results as if the stream were sending 1 pps.

Temporal sampling could scale if you sampled a window of
t milliseconds every interval T.  e.g. 100ms out of 1 second.

regards

Andrew