Subject: RE: [PSAMP] two more selectorAlgorithm

From: "Schmoll, Carsten" <[email-masked]>
Date: Tue, 8 Aug 2006 10:41:05 +0200

Dear Andrew,

please see my reply inline (some oroginal text deleted). 

> > * Random 1-in-k sampling    (spatial)
> 
> How is this different from n-out-of-N, where n = 1 and N = k?

You're right - it isn't. Tell it to the fact that everytime I
read a paper about sampling n-out-of-N, n is always >> 1.
So for PSAMP a separate 1-in-k is redundant.

> > * Random 1-in-T sampling    (temporal)
> > 
> > where from all packets within a selector's input
> > observed within the interval T one packet is selected
> > at random.
> 
> How do you scale this method to gain information about the
> parent population?  For example, if T = 10 seconds and the
> traffic is a single stream sending 1000 pps, it would generate
> the same results as if the stream were sending 1 pps.

Yes, thats true too. You don't scale this method to the parent 
population thus resulting in a very diverse attained selection
fraction.

For some measurements (e.g. QoS estimation) this is just fine.
The requirement there might be: I'd like to sample 3.000 packets 
per minute from the stream (regardless of there being 30.000 or 
300.000 packets in the stream). 
That is not possible with any of the other methods as far as I see.
Therefore I would like to keep 1-in-T as one new selector algorithm.

> Temporal sampling could scale if you sampled a window of
> t milliseconds every interval T.  e.g. 100ms out of 1 second.

Correct, that would be Random time-based sampling, where the start
of the interval t would be a random time in between 0 and T-t from
the beginning of the interval T.

That leaves us with the two (different than before) additions:

* Random 1-in-T sampling
* Random time-based sampling

Ok?

Best regards,
Carsten.

_______________________________________________
PSAMP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/psamp

---

From: "Schmoll, Carsten" <[email-masked]>
Date: Tue, 8 Aug 2006 11:04:05 +0200

> 300.000 packets in the stream). 

Ah, dear me: the correct example must be

I'd like to sample one packet every 20 msec, selected closest
to a random time offset inside each 20 msec interval
(regardless of there being 10 or 100 packets per interval
in the stream).

Regards,
Carsten.

---

From: "Tanja Zseby" <[email-masked]>
Date: Tue, 15 Aug 2006 09:49:21 +0200

Hi Carsten,

PSAMP-INFO just describes the IEs for the sampling schemes defined in
the PSAMP-TECH document (draft-ietf-psamp-sample-tech-07.txt). Of course
there are many more sampling schemes possible, but for PSAMP-TECH we
decided to concentrate on the most basic schemes to make it not too
complex for now (e.g. we also have a quite limited filter-definition).
So I wouldnt add further schemes unless there are very good arguments
why exactly these scheme are required now. I also think it is easy to
add further schemes in future in case vendors use/require them.

Regards,
Tanja

> -----Original Message-----
> From: Schmoll, Carsten [mailto:[email-masked]] 
> Sent: Tuesday, August 08, 2006 10:41 AM
> To: Andrew Johnson
> Cc: [email-masked]
> Subject: RE: [PSAMP] two more selectorAlgorithm
> 
> 
> Dear Andrew,
> 
> > > where from all packets within a selector's input observed 
> within the 
> > > interval T one packet is selected at random.
> > 
> > How do you scale this method to gain information about the parent 
> > population?  For example, if T = 10 seconds and the traffic is a 
> > single stream sending 1000 pps, it would generate the same 
> results as 
> > if the stream were sending 1 pps.
> 
> Yes, thats true too. You don't scale this method to the 
> parent population thus resulting in a very diverse attained 
> selection fraction.
> 
> The requirement there might be: I'd like to sample 3.000 
> packets per minute from the stream (regardless of there being 
> 30.000 or 300.000 packets in the stream). 
> > Temporal sampling could scale if you sampled a window of t 
> > milliseconds every interval T.  e.g. 100ms out of 1 second.
> 
> Correct, that would be Random time-based sampling, where the 
> start of the interval t would be a random time in between 0 
> and T-t from the beginning of the interval T.
>