Subject: Packet Sampling in Cisco and Juniper Gears

From: "Stas Khirman" <[email-masked]>
Date: Tue, 4 May 2004 17:24:11 -0700

Do Cisco and Juniper gears support some form of packet sampling? I had
checked Juniper documentation and it mention packet sampling fro cFlowD
(Netflow) and file dumping , but it is seen to deal only with L3/L4
headers only. Does Cisco and/or Juniper support sFlow or something
similar??

Regards
Stas

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/psamp/>

---

From: "Fulvio Risso" <[email-masked]>
Date: Wed, 5 May 2004 09:13:28 +0200

Cisco Catalyst 9000 supports packet capture (not sampling).
This refers only to the packets that go to the supervisor board. Packets
that are routed directly from the network cards cannot be captured at this
time.

Cheers,

	fulvio

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Stas Khirman
> Sent: mercoledi 5 maggio 2004 2.24
> To: [email-masked]
> Subject: Packet Sampling in Cisco and Juniper Gears
>
>

---

From: Benoit Claise <[email-masked]>
Date: Sat, 08 May 2004 21:58:52 +0200

Stas,

>Do Cisco and Juniper gears support some form of packet sampling? 
>
Yes for Cisco: systematic count based sampling and random count based 
sampling.

Regards, Benoit

>I had

---

From: "Stas Khirman" <[email-masked]>
Date: Sat, 8 May 2004 15:17:10 -0700

Benoit and all,

Thank you for responses, but it's seen that I failed in my initial question
description.

Yes, Juniper and [high end] Cisco gears are supporting randomly sampled
NetFlow and some other statistics.

But do they support export of the packet samples? I mean random capture and
export of the partial packet snapshots (header+part of payload) in the
manner similar to sFlow?

Regards
Stas

> From: Benoit Claise [mailto:[email-masked]]
> Sent: Saturday, May 08, 2004 12:59 PM
> To: Stas Khirman
> Cc: [email-masked]
> Subject: Re: Packet Sampling in Cisco and Juniper Gears
>
>
> Stas,
>

---

From: "Fulvio Risso" <[email-masked]>
Date: Sun, 9 May 2004 09:43:13 +0200

> Sent: domenica 9 maggio 2004 0.17
> To: Benoit Claise
> Cc: [email-masked]
> Subject: RE: Packet Sampling in Cisco and Juniper Gears
>
>
> Benoit and all,
>

Cisco Catalyst 9000 exports complete packets (you have to apply a sampling
mechianism on the collector size, if you want).
However, this device is able to capture only the packets that goes through
the supervisor card.

	fulvio

---

From: Benoit Claise <[email-masked]>
Date: Tue, 11 May 2004 09:24:27 +0200

Hi Stas

>export of the partial packet snapshots (header+part of payload) in the
For this specific question on the high end routers, not right now but 
foreseen.

Regards, Benoit.