Subject: [rtcweb] Proposed minutes and call for consensus

From: Ted Hardie <[email-masked]>
Date: Mon, 16 Aug 2021 11:39:53 +0100

****
The working group met at IETF 111 on July 29, 2021

During the meeting, the working group discussed
https://datatracker.ietf.org/doc/draft-uberti-rtcweb-rfc8829bis/ and agreed
to add language that would clarify that the currently correct language was
formerly max-bundle. The group also agreed that the 3rd party call control
issue should be documented but that there should be no normative changes.

In AOB, the group discussed the examples draft, which is currently an
AD-sponsored draft that has expired.  The chairs agreed to talk to Suhas to
confirm that he still had energy and, if so, to work with the AD to find
reviewers.
*****

Please send any corrections to the list; if you have objections to the
consensus of the room, please also send those to the list.  Assuming that
none are received, the next step would be a WGLC of rfc8829bis once the
agreed changes are mad.

Ted and Sean

Raw minutes:

Original BOF was March 2011 and we are not done yet.
JSEPbis

I-D:
https://datatracker.ietf.org/doc/draft-uberti-rtcweb-rfc8829bis/

Repo:
https://github.com/rtcweb-wg/jsep/pull/1017

Diff:
https://tools.ietf.org/rfcdiff?url1=https://www.rfc-editor.org/rfc/rfc8829.txt&url2=https://www.ietf.org/archive/id/draft-uberti-rtcweb-rfc8829bis-00.txt

Justin presented.

Ekr - add that the correct behavior is what was max-bundle.

Justin will add a bit of that text which clarifies prefered behavior to
introduction section.

On the Issue with 3PCC:

Roman would like to see us to add a note that says it works this way and
3PCC implementation need to be aware but no normative changes to how the
draft works. No objections to adding this.

Sean Turner - are we done? No issues raised.
------------------------------

Murray - There’s the examples document - it’s dead. Do we want to
reconsider? Not invested in it.

Cullen - there’s useful info for implementers and we were going to pub, but
don’t know what we were waiting for. I prefer to pub.

Sean - fine to run it through this WG.

Murray - I’ll check the charter.

Sean - we’ll check with Suhas.

Ted - we’ll take it to the list. The review of examples is difficult. It
may have stalled on reviews.
Please send a note to chairs that you will review. We’ll ask Suhas if it’s
ready.

Murray - if there’s not enough energy that’s ok too.

ekr - fine to keep as an I-D, and not advance - lot of work, there are
defects in the doc, world has gone on.

Nils - I tried to review and ran out of steam. Devide and conquer I guess?
One person to review would take a lot of time.

Sean - fine to split it up.

Cullen - we split it up last time, got good reviews. Let’s review the
sections we didn’t get reviews on the last time. But asking for reviews and
not publishing doesn’t encourage people to review.

Justin - machine generation found issues we thought were correct. Unless
machine checked, there will be errors.

ekr - who is advocating to take it to RFC?

Bernard - 2nd Justin’s concerns. SDP has changed. Likely an enormous amt
work required here. Not saying it’s not worth doing.

Justin - python based generator for JSEP, maybe could adapt that for this
effort. Offering to help.

Bernard - reviewing the generator would be easier than the examples.

Nils - the draft abbreviates the SDP in the latter sections. Automating it
will change the examples.

Jonathan Lennox - agree with ekr. Don’t think it’s worth the effort.

Cullen - everytime I have to debug webrtc, I have to look at SDP.

Timothy - audience would be implementers of the stack. You can debug SDP
with browser tools. But it’s a small audience

Sean - we can solicit reviews and then hand it back to you, Murray.

Ted - first check into Suhas. If he doesn’t have energy, we should take
that signal. After talking to him, the chairs will talk to Murray about
AD-sponsored. Anyone object?

(no objections)

Ted - any other topic for the WG?

(none raised)

---

From: Sean Turner <[email-masked]>
Date: Mon, 16 Aug 2021 12:40:08 -0400

lgtm

> On Aug 16, 2021, at 06:39, Ted Hardie <[email-masked]> wrote:
> 
> ****
> During the meeting, the working group discussed https://datatracker.ietf.org/doc/draft-uberti-rtcweb-rfc8829bis/ and agreed to add language that would clarify that the currently correct language was formerly max-bundle. The group also agreed that the 3rd party call control issue should be documented but that there should be no normative changes.
> 
> In AOB, the group discussed the examples draft, which is currently an AD-sponsored draft that has expired.  The chairs agreed to talk to Suhas to confirm that he still had energy and, if so, to work with the AD to find reviewers.
> *****
> 
> Please send any corrections to the list; if you have objections to the consensus of the room, please also send those to the list.  Assuming that none are received, the next step would be a WGLC of rfc8829bis once the agreed changes are mad.
> 
> Ted and Sean
> 
> 
> 
> 
> Raw minutes:
> 
> Justin will add a bit of that text which clarifies prefered behavior to introduction section.
> 
> On the Issue with 3PCC:
> 
> Roman would like to see us to add a note that says it works this way and 3PCC implementation need to be aware but no normative changes to how the draft works. No objections to adding this.
> 
> Murray - There’s the examples document - it’s dead. Do we want to reconsider? Not invested in it.
> 
> Cullen - there’s useful info for implementers and we were going to pub, but don’t know what we were waiting for. I prefer to pub.
> 
> Ted - we’ll take it to the list. The review of examples is difficult. It may have stalled on reviews.
> Please send a note to chairs that you will review. We’ll ask Suhas if it’s ready.
> 
> ekr - fine to keep as an I-D, and not advance - lot of work, there are defects in the doc, world has gone on.
> 
> Nils - I tried to review and ran out of steam. Devide and conquer I guess? One person to review would take a lot of time.
> 
> Cullen - we split it up last time, got good reviews. Let’s review the sections we didn’t get reviews on the last time. But asking for reviews and not publishing doesn’t encourage people to review.
> 
> Justin - machine generation found issues we thought were correct. Unless machine checked, there will be errors.
> 
> Bernard - 2nd Justin’s concerns. SDP has changed. Likely an enormous amt work required here. Not saying it’s not worth doing.
> 
> Justin - python based generator for JSEP, maybe could adapt that for this effort. Offering to help.
> 
> Nils - the draft abbreviates the SDP in the latter sections. Automating it will change the examples.
> 
> Timothy - audience would be implementers of the stack. You can debug SDP with browser tools. But it’s a small audience
> 
> Ted - first check into Suhas. If he doesn’t have energy, we should take that signal. After talking to him, the chairs will talk to Murray about AD-sponsored. Anyone object?
> 
> (no objections)
>