Subject: [RTG-DIR] Routing Directorate Review of draft-ietf-mpls-seamless-mcast-15

From: Stig Venaas <[email-masked]>
Date: Mon, 02 Feb 2015 13:38:58 -0800

Hi

I have been selected as the Routing Directorate reviewer for this draft. 
The Routing Directorate seeks to review all routing or routing-related 
drafts as they pass through IETF last call and IESG review, and 
sometimes on special request. The purpose of the review is to provide 
assistance to the Routing ADs. For more information about the Routing 
Directorate, please see ​ 
http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it 
would be helpful if you could consider them along with any other IETF 
Last Call comments that you receive, and strive to resolve them through 
discussion or by updating the draft.

Document: draft-ietf-mpls-seamless-mcast-15
Reviewer: Stig Venaas
Review Date: 2 February 2015
IETF LC End Date: 2 February 2015
Intended Status: Proposed Standard

Summary:
The document is fairly well written. I only found minor editorial
issues, plus potentially a missing IANA action.

The document states in e.g.
6.2.2. Leaf A-D Route for Global Table Multicast
that the RD in the MCAST-VPN NLRI is set to all 1s for (*,G)-state.
Is this use of RD defined in another document? Shouldn't RD type
65535 then be assigned for this purpose in
http://www.iana.org/assignments/route-distinguisher-types/route-distinguisher-types.xhtml

Minor issues:

Section 3:
The reader is suppose to be familiar with MVPN procedures and
               ^^^^^^^^

although this by no means imply that this alternative
                           ^^^^^^

5.1.2. Routes re-avertise by PE or ASBR
               ^^^^^^^^^^^
5.2.2. Routes re-avertise by PE or ASBR
               ^^^^^^^^^^^

Stig

---

From: Loa Andersson <[email-masked]>
Date: Tue, 03 Feb 2015 12:38:16 +0800

Folks,

First we have a problem with the draft-ietf-mpls-seamless-mcast aliases.
The mail does not go directly to most of the authors, even though I
guess the authors should see this through the mpls wg list.

I've copied the authors with their addresses directly.

Stig,

See inline please.

> issues, plus potentially a missing IANA action.

Section 15 is the IANA section, can you be mote specific about
"potentially a missing IANA action"?

/Loa
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Eric C Rosen <[email-masked]>
Date: Tue, 3 Feb 2015 10:26:45 -0500

On 2/2/2015 4:38 PM, Stig Venaas wrote:
> The document states in e.g. 6.2.2. Leaf A-D Route for Global Table
> Multicast that the RD in the MCAST-VPN NLRI is set to all 1s for
> (*,G)-state. Is this use of RD defined in another document?

No it isn't.

> Shouldn't RD type 65535 then be assigned for this purpose in

Stig,

I think you're right, the draft should do something to prevent a future 
draft from using -1 in the RD field.  Perhaps we should ask IANA to 
assign value 65535  to "for use only as specified in this document".

Of course, IANA will complain that we're not supposed to ask for 
specific assignments, but it's a bit too late to ask for early 
allocation ;-)

Eric

P.S.: The nits you pointed out are fixed in the source.

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 3 Feb 2015 20:48:56 -0500

Eric: 

An early allocation just needs a review of your WG chairs and AD.  Start the conversation with Loa - he's good at working through these issues.  

Sue 

-----Original Message-----
From: rtg-dir [mailto:[email-masked]] On Behalf Of Eric C Rosen
Sent: Tuesday, February 03, 2015 10:27 AM
To: Stig Venaas; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [RTG-DIR] [mpls] Routing Directorate Review of draft-ietf-mpls-seamless-mcast-15

No it isn't.

Stig,

I think you're right, the draft should do something to prevent a future draft from using -1 in the RD field.  Perhaps we should ask IANA to assign value 65535  to "for use only as specified in this document".

Of course, IANA will complain that we're not supposed to ask for specific assignments, but it's a bit too late to ask for early allocation ;-)

Eric

---

From: Loa Andersson <[email-masked]>
Date: Wed, 04 Feb 2015 12:06:01 +0800

Sue,

Tnx - though I'm not sure here.

Adrian, Pearl and Eric you need to look at the proposal below.

The early allocation follows the same rules as other allocations when
it comes to assigning specific values.

What I see here is that Eric want to assign 65535 from the
Route Distinguisher Type Field; values 32768-65535 are assigned under
IETF Consensus.

We have a document that is past IETF Last Call (2 days) in fact the
comments from Stig was part of the IETF Last Call comments.

I think Eric is correct, it is to late for an early allocation. What I
propose, given that Adrian and IANA (Pearl) agree, is that Eric add
some text in response to the LC comment that says:

In body text (Eric you'll have to flesh it out a bit).

"A RD field with the value [TBAx] is for use only as specified in this 
document."

And in the IANA section.

"IANA is requested to assign a new Route Distinguisher Type from the
Route Distinguisher Type Field registry. The highest available value in
the IETF consensus range should be assigned."

/Loa

--

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 4 Feb 2015 10:24:59 -0500

Loa:

Thanks for doing what you can.   

Sue 

-----Original Message-----
From: Loa Andersson [mailto:[email-masked]] 
Sent: Tuesday, February 03, 2015 11:06 PM
To: Susan Hares; 'Eric C Rosen'; 'Stig Venaas'; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; <[email-masked]>
Subject: Re: [RTG-DIR] [mpls] Routing Directorate Review of draft-ietf-mpls-seamless-mcast-15

Sue,

The early allocation follows the same rules as other allocations when it comes to assigning specific values.

What I see here is that Eric want to assign 65535 from the Route Distinguisher Type Field; values 32768-65535 are assigned under IETF Consensus.

We have a document that is past IETF Last Call (2 days) in fact the comments from Stig was part of the IETF Last Call comments.

I think Eric is correct, it is to late for an early allocation. What I propose, given that Adrian and IANA (Pearl) agree, is that Eric add some text in response to the LC comment that says:

"A RD field with the value [TBAx] is for use only as specified in this document."

And in the IANA section.

"IANA is requested to assign a new Route Distinguisher Type from the Route Distinguisher Type Field registry. The highest available value in the IETF consensus range should be assigned."

/Loa

On 2015-02-04 09:48, Susan Hares wrote:
>> http://www.iana.org/assignments/route-distinguisher-types/route-disti
>> n
>> guisher-types.xhtml
>
> Stig,
>

--

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 5 Feb 2015 20:48:40 -0000

Hi Pearl,

Thanks for this.

I do not believe you need to make any early allocation assignment.
It seems to me that an allocation of this particular code point is very unlikely to arrive in the next couple of weeks.

The text is now in the draft, and the draft is on its way to the IESG for evaluation on 19/2

Cheers,
Adrian

> From: Pearl Liang via RT [mailto:[email-masked]]
> Sent: 05 February 2015 19:42
> Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]; [email-masked]; draft-
> [email-masked]; [email-masked];
> [email-masked]
> Subject: [IANA #807148] Re: [RTG-DIR] [mpls] Routing Directorate Review of
> draft-ietf-mpls-seamless-mcast-15
> 
> Hi Loa, Sue, Eric, Adrian, et al.
> 
> Adrian, we have a question for you.
> 
> We received the added IANA action from Eric as per the discussion below.
> Here is a copy of Eric's proposed text in version -16::
> 
> [[[
> This document makes use of a Route Distinguisher whose value is all
> 1's. The two-octet type field of this Route Distinguisher thus has
> the value 65535. IANA is therefore requested to assign the value
> 65535 from the "Route Distinguisher Type Field" registry to "For Use
> Only in Certain Leaf A-D Routes", with this document as the
> reference.
> ]]]
> 
> The registry is located at http://www.iana.org/assignments/route-distinguisher-
> types.
> Values 32768-65535 are assigned under IETF Consensus.
> 
> The above text looks fine.  Since it looks like the draft is almost approved,
> Is it okay to complete the requested action when the document has been
> approved?
> If you need an early assignment now to lock down the value 65535, we need
> Adrian
> to advise us how to proceed.
> 
> Thanks,
> ~pl
> 
> Pearl Liang
> ICANN
> 
> 
> On Wed Feb 04 04:06:36 2015, [email-masked] wrote:
> > Sue,
> >
> > > An early allocation just needs a review of your WG chairs and AD.
> > > Start the conversation with Loa - he's good at working through these
> > > issues.
> > >
> > > Sue
> > >
> > >> http://www.iana.org/assignments/route-distinguisher-types/route-
> > >> distin
> > >> guisher-types.xhtml
> > >
> > > Stig,
> > >
> > > I think you're right, the draft should do something to prevent a
> > > future draft from using -1 in the RD field.  Perhaps we should ask
> > > IANA to assign value 65535  to "for use only as specified in this
> > > document".
> > >

---

From: "Pearl Liang via RT" <[email-masked]>
Date: Thu, 05 Feb 2015 19:41:36 +0000

[[[

The registry is located at http://www.iana.org/assignments/route-distinguisher-types.
Values 32768-65535 are assigned under IETF Consensus.

The above text looks fine.  Since it looks like the draft is almost approved,
Is it okay to complete the requested action when the document has been approved?
If you need an early assignment now to lock down the value 65535, we need Adrian
to advise us how to proceed.

Thanks,
~pl

Pearl Liang
ICANN

---

From: "Pearl Liang via RT" <[email-masked]>
Date: Thu, 05 Feb 2015 21:32:26 +0000

Hi Adrian,

Thank you for the reply.  I've responded to the Evaluation request.

Cheers,
~pl

On Thu Feb 05 20:49:09 2015, [email-masked] wrote:
> It seems to me that an allocation of this particular code point is
> very unlikely to arrive in the next couple of weeks.
> 
> > > Route Distinguisher Type Field registry. The highest available
> > > value
> > > in
> > > > From: rtg-dir [mailto:[email-masked]] On Behalf Of Eric
> > > > C
> > > > Rosen
> > > > To: Stig Venaas; draft-ietf-mpls-seamless-
> > > > [email-masked];
> > > > [email-masked]
> > > > Subject: Re: [RTG-DIR] [mpls] Routing Directorate Review of
> > > > draft-