Subject: [RTG-DIR] RtgDir review:

From: Ravi Singh <[email-masked]>
Date: Fri, 9 Feb 2018 13:36:20 +0000

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document: draft-ietf-bfd-yang-09
Reviewer: Ravi Singh
Review Date: 02/09/2018
Intended Status: Proposed standard

Summary: there is more commonality of info in the new modules listed in sections 2.6-2.10 than there are differences. So, I think it would be worthwhile looking at sub-abstracting things to avoid repetitive fields individually listed in the modules of section 2.6-2.10.

Details:
I've reviewed the draft. Most sections look good.
My comments below pertain to 2.6 to 2.10.
Section 2 says "Since BFD is used for liveliness detection of various forwarding
   paths, there is no uniform key to identify a BFD session.  So the BFD
   data model is split in multiple YANG modules where each module
   corresponds to one type of forwarding path. "
That is ok. However, this is causing too much repetition of info across the multiple modules.
There appears to be scope for modularization to not repeat the individual fields in describing them in every module that uses them.
Instead sub-modules should be considered & listed in one section which just augment the newly created modules of this draft wherever currently used.

Eg.
Separate sub-modules could be considered for:
A.
        +--ro session-statistics
        |  +--ro session-count?              uint32
        |  +--ro session-up-count?           uint32
        |  +--ro session-down-count?         uint32
        |  +--ro session-admin-down-count?   uint32

B.
           +--rw source-addr                 inet:ip-address
           +--rw dest-addr                   inet:ip-address
           +--rw local-multiplier?           multiplier
           +--rw (interval-config-type)?
           |  +--:(tx-rx-intervals)
           |  |  +--rw desired-min-tx-interval?    uint32
           |  |  +--rw required-min-rx-interval?   uint32
           |  +--:(single-interval)
           |     +--rw min-interval?               uint32
           +--rw demand-enabled?             boolean {demand-mode}?
           +--rw admin-down?                 boolean
           +--rw authentication! {authentication}?
           |  +--rw key-chain?    kc:key-chain-ref
           |  +--rw meticulous?   Boolean

C.
              +--ro path-type?              identityref
              +--ro ip-encapsulation?       boolean
              +--ro local-discriminator?    discriminator
              +--ro remote-discriminator?   discriminator
              +--ro remote-multiplier?      multiplier
              +--ro demand-capability?      boolean {demand-mode}?
              +--ro source-port?            inet:port-number
              +--ro dest-port?              inet:port-number
              +--ro session-running
              |  +--ro session-index?                uint32
              |  +--ro local-state?                  state
              |  +--ro remote-state?                 state
              |  +--ro local-diagnostic?
              |  |       iana-bfd-types:diagnostic
              |  +--ro remote-diagnostic?
              |  |       iana-bfd-types:diagnostic
              |  +--ro remote-authenticated?         boolean
              |  +--ro remote-authentication-type?
              |  |       iana-bfd-types:auth-type {authentication}?
              |  +--ro detection-mode?               enumeration
              |  +--ro negotiated-tx-interval?       uint32
              |  +--ro negotiated-rx-interval?       uint32
              |  +--ro detection-time?               uint32
              |  +--ro echo-tx-interval-in-use?      uint32
              |          {echo-mode}?
              +--ro sesssion-statistics
                 +--ro create-time?            yang:date-and-time
                 +--ro last-down-time?         yang:date-and-time
                 +--ro last-up-time?           yang:date-and-time
                 +--ro down-count?             uint32
                 +--ro admin-down-count?       uint32
                 +--ro receive-packet-count?   uint64
                 +--ro send-packet-count?      uint64
                 +--ro receive-bad-packet?     uint64
                 +--ro send-failed-packet?     Uint64

D.
           +--rw (interval-config-type)?
           |  +--:(tx-rx-intervals)
           |  |  +--rw desired-min-tx-interval?    uint32
           |  |  +--rw required-min-rx-interval?   uint32
           |  +--:(single-interval)
           |     +--rw min-interval?               uint32

E.

              +--ro sesssion-statistics
              |  +--ro create-time?            yang:date-and-time
              |  +--ro last-down-time?         yang:date-and-time
              |  +--ro last-up-time?           yang:date-and-time
              |  +--ro down-count?             uint32
              |  +--ro admin-down-count?       uint32
              |  +--ro receive-packet-count?   uint64
              |  +--ro send-packet-count?      uint64
              |  +--ro receive-bad-packet?     uint64
              |  +--ro send-failed-packet?     uint64

F.       In notifications:
        +--ro local-discr?                 discriminator
        +--ro remote-discr?                discriminator
        +--ro new-state?                   state
        +--ro state-change-reason?         iana-bfd-types:diagnostic
        +--ro time-of-last-state-change?   yang:date-and-time
        +--ro dest-addr?                   inet:ip-address
        +--ro source-addr?                 inet:ip-address
        +--ro session-index?               uint32
        +--ro path-type?                   identityref

Separate sub-modules for the above could be used to enable cleaner abstractions. The same could augment the modules of sections 2.6-2.10.

Regards
Ravi

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 9 Feb 2018 14:17:51 +0000

+yang doctors

Hi Ravi,
 submodules have proved to be unwieldy and offer little advantage over groupings. I don’t know that we want to crave this model up into submodules. I’ve copied the YANG doctors to assure this is the consensus as there have been submodule debates on the NETMOD list in the past.

Thanks,
Acee

From: rtg-dir <[email-masked]> on behalf of Ravi Singh <[email-masked]>
Date: Friday, February 9, 2018 at 8:36 AM
To: "[email-masked]" <[email-masked]>
Cc: Routing Directorate <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [RTG-DIR] RtgDir review:

Hello,

Details:

Eg.

B.

C.

D.

E.

F.       In notifications:

Regards
Ravi

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Sun, 11 Feb 2018 19:31:32 +0000

Hi Ravi,

There is indeed lots of common information and this was addressed by using groupings.

I am not sure I understand the suggestion to use submodules. A submodule can belong to only 1 module (https://tools.ietf.org/html/rfc7950#section-5.1) so I do not see how using submodules would help (but I could be missing something).

We’ve done what you suggested by defining groupings for the common information, so although you see repetitions in the YANG trees, there is no repetition in the YANG modules.

Regards,
Reshad.

From: "Acee Lindem (acee)" <[email-masked]>
Date: Friday, February 9, 2018 at 9:18 AM
To: Ravi Singh <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, YANG Doctors <[email-masked]>
Subject: Re: [RTG-DIR] RtgDir review:
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Friday, February 9, 2018 at 9:18 AM

+yang doctors

Hi Ravi,

Thanks,
Acee

Hello,

Details:

Eg.

B.

C.

D.

E.

F.       In notifications:

Regards
Ravi

---

From: Ravi Singh <[email-masked]>
Date: Thu, 22 Feb 2018 06:04:56 +0000

Hi Reshad
Thanks for your response.

> We’ve done what you suggested by defining groupings for the common information, so although you see repetitions in the YANG trees, there is no repetition in the YANG modules.

Got it.
Thanks
Ravi

From: Reshad Rahman (rrahman) [mailto:[email-masked]]
Sent: Sunday, February 11, 2018 11:32 AM
To: Acee Lindem (acee) <[email-masked]>; Ravi Singh <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; YANG Doctors <[email-masked]>
Subject: Re: [RTG-DIR] RtgDir review:

Hi Ravi,

I am not sure I understand the suggestion to use submodules. A submodule can belong to only 1 module (https://tools.ietf.org/html/rfc7950#section-5.1<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_rfc7950-23section-2D5.1&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=6ArkE4n20mNZQF6JxrMYwJyAGBWWjzhSIC2O3-fXPV4&m=oDCkyMmWPlFCILjgX6xc441J2zq0hhL8SEs_Hh9zN6I&s=7kls7KDHke9pRPTtdQmrkY7S0DD09PoB_sE1yaqsbGM&e=>) so I do not see how using submodules would help (but I could be missing something).

Regards,
Reshad.

From: "Acee Lindem (acee)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, February 9, 2018 at 9:18 AM
To: Ravi Singh <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, YANG Doctors <[email-masked]<mailto:[email-masked]>>
Subject: Re: [RTG-DIR] RtgDir review:
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Resent-Date: Friday, February 9, 2018 at 9:18 AM

+yang doctors

Hi Ravi,

Thanks,
Acee

From: rtg-dir <[email-masked]<mailto:[email-masked]>> on behalf of Ravi Singh <[email-masked]<mailto:[email-masked]>>
Date: Friday, February 9, 2018 at 8:36 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Routing Directorate <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [RTG-DIR] RtgDir review:

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir<https://urldefense.proofpoint.com/v2/url?u=http-3A__trac.tools.ietf.org_area_rtg_trac_wiki_RtgDir&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=6ArkE4n20mNZQF6JxrMYwJyAGBWWjzhSIC2O3-fXPV4&m=oDCkyMmWPlFCILjgX6xc441J2zq0hhL8SEs_Hh9zN6I&s=XUE05wPGYd0V4GBi_2t1qTr8FNvPFAocvFvGJ6F7qO8&e=>

Details:

Eg.

B.

C.

D.

E.

F.       In notifications:

Regards
Ravi