Subject: [RTG-DIR] RtgDir review: draft-ietf-v6ops-conditional-ras

From: Ravi Singh <[email-masked]>
Date: Mon, 21 May 2018 23:25:16 +0000

Hello, 
I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir 
Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft. 

Document: draft-ietf-v6ops-conditional-ras
Reviewer: Ravi Singh
Review Date: May 21, 2018
Intended Status: Informational                                
Summary: This document is basically ready for publication, but has nits that should be considered prior to publication.

Nits:
1. For readability sake for wider audiences, first usage of acronym in the draft should expand the acronym even though the usage of many of these acronyms is pretty common:
      a. Section 3.1.2: RDNSS, SLAAC, CPE
      b. 3.2.6: ULA
      c. 3.2.7: DAD
      d. 3.3: SDN, RTT

2. Typo corrections:  
     a. POI -> PIO
                3.1.2: 2 occurrences
                3.2.4 & 3.2.7: 2 occurrences each
    b. 3Section .2.6: 
               "algorith" - > "algorithm"

    c. In section 3.1.2:  

         "address selected by a host as described in Section 3.1.2.  However," -> 
         "address selected by a host as described in Section 3.1.1.  However,"
 
   d. Section 3.2.3: typo: quoted section # needs correction.
          " correct uplink based on the source address as described in Section 3.2.1."
           ->
         "correct uplink based on the source address as described in Section 3.1.1."

3.  Section 3.2.5:
     "For simplicity, all topologies below show the ISP uplinks terminated"
     ->
     "For simplicity, all topologies above show the ISP uplinks terminated" ?

4. Section 3.3 & 3.4: the text seems to indicate that this draft if proposing some solution, even though as indicated in this draft's abstract….the solution being referenced is in ietf-rtgwg-enterprise-pa-multihoming and this draft if describing the use of that solution in sample scenarios. Slight rewording of text should help to address this.

Regards
Ravi

---

From: Jen Linkova <[email-masked]>
Date: Wed, 23 May 2018 00:01:43 +1000

Thanks a lot for your review, Ravi!
I'll post the updated version to address your comments later on this
week or at the beginning of the next week.

On Tue, May 22, 2018 at 9:25 AM, Ravi Singh <[email-masked]> wrote:
> Hello,
> I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

-- 
sincerely yours,
Jen Linkova a.k.a Furry
Network Engineer