Subject: Re: [RTG-DIR] [Lsr] RtgDir Review: draft-ietf-isis-segment-routing-msd-15

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 3 Oct 2018 11:42:56 +0000

Hey Bruno, Jeff, Les,

Have we agreed on the precise definition of “label imposition”?

Thanks,
Acee

From: Lsr <[email-masked]> on behalf of Bruno Decraene <[email-masked]>
Date: Wednesday, October 3, 2018 at 4:37 AM
To: Jeff Tantsura <[email-masked]>
Cc: Routing Directorate <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Alvaro Retana <[email-masked]>, "[email-masked]" <[email-masked]>, "Les Ginsberg (ginsberg)" <[email-masked]>, MEURIC Julien IMT/OLN <[email-masked]>
Subject: Re: [Lsr] [RTG-DIR] RtgDir Review: draft-ietf-isis-segment-routing-msd-15

Jeff,

From: Jeff Tantsura [mailto:[email-masked]]
Sent: Tuesday, October 02, 2018 8:28 PM
To: DECRAENE Bruno IMT/OLN; Alvaro Retana; MEURIC Julien IMT/OLN; Les Ginsberg (ginsberg)
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [RTG-DIR] RtgDir Review: draft-ietf-isis-segment-routing-msd-15

Gents,

I’m 100% with Les here, going into platform/asic specifics within this document would inevitably create ambiguity.
Absolutely.
And nobody is asking for this.

Cheers
--Bruno

Cheers,
Jeff
On Oct 2, 2018, 11:20 AM -0700, Les Ginsberg (ginsberg) <[email-masked]>, wrote:

Bruno –

Trimming the thread…

[Les2:] Label imposition is meant to cover both the SWAP operation and the PUSH operation. In the example you provided above where a label stack of “12” is replaced by a label stack of “14,15” the number of labels “imposed” is 2.
[Bruno2] In that case, I definitely think that the discussion was useful and that this point needs to be clarified in the document.
Whether you choose to call that (1 POP, 2 PUSH) or (1 SWAP, 1 PUSH)  or simply a SWAP isn’t relevant here (though it might matter to folks like the RFC 3031 authors).

With that ibn mind, here is proposed text:

“Base MPLS Imposition MSD (BMI-MSD) signals the total number of MPLS
   labels which can be imposed, including all service/transport/special
   labels.  Imposition includes swap and/or push operations.

If the advertising router performs label imposition in the context of
   the ingress interface, it is not possible to meaningfully advertise
   per link values.  In such a case only the Node MSD SHOULD be
   advertised.”

[Bruno2] Given that the term “imposition” does not seem to be defined within the IETF, I would still favor a formal definition not using it. e.g. “BMI-MSD advertises the ability to increase the depth of the label stack by BMI-MSD labels”.
Alternatively, I’d propose the following rewording which seems clearer to me:
OLD: Imposition includes swap and/or push operations.
NEW: A swap operation counts as an imposition of one label; just like one push operation.

[Les3:] This gets into implementation specific issues that I would really like to avoid.
For example, some implementations perform one and only one  “operation”. Conceptually that may involve a swap and a push – but from the internal implementation POV it is simply one operation. And this may be true regardless of how many labels are involved. Other implementations might perform this in several discrete steps. The language we use here should not imply anything about how many labels are associated with a specific operation.

The term “increase” isn’t accurate because in the case of a swap there is no increase, yet the label which is replaced is counted.

https://tools.ietf.org/html/rfc3031#section-3.10 is relevant here.

The term “imposition” is generic – and as Alvaro has pointed out is used in RFC 4221. And the language proposed above does define the relationship between “swap and push” and “imposition”.

I appreciate your desire for clarity – and I am still open to new language – but at this point I still think what I proposed is  the most accurate.

   Les

Thanks,
--Bruno

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc

pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler

a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,

Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;

they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

---

From: <[email-masked]>
Date: Wed, 3 Oct 2018 14:07:13 +0000

Hi Acee,

From: Acee Lindem (acee) [mailto:[email-masked]]

Hey Bruno, Jeff, Les,

Have we agreed on the precise definition of “label imposition”?
Thanks for asking.
Not so far.
We don’t necessarily need to agree on a precision definition of “label imposition”. In my latest email (a few hours ago), I proposed to reuse the phrasing from RFC 3031, which does not use that term. If we are fine with using RFC 3031 terms, that would be fine for me.

Thanks,
--Bruno

Thanks,
Acee

Jeff,

Gents,

Cheers
--Bruno

Cheers,
Jeff

Bruno –

Trimming the thread…

   Les

Thanks,
--Bruno

Thank you.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 3 Oct 2018 21:05:25 +0000

Hi Bruno,

On Oct 3, 2018, at 10:07 AM, [email-masked]<mailto:[email-masked]> wrote:

Hi Acee,

Hey Bruno, Jeff, Les,

Since the MSD type has always been defined in terms of “Imposition” in both the OSPF and IS-IS MSD drafts, I think it would be better to clarify any ambiguities the text Les quotes below.

Of course, we don’t want to get too bogged down in semantics as has happened in the past: https://www.youtube.com/watch?v=-P8IYKxpqG0

Thanks,
Acee

Thanks,
--Bruno

Thanks,
Acee

From: Lsr <[email-masked]<mailto:[email-masked]>> on behalf of Bruno Decraene <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, October 3, 2018 at 4:37 AM
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Cc: Routing Directorate <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Alvaro Retana <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Les Ginsberg (ginsberg)" <[email-masked]<mailto:[email-masked]>>, MEURIC Julien IMT/OLN <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lsr] [RTG-DIR] RtgDir Review: draft-ietf-isis-segment-routing-msd-15

Jeff,

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Gents,

Cheers
--Bruno

Cheers,
Jeff
On Oct 2, 2018, 11:20 AM -0700, Les Ginsberg (ginsberg) <[email-masked]<mailto:[email-masked]>>, wrote:

Bruno –

Trimming the thread…

   Les

Thanks,
--Bruno

Thank you.

_______________________________________________
Lsr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsr

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 3 Oct 2018 21:27:25 +0000

(Hard to follow Acee’s post – especially for entertainment value)

Bruno –

I think that we do want some less awkward text. So I am proposing to add the following into the Introduction:

“Label Imposition is the act of modifying and/or adding labels to the outgoing label stack associated with a packet.
This includes:

o  replacing the label at the top of the label stack with a new label
o  pushing one or more new  labels onto the label stack.

The number of labels imposed is then the sum of the labels which are replaced and the labels which are pushed.
See [RFC3031] for further details.”

The BMI definition then becomes:

   labels.”

Does this work??

    Les

From: Acee Lindem (acee)
Sent: Wednesday, October 03, 2018 2:05 PM
To: Bruno Decraene <[email-masked]>
Cc: Routing Directorate <[email-masked]>; [email-masked]; [email-masked]; Alvaro Retana <[email-masked]>; [email-masked]; Jeff Tantsura <[email-masked]>; Les Ginsberg (ginsberg) <[email-masked]>; MEURIC Julien IMT/OLN <[email-masked]>
Subject: Re: [Lsr] [RTG-DIR] RtgDir Review: draft-ietf-isis-segment-routing-msd-15

Hi Bruno,

Hi Acee,

Hey Bruno, Jeff, Les,

Thanks,
Acee

Thanks,
--Bruno

Thanks,
Acee

Jeff,

Gents,

Cheers
--Bruno

Cheers,
Jeff

Bruno –

Trimming the thread…

   Les

Thanks,
--Bruno

Thank you.

Thank you.

---

From: <[email-masked]>
Date: Thu, 4 Oct 2018 07:56:05 +0000

Les,

Thanks for the proposed text.
It’s crystal clear. It works for me.

--Bruno

From: Les Ginsberg (ginsberg) [mailto:[email-masked]]
Sent: Wednesday, October 03, 2018 11:27 PM
To: Acee Lindem (acee); DECRAENE Bruno IMT/OLN
Cc: Routing Directorate; [email-masked]; [email-masked]; Alvaro Retana; [email-masked]; Jeff Tantsura; MEURIC Julien IMT/OLN
Subject: RE: [Lsr] [RTG-DIR] RtgDir Review: draft-ietf-isis-segment-routing-msd-15

Bruno –

Does this work??

    Les

From: Acee Lindem (acee)

Hi Bruno,

Hi Acee,

Hey Bruno, Jeff, Les,

Thanks,
Acee

Thanks,
--Bruno

Thanks,
Acee

Jeff,

Gents,

Cheers
--Bruno

Cheers,
Jeff

Bruno –

Trimming the thread…

   Les

Thanks,
--Bruno

Thank you.

Thank you.

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 5 Oct 2018 00:14:02 +0000

Bruno/Julien/Benjamin –

V18 of the draft has been published. I believe this addresses all outstanding comments.

Thanx very much for your input.

    Les

From: [email-masked] <[email-masked]>
Sent: Thursday, October 04, 2018 12:56 AM
To: Les Ginsberg (ginsberg) <[email-masked]>; Acee Lindem (acee) <[email-masked]>
Cc: Routing Directorate <[email-masked]>; [email-masked]; [email-masked]; Alvaro Retana <[email-masked]>; [email-masked]; Jeff Tantsura <[email-masked]>; MEURIC Julien IMT/OLN <[email-masked]>
Subject: RE: [Lsr] [RTG-DIR] RtgDir Review: draft-ietf-isis-segment-routing-msd-15

Les,

--Bruno

Cc: Routing Directorate; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Alvaro Retana; [email-masked]<mailto:[email-masked]>; Jeff Tantsura; MEURIC Julien IMT/OLN

Bruno –

Does this work??

    Les

From: Acee Lindem (acee)
Sent: Wednesday, October 03, 2018 2:05 PM
To: Bruno Decraene <[email-masked]<mailto:[email-masked]>>
Cc: Routing Directorate <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Alvaro Retana <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; Les Ginsberg (ginsberg) <[email-masked]<mailto:[email-masked]>>; MEURIC Julien IMT/OLN <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lsr] [RTG-DIR] RtgDir Review: draft-ietf-isis-segment-routing-msd-15

Hi Bruno,

Hi Acee,

Hey Bruno, Jeff, Les,

Thanks,
Acee

Thanks,
--Bruno

Thanks,
Acee

Jeff,

Gents,

Cheers
--Bruno

Cheers,
Jeff

Trimming the thread…

   Les

Thanks,
--Bruno

Thank you.

Thank you.

Thank you.

---

From: <[email-masked]>
Date: Fri, 5 Oct 2018 07:15:14 +0000

Les,

V18 addresses all my comments.

Thank you, Les, for the discussion and for reflecting the outcome in the draft.

--Bruno

From: Les Ginsberg (ginsberg) [mailto:[email-masked]]
Sent: Friday, October 05, 2018 2:14 AM
To: DECRAENE Bruno IMT/OLN; Acee Lindem (acee); MEURIC Julien IMT/OLN; Benjamin Kaduk
Cc: Routing Directorate; [email-masked]; [email-masked]; Alvaro Retana; [email-masked]; Jeff Tantsura; MEURIC Julien IMT/OLN
Subject: RE: [Lsr] [RTG-DIR] RtgDir Review: draft-ietf-isis-segment-routing-msd-15

Bruno/Julien/Benjamin –

    Les

Les,

--Bruno

Bruno –

Does this work??

    Les

From: Acee Lindem (acee)

Hi Bruno,

Hi Acee,

Hey Bruno, Jeff, Les,

Thanks,
Acee

Thanks,
--Bruno

Thanks,
Acee

Jeff,

Gents,

Cheers
--Bruno

Cheers,
Jeff

Trimming the thread…

   Les

Thanks,
--Bruno

Thank you.

Thank you.

Thank you.

---

From: Julien Meuric <[email-masked]>
Date: Fri, 5 Oct 2018 18:18:20 +0200

Hi Les,

Indeed, this version resolves my initial comments.

Thank you.

Julien

Oct. 05, 2018 - [email-masked]:

Bruno/Julien/Benjamin
–

V18
of the draft has been published. I believe this addresses
all outstanding comments.

Thanx
very much for your input.

Les

From:
[email-masked]
<[email-masked]>

Les,

Thanks
for the proposed text.

It’s
crystal clear. It works for me.

--Bruno

(Hard
to follow Acee’s post – especially for entertainment
value)

Bruno
–

I
think that we do want some less awkward text. So I am
proposing to add the following into the Introduction:

“Label
Imposition is the act of modifying and/or adding
labels to the outgoing label stack associated with a
packet.

This
includes:

o
replacing the label at the top of the label stack
with a new label

o
pushing one or more new  labels onto the label stack.

The
number of labels imposed is then the sum of the labels
which are replaced and the labels which are pushed.

See
[RFC3031] for further details.”

The
BMI definition then becomes:

“Base
MPLS Imposition MSD (BMI-MSD) signals the total number
of MPLS

labels which can be imposed, including all
service/transport/special

labels.”

Does
this work??

Les

From:
Acee Lindem (acee)

Hi Bruno,

On Oct 3, 2018, at 10:07 AM,
[email-masked] wrote:

Hi
Acee,

From: Acee
Lindem (acee) [mailto:[email-masked]]

Hey
Bruno, Jeff, Les,

Have
we agreed on the precise definition of
“label imposition”?

Thanks
for asking.

Not
so far.

We
don’t necessarily need to agree on a
precision definition of “label imposition”.
In my latest email (a few hours ago), I
proposed to reuse the phrasing from RFC
3031, which does not use that term. If we
are fine with using RFC 3031 terms, that
would be fine for me.

Since the MSD type has always
been defined in terms of “Imposition” in both the
OSPF and IS-IS MSD drafts, I think it would be
better to clarify any ambiguities the text Les
quotes below.

Of course, we don’t want to get
too bogged down in semantics as has happened in the
past:
https://www.youtube.com/watch?v=-P8IYKxpqG0

Thanks,

Acee

Thanks,

--Bruno

Thanks,

Acee

From: Lsr
<[email-masked]>
on behalf of Bruno Decraene <[email-masked]>

Date: Wednesday,
October 3, 2018 at 4:37 AM

Jeff,

From: Jeff
Tantsura [mailto:[email-masked]]

Sent: Tuesday,
October 02, 2018 8:28 PM

Gents,

I’m
100% with Les here, going into
platform/asic specifics within this
document would inevitably create
ambiguity.

Absolutely.

And
nobody is asking for this.

Cheers

--Bruno

Cheers,

Jeff

On Oct
2, 2018, 11:20 AM -0700, Les Ginsberg
(ginsberg) <[email-masked]>,
wrote:

Bruno
–

Trimming
the thread…

[Les2:]
Label imposition is
meant to cover both
the SWAP operation
and the PUSH
operation. In the
example you provided
above where a label
stack of “12” is
replaced by a label
stack of “14,15” the
number of labels
“imposed” is 2.

[Bruno2]
In that case, I
definitely think that
the discussion was
useful and that this
point needs to be
clarified in the
document.

Whether
you choose to call
that (1 POP, 2 PUSH)
or (1 SWAP, 1 PUSH)
or simply a SWAP
isn’t relevant here
(though it might
matter to folks like
the RFC 3031
authors).

With
that ibn mind, here
is proposed text:

“Base
MPLS Imposition MSD
(BMI-MSD) signals
the total number of
MPLS

labels which can be
imposed, including
all
service/transport/special

labels.  Imposition
includes swap and/or
push operations.

If
the advertising
router performs
label imposition in
the context of

the ingress
interface, it is not
possible to
meaningfully
advertise

per link values.  In
such a case only the
Node MSD SHOULD be

advertised.”

[Bruno2]
Given that the term
“imposition” does not
seem to be defined
within the IETF, I would
still favor a formal
definition not using it.
e.g. “BMI-MSD advertises
the ability to increase
the depth of the label
stack by BMI-MSD
labels”.

Alternatively,
I’d propose the
following rewording
which seems clearer to
me:

OLD: Imposition
includes swap and/or
push operations.

NEW:
A swap operation counts
as an imposition of one
label; just like one
push operation.

[Les3:]
This gets into
implementation
specific issues that
I would really like
to avoid.

For
example, some
implementations
perform one and only
one  “operation”.
Conceptually that
may involve a swap
and a push – but
from the internal
implementation POV
it is simply one
operation. And this
may be true
regardless of how
many labels are
involved. Other
implementations
might perform this
in several discrete
steps. The language
we use here should
not imply anything
about how many
labels are
associated with a
specific operation.

The
term “increase”
isn’t accurate
because in the case
of a swap there is
no increase, yet the
label which is
replaced is counted.

https://tools.ietf.org/html/rfc3031#section-3.10 is
relevant here.

The
term “imposition” is
generic – and as
Alvaro has pointed
out is used in RFC
4221. And the
language proposed
above does define
the relationship
between “swap and
push” and
“imposition”.

I
appreciate your
desire for clarity –
and I am still open
to new language –
but at this point I
still think what I
proposed is  the
most accurate.

Les

Thanks,

--Bruno