Subject: Re: [RTG-DIR] RtgDir review: draft-ietf-6lo-deadline-time-03

From: Charlie Perkins <[email-masked]>
Date: Wed, 6 Feb 2019 17:42:07 -0800

Hello Lijo and all,

I reckon we need to pick a new time representation.  If no one objects 
to having the time representations take up more bits, then we can just 
make the origination field mandatory and the deadline time into a delta, 
as suggested.  I have an alternative idea but I don't think it has been 
used before and so people might not like dealing with an entirely new 
time format.

We could probably keep the ASN option.

What do you think?

Regards,
Charlie P.

On 1/7/2019 6:24 AM, Dan Frost wrote:
> Hello,
>
> I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ​https://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir
>
> Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.
>
> Document: draft-ietf-6lo-deadline-time-03
> Reviewer: Dan Frost
> Review Date: 2019-01-07
> Intended Status: Standards Track
>
> Summary:
>
> I have some minor concerns about this document that I think should be resolved before publication.
>
> Comments:
>
> This draft specifies a mechanism for including packet delivery deadline times, in the form of an elective 6LoWPAN routing header, for use in low-power and lossy networks with real-time requirements for end-to-end delay. Routers can use packet deadline times to make informed scheduling decisions or discard overdue packets. The timing metadata can also be useful for performance monitoring and diagnostics.
>
> The draft is, for the most part, clear, and the writing quality is good.
>
> Major Issues:
>
> No major issues found.
>
> Minor Issues:
>
> The main issue I see with the spec is the way timestamp formats are specified with the TU (time units) field. The possible values for this field include "seconds" and "microseconds". This is unusual, particularly in combination with the EXP field, which leads to some time values having multiple representations. And when representing absolute timestamps, we'd usually use well-known formats like NTP or IEEE 1588. The draft probably needs to rework the timestamp representation options along these lines, including specifying a single default format for interoperability (we did this in RFC 6374, for example). An important consideration here is the typical capabilities of the kinds of devices expected to implement this spec; many devices only have good support for one standard timestamp format. Industrial devices, a specfiic target of this spec, usually expect IEEE 1588.
>
> Making the Origination Time non-optional and specifying the Deadline Time as a delta could also be considered.
>
> Is the D flag (must drop if deadline exceeded) really necessary? Should the semantics not just be to drop the overdue packet if there's congestion, and forward it otherwise?
>
> Nits:
>
> Section 4: s/Whenever the packets crosses into a network/Whenever a packet crosses into a network/
>
> Cheers,
> -d
>

---

From: Lijo Thomas <[email-masked]>
Date: Thu, 7 Feb 2019 17:59:35 +0530 (IST)

Hi Charlie ,

Yup, we need to have a some round of discussion so that we could arrive at a
conclusion.

The problem with the current reviews what I felt, was that they put some
comments and doesn't guide a minimum level to proceed further.

But the point is that if we cant streamline our bits usage, it wont be really
useful for the real implementations.

Also making origination time default and adding delta would also be costlier
when we compared to passing  deadline time only. I agree there is a trade off.

I have shared an earlier document  indicating the comments to address and some
solutions after some discussions, hence kindly go through if it is convenient.

Bit confused to arrive at a conclusion while reading all the comments we
received.

Hence I request you to suggest the best possible way to move forward.

Happy to receive your further inputs.

Thanks & Regards
Lijo Thomas

On February 7, 2019 at 7:12 AM Charlie Perkins <[email-masked]>
wrote:
> > I have been selected as the Routing Directorate reviewer for this draft. The
> > Routing Directorate seeks to review all routing or routing-related drafts as
> > they pass through IETF last call and IESG review, and sometimes on special
> > request. The purpose of the review is to provide assistance to the Routing
> > ADs. For more information about the Routing Directorate, please see
> > https://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir
> >
> > Although these comments are primarily for the use of the Routing ADs, it
> > would be helpful if you could consider them along with any other IETF Last
> > Call comments that you receive, and strive to resolve them through
> > discussion or by updating the draft.
> >
> > This draft specifies a mechanism for including packet delivery deadline
> > times, in the form of an elective 6LoWPAN routing header, for use in
> > low-power and lossy networks with real-time requirements for end-to-end
> > delay. Routers can use packet deadline times to make informed scheduling
> > decisions or discard overdue packets. The timing metadata can also be useful
> > for performance monitoring and diagnostics.
> >
> > The main issue I see with the spec is the way timestamp formats are
> > specified with the TU (time units) field. The possible values for this field
> > include "seconds" and "microseconds". This is unusual, particularly in
> > combination with the EXP field, which leads to some time values having
> > multiple representations. And when representing absolute timestamps, we'd
> > usually use well-known formats like NTP or IEEE 1588. The draft probably
> > needs to rework the timestamp representation options along these lines,
> > including specifying a single default format for interoperability (we did
> > this in RFC 6374, for example). An important consideration here is the
> > typical capabilities of the kinds of devices expected to implement this
> > spec; many devices only have good support for one standard timestamp format.
> > Industrial devices, a specfiic target of this spec, usually expect IEEE
> > 1588.
> >
> > Is the D flag (must drop if deadline exceeded) really necessary? Should the
> > semantics not just be to drop the overdue packet if there's congestion, and
> > forward it otherwise?
> >
> > Nits:
> >
------------------------------------------------------------------------------------------------------------
[ C-DAC is on Social-Media too. Kindly follow us at:
Facebook: https://www.facebook.com/CDACINDIA & Twitter: @cdacindia ]

This e-mail is for the sole use of the intended recipient(s) and may
contain confidential and privileged information. If you are not the
intended recipient, please contact the sender by reply e-mail and destroy
all copies and the original message. Any unauthorized review, use,
disclosure, dissemination, forwarding, printing or copying of this email
is strictly prohibited and appropriate legal action will be taken.
------------------------------------------------------------------------------------------------------------

---

From: Charlie Perkins <[email-masked]>
Date: Fri, 8 Feb 2019 21:16:57 -0800

Hello Dan,

We could go with the formats shown in 
draft-ietf-ntp-packet-timestamps-05.txt, or a format derived from them 
by scaling down to fewer bits.  Do we need to support both NTP and PTP 
versions?  I think we should also continue to support ASN as a time unit.

There has been discussion about whether or not the 'D' bit is needed, 
and so far the balance of the discussion seems to indicate that it is 
O.K. to keep it.  However, that could still change.

Thanks much for your review!

We will soon have a specific proposal for a new Deadline Time and 
Origination Time (DT and OT) format based on discussion about the above 
points.  It will somehow be derived from the formats shown in the NTP 
draft document.

Regards,
Charlie P.