Subject: [RTG-DIR] Harmful consequences of Postel's principle

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Tue, 7 May 2019 16:11:22 +0000

Hi,

Not sure if this document caught your attention as I think it is a bit of a misnomer for the title. The IAB are looking to publish it as an IAB document.

I'm going to comment on it as I think to make a generic statement that Postel's principle is harmful is harmful.

Interested in your thoughts-
Deborah

-----Original Message-----
From: IAB <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, May 06, 2019 10:40 PM
To: [email-masked]
Cc: [email-masked]
Subject: [IAB] I-D Action: draft-iab-protocol-maintenance-03.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Internet Architecture Board IETF of the IETF.

        Title           : The Harmful Consequences of the Robustness Principle
        Author          : Martin Thomson
	Filename        : draft-iab-protocol-maintenance-03.txt
	Pages           : 11
	Date            : 2019-05-06

Abstract:
   Jon Postel's famous statement of "Be liberal in what you accept, and
   conservative in what you send" is a principle that has long guided
   the design and implementation of Internet protocols.  The posture
   this statement advocates promotes interoperability in the short term,
   but can negatively affect the protocol ecosystem over time.  For a
   protocol that is actively maintained, the robustness principle can,
   and should, be avoided.

The IETF datatracker status page for this draft is:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Diab-2Dprotocol-2Dmaintenance_&d=DwICaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=VZUxXboWY44rtZcmcswiLQuQ8TmW6g7F7Azgl-j0amw&s=Fxp9wRoCVRJ_8BZBzY1MoExjRlVCegLbFtq8txcr6F8&e=

There are also htmlized versions available at:
https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Diab-2Dprotocol-2Dmaintenance-2D03&d=DwICaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=VZUxXboWY44rtZcmcswiLQuQ8TmW6g7F7Azgl-j0amw&s=aCbWfZ2WFHlTnh7WeiI8hJ_N04EoyW90y-Wuml8gLuA&e=
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Diab-2Dprotocol-2Dmaintenance-2D03&d=DwICaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=VZUxXboWY44rtZcmcswiLQuQ8TmW6g7F7Azgl-j0amw&s=lBVwS9yzx9lBmBEMA0cIidmh_hgRqGFclGMt6iNTPfw&e=

A diff from the previous version is available at:
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Diab-2Dprotocol-2Dmaintenance-2D03&d=DwICaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=VZUxXboWY44rtZcmcswiLQuQ8TmW6g7F7Azgl-j0amw&s=JdV3Cux54CLr3GLrhc4SapVMu0mBchg-65xKrwqYPCo&e=

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=DwICaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=VZUxXboWY44rtZcmcswiLQuQ8TmW6g7F7Azgl-j0amw&s=FA3-28RGBPX6oeQnIR42NBpfekSVh-BU7wyHCkuesdA&e=

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 7 May 2019 17:42:29 +0100

I read it some time ago. 

I am in no way convinced that publishing this in the IAB stream is in any way going to have a positive impact on the way protocols are designed or on the image of the IETF.

It left me remembering that the Internet routes around errors. So I am also not so worried about that IAB publishing it. 

It is also possible that the authors do not completely understand the robustness principle.

Best,
Adrian

-----Original Message-----
From: BRUNGARD, DEBORAH A <[email-masked]> 
Sent: 07 May 2019 17:11
To: [email-masked]; [email-masked]
Subject: Harmful consequences of Postel's principle

Hi,

-----Original Message-----
From: IAB <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, May 06, 2019 10:40 PM
To: [email-masked]
Cc: [email-masked]
Subject: [IAB] I-D Action: draft-iab-protocol-maintenance-03.txt

Abstract: