Subject: [RTG-DIR] RtgDir Review: draft-ietf-mboned-ieee802-mcast-problems-09

From: Tal Mizrahi <[email-masked]>
Date: Tue, 15 Oct 2019 11:33:28 +0300

Hello,

I have been selected as the Routing Directorate reviewer for this draft.
The Routing Directorate seeks to review all routing or routing-related
drafts as they pass through IETF last call and IESG review, and sometimes
on special request. The purpose of the review is to provide assistance to
the Routing ADs. For more information about the Routing Directorate, please
see http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it
would be helpful if you could consider them along with any other IETF Last
Call comments that you receive, and strive to resolve them through
discussion or by updating the draft.

Document: draft-ietf-mboned-ieee802-mcast-problems-09
Reviewer: Tal Mizrahi
Review Date: 2019-10-15
Intended Status: Informational

Summary:
========
I have some minor concerns about this document that I think should be
resolved before publication.

Comments:
=========
- The draft is clear and well-written.
- The scope of the document should be clearly specified in the abstract and
introduction. The title is a bit misleading, suggesting that the scope is
IEEE 802 wireless media in general, while most of the document is focused
on 802.11, with Section 6 briefly discussing non-dot-11 standards. Please
clarify that the document is focused on 802.11.
- Throughout the document there is no clear distinction between multicast
and broadcast. Please add an explanation about whether there is a
difference between how IEEE 802.11 handles broadcast vs. multicast.
Throughout the document: please be clear about whether you are referring to
multicast, broadcast or to both.
- The Security Considerations section needs more work. For example:
  - "This document does not introduce or modify any security mechanisms." -
while this is true, the reader expects to have a brief overview of the
security considerations / challenges related to multicast in 802.11
networks.
  - "As noted in [group_key]..." - please add some brief background about
how group keys are used in 802.11.
- "Since typically there are no ACKs for multicast" - please clarify what
you mean by 'typically'.

Nits:
=====
- The [group_key] reference includes an extra "".
- Section 7: "will provide" ==> "provides"
- "mimo" ==> "MIMO"
- "reciever" ==> "receiver"

Thanks,
Tal Mizrahi.

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 15 Oct 2019 08:51:50 +0000

Thank you Tal for your valuable review. As the responsible AD for this draft, I appreciate the time spent on the review.

I am confident that the authors will incorporate your comments

Regards

-éric

From: ietf <[email-masked]> on behalf of Tal Mizrahi <[email-masked]>
Date: Tuesday, 15 October 2019 at 10:34
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, IETF <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RtgDir Review: draft-ietf-mboned-ieee802-mcast-problems-09

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir<http://trac..tools.ietf.org/area/rtg/trac/wiki/RtgDir>

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Summary:
========
I have some minor concerns about this document that I think should be resolved before publication.

Comments:
=========
- The draft is clear and well-written.
- The scope of the document should be clearly specified in the abstract and introduction. The title is a bit misleading, suggesting that the scope is IEEE 802 wireless media in general, while most of the document is focused on 802.11, with Section 6 briefly discussing non-dot-11 standards. Please clarify that the document is focused on 802.11.
- Throughout the document there is no clear distinction between multicast and broadcast. Please add an explanation about whether there is a difference between how IEEE 802.11 handles broadcast vs. multicast. Throughout the document: please be clear about whether you are referring to multicast, broadcast or to both.
- The Security Considerations section needs more work. For example:
  - "This document does not introduce or modify any security mechanisms." - while this is true, the reader expects to have a brief overview of the security considerations / challenges related to multicast in 802.11 networks.
  - "As noted in [group_key]..." - please add some brief background about how group keys are used in 802.11.
- "Since typically there are no ACKs for multicast" - please clarify what you mean by 'typically'.

Nits:
=====

Thanks,
Tal Mizrahi.