Subject: Re: [RTG-DIR] RtgDir Review: draft-ietf-detnet-mpls-over-udp-ip

From: Balázs Varga A <[email-masked]>
Date: Tue, 7 Jan 2020 14:43:26 +0000

Hi Harish,

Many thanks for your review comments/nits.
Sorry for the delay caused by the holiday season, reactions are coming soon.

Many thanks & Cheers
Bala'zs

-----Original Message-----
From: Harish Sitaraman <[email-masked]> 
Sent: Sunday, December 22, 2019 8:03 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RtgDir Review: draft-ietf-detnet-mpls-over-udp-ip

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document: draft-ietf-detnet-mpls-over-udp-ip-04.txt
Reviewer: Harish Sitaraman
Review Date: Dec 22, 2019
IETF LC End Date: date-if-known
Intended Status: Standards Track

Summary:
I have some minor concerns about this document that I think should be resolved before publication.

Comments:
The document is concise and focussed. I'm not as familiar with the work of the DetNet WG so I quickly skimmed through some of the related drafts.

Major Issues:
No major issues found.

Minor Issues:
Section 1, last paragraph:
"These requirements are satisfied by the DetNet over MPLS Encapsulation described in [I-D.ietf-detnet-mpls] and they are partly satisfied by the DetNet IP data plane defined in [I-D.ietf-detnet-ip]"

Please explicitly mention which subset of the requirements are satisfied by ietf-detnet-ip since the text mentions "partly satisfied"?
For MPLS, it seems apparent since prior to listing the requirements, the text says "(these are a subset of the requirements for MPLS encapsulation listed in [I-D.ietf-detnet-mpls])".

Section 3:
"In case of aggregates the A-Label is treated as an S-Label and it too is not modified."
I couldn't understand the usage of "aggregates" here - Is this referring to A-label used only at the aggregation end-point but not as dis-aggregation end-point? If there is not distinction, the maybe A-label can be clubbed into the previous sentence as not being modified.

Section 4:
"The headers for each outgoing packet MUST be formatted according to the configuration information and as defined in [RFC7510], with one exception. Note that the UDP Source Port value MUST be set to uniquely identify the DetNet flow."

The MUST in the first sentence above is used along with an exception, which I think the next sentence "Note that..." clarifies on how the source port should be set. Would it be possible to remove "with one exception" and stitch the two sentences together to be more more precise?

"This includes QoS related traffic treatment." - I assume this is IP ToS/DSCP and not MPLS EXP? Is traffic treatment relevant for receive processing in the next paragraph?

Section 5:
"e.g., via the controller or management plane"
Would it be better to use "...via the controller plane [RFC8655]"
since the next paragraph starts using controller plane?

Nits:
Section 4:
"To support receive processing an implementation" - add a comma after 'processing'. It might be preferable to replace "receive processing"
(I noticed a prior use in the DetNet MPLS draft and not in the base
RFC) with "To support processing incoming DetNet MPLS over UDP/IP encapsulation..." to be specific.

Section 4:
The packet MUST then be handed as
                                           ^^^^^^^ Section 5:
multiple sets of UPD/IP information
                          ^^^^
needed to provided the traffic treatment => s/provided/provide
                 ^^^^^^^^
Section 9,  References:
Re-run to pull in latest versions of drafts.

--
Harish

---

From: Balázs Varga A <[email-masked]>
Date: Wed, 8 Jan 2020 15:44:26 +0000

Hi Harish,

Many thanks for the review. Proposed resolutions are described below (marked with "<Balazs>").
We will start to update the text if reactions are OK with You.

Thanks & Cheers
Bala'zs

-----Original Message-----
From: Balázs Varga A 
Sent: Tuesday, January 7, 2020 3:43 PM
To: Harish Sitaraman <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: RtgDir Review: draft-ietf-detnet-mpls-over-udp-ip

Hi Harish,

Many thanks & Cheers
Bala'zs

-----Original Message-----
From: Harish Sitaraman <[email-masked]> 
Sent: Sunday, December 22, 2019 8:03 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RtgDir Review: draft-ietf-detnet-mpls-over-udp-ip

Hello,

Summary:

Comments:

Major Issues:
No major issues found.

Minor Issues:

<Balazs> Partly satisfied means that requirement 2 and 3 is not fulfilled. Text will be changed to " These requirements are satisfied by the DetNet over MPLS Encapsulation described in [I-D.ietf-detnet-mpls] and they are partly satisfied (requirement 1 and 4) by the DetNet IP data plane defined in [I-D.ietf-detnet-ip]".

Section 3:

<Balazs> A-label is used at both at the aggregation and deaggregation endpoints. (See also explanation in 2.2. Abbreviations). Text will be changed as "A-Label (if present) is not modified as well."

Section 4:

<Balazs> OK, sentences will be collapsed. Text will be changed as "The headers for each outgoing packet MUST be formatted according to the configuration information and as defined in [RFC7510], and the UDP Source Port value MUST be set to uniquely identify the DetNet flow."

<Balazs> Yes, your assumption is correct, it is IP ToS/DSCP. And no, not relevant for receive processing.

Section 5:

<Balazs> OK. Text will be changed to "...via the controller plane [RFC8655]"

Nits:
Section 4:
"To support receive processing an implementation" - add a comma after 'processing'. It might be preferable to replace "receive processing"
(I noticed a prior use in the DetNet MPLS draft and not in the base RFC) with "To support processing incoming DetNet MPLS over UDP/IP encapsulation..." to be specific.
<Balazs> OK. Text will be changed to " To support processing incoming DetNet MPLS over UDP/IP encapsulation, an implementation ... "

Section 4:
The packet MUST then be handed as
                                           ^^^^^^^ 
<Balazs> OK. Text will be changed to " The packet MUST then be handled as"

Section 5:
multiple sets of UPD/IP information
                          ^^^^
<Balazs> OK. Text will be changed. 

needed to provided the traffic treatment => s/provided/provide
                 ^^^^^^^^
<Balazs> OK. Text will be changed to " needed to provide the traffic treatment "

Section 9,  References:
<Balazs> OK.

--
Harish