Subject: [RTG-DIR] RtgDir review: draft-ietf-i2rs-yang-l2-network-topology-13.txt

From: Stig Venaas <[email-masked]>
Date: Wed, 24 Jun 2020 10:07:23 -0700

Hello,

I have been selected as the Routing Directorate reviewer for this
draft. The Routing Directorate seeks to review all routing or
routing-related drafts as they pass through IETF last call and IESG
review, and sometimes on special request. The purpose of the review is
to provide assistance to the Routing ADs. For more information about
the Routing Directorate, please see
http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs,
it would be helpful if you could consider them along with any other
IETF Last Call comments that you receive, and strive to resolve them
through discussion or by updating the draft.

Document: draft-ietf-i2rs-yang-l2-network-topology-13.txt
Reviewer: Stig Venaas
Review Date: 2020-06-24
IETF LC End Date: 2020-06-25
Intended Status: Standards Track

Summary:
This document is basically ready for publication, but has nits that
should be considered prior to publication.

Comments:
The document is well written and easy to read. I only found some minor
nits that should be taken care of.

Major Issues:
No major issues found.

Minor Issues:
No minor issues found.

Nits:

The idnits tool found some nits; regarding references in particular.

There may be some minor model issues, tracker says: Yang Validation 9
errors, 2 warnings.

The abstract is rather short, I think it would be worth going into a
little more detail.

In Introduction “A sample example” should maybe just be “An example”?

For grouping l2-network-type, shouldn’t “indicates” be capitalized?
      presence "indicates L2 Network";

For leaf maximum-frame-size, missing space before PPP
      if L2 frame is other type (e.g.,PPP), the L2

For l2-termination-point-type, leaf tag, should say “is supported”
      "Defines whether lag is support or not.";

In the security considerations, should be “defines”
      The Layer 2 topology module define

In Appendix A, should say “represents”.
      implementations, a corresponding companion module is defined that
      represent the operational state of layer 2 network topologies.  The

Regards,
Stig

---

From: <[email-masked]>
Date: Wed, 24 Jun 2020 18:13:33 +0000

Hi Stig, 

Thank you for the review. These nits will be fixed in the next iteration. 

As per this comment: 

"There may be some minor model issues, tracker says: Yang Validation 9 errors, 2 warnings." 

Actually, this is an issue of the IETF datatracker that only populates in IETF-defined modules. In particular, IEEE-related modules are not populated in as revealed by the error message:

==
[email-masked]:31: error: module "ieee802-dot1q-types" not found in search path
==

Unless I'm mistaken, Sue has reported this issue in the write-up. Will look further on the warnings, though. 

Cheers,
Med

> -----Message d'origine-----
> De : Stig Venaas [mailto:[email-masked]]
> Envoyé : mercredi 24 juin 2020 19:07
> À : <[email-masked]>
> Cc : [email-masked]; draft-ietf-i2rs-yang-l2-network-
> [email-masked]; [email-masked]
> Objet : RtgDir review: draft-ietf-i2rs-yang-l2-network-topology-13.txt
> 
> Hello,
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 24 Jun 2020 15:24:37 -0400

Med: 

I did report the issue in the write-up, and the Tools people said they were working on it. 

Sue 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, June 24, 2020 2:14 PM
To: Stig Venaas; <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: RtgDir review: draft-ietf-i2rs-yang-l2-network-topology-13.txt

Hi Stig, 

As per this comment: 

==
[email-masked]:31: error: module "ieee802-dot1q-types" not found in search path ==

Cheers,
Med

> De : Stig Venaas [mailto:[email-masked]] Envoyé : mercredi 24 juin 
> 2020 19:07 À : <[email-masked]> Cc : [email-masked]; 
> draft-ietf-i2rs-yang-l2-network- [email-masked]; [email-masked] 

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.