Subject: [secdir] FNV web site

From: Paul Hoffman <[email-masked]>
Date: Tue, 23 Mar 2010 12:44:00 -0700

<http://isthe.com/chongo/tech/comp/fnv/>

--Paul Hoffman, Director
--VPN Consortium

---

From: Alan DeKok <[email-masked]>
Date: Tue, 23 Mar 2010 12:47:36 -0700

> <http://isthe.com/chongo/tech/comp/fnv/>

  If hash distribution matters, see:

http://sites.google.com/site/murmurhash/avalanche
...
This is why you probably shouldn't use FNV. Both low bits of the hash
and end bits of the key aren't thorougly mixed.
...

  If hash distributions don't matter, FNV is very fast.

  Alan DeKok.

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 23 Mar 2010 15:51:50 -0400

So, couldn't you just use it to compute twice as many hash bits as you need
and then xor the top and bottom half of the output to fix this flaw?

Donald
=============================
Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
155 Beaver Street   +1-508-634-2066 (home)
Milford, MA 01757 USA
[email-masked]

On Tue, Mar 23, 2010 at 3:47 PM, Alan DeKok <[email-masked]>wrote:

> _______________________________________________
> secdir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/secdir
>

---

From: Stefan Santesson <[email-masked]>
Date: Mon, 29 Mar 2010 11:31:53 +0100

I assume that the result for the modified FNV is the FNV-1a.

I would suggest using the FNV-1a over FNV-1 since FNV-1 has the downside
that the last octet to hash only influence the lowest 8 bits of hash.

The result for FNV-1a seems OK.

/Stefan