Subject: [secdir] SecDir review of draft-ietf-sieve-notify-presence-02

From: Stefan Santesson <[email-masked]>
Date: Sat, 13 Nov 2010 00:08:06 +0100

I have reviewed this document as part of the security directorate's  ongoing
effort to review all IETF documents being processed by the IESG.  These
comments were written primarily for the benefit of the
security area directors.  Document editors and WG chairs should treat these
comments just like any other last call comments.

This draft seems short well written and to the point.
However, the security considerations section seems to be on the short side
and I'm wandering if all relevant security issues really are covered.

One thing that strikes me as possibly relevant is if this in any way can be
a means (in some variants of it's use) through which a spammer can gain
information about the status of the recipient.

/Stefan Santesson

---

From: Barry Leiba <[email-masked]>
Date: Sun, 14 Nov 2010 08:49:56 +0800

Thanks for the review, Stefan.

> information about the status of the recipient.

We had thought of that, but I thought enough was said.  Probably not,
so I intend to add this paragraph to the security considerations,
already in my working copy:
---
In some situations, scripts may act on some of the recipient's
presence information that the sender of the triggering message
is not allowed to see.  This can be a benefit to the recipient
in many cases, but it can also present an opportunity for a
sender to use messages to probe the recipient's presence (if,
for example, messages sometimes result in auto-replies, and
sometimes do not).  Script authors should take care in
considering this aspect of presence-triggered actions.
---

Does that address your concern adequately?

Barry