Subject: [secdir] secdir review of draft-ietf-sipcore-keep-10.txt

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 21 Dec 2010 09:54:47 +0100

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the
IESG.  These comments were written primarily for the benefit of the
security area directors.  Document editors and WG chairs should treat
these comments just like any other last call comments.

This document discusses how to negotiate the usage of keep-alive
messages using a new SIP "keep" Via header field. The document appears
to be well worked out and the security considerations seem to be
adequate. I spotted to mostly editorial nits in the security
considerations:

a) [...]  This specification does not specify a connection
   reuse mechanism, and it does it address security issues related to
   connection reuse.  [...]

   s/it does it/it does not/

b) [...]  They do not instruct the enity to
   place a value in a "keep" parameter of any request it forwards.  [...]

   s/enity/entity/

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 21 Dec 2010 11:33:37 +0100

Hi Juergen,

Thanks for your comments! I will do the changes as suggested.

Regards,

Christer

> -----Original Message-----
> From: Juergen Schoenwaelder 
> [mailto:[email-masked]] 
> Sent: 21. joulukuuta 2010 10:55
> To: [email-masked]; [email-masked]; 
> [email-masked]
> Subject: secdir review of draft-ietf-sipcore-keep-10.txt
> 
> I have reviewed this document as part of the security 
> directorate's ongoing effort to review all IETF documents 
> being processed by the IESG.  These comments were written 
> primarily for the benefit of the security area directors.  
> Document editors and WG chairs should treat these comments 
> just like any other last call comments.
> 
> This document discusses how to negotiate the usage of 
> keep-alive messages using a new SIP "keep" Via header field. 
> The document appears to be well worked out and the security 
> considerations seem to be adequate. I spotted to mostly 
> editorial nits in the security
> considerations:
>